Apache will nur SSL Verbindungen

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache will nur SSL Verbindungen

Postby riedere » 02. July 2005 20:04

LAMPP läuft schon länger auf diesem aurox.
Nun habe ich virtual Host eingestellt kann aber die Seiten nur mit https erreichen.
Im Log steht VirtualHost mixing *:80 Ports and non -* Ports are not allowed.
Ich möchte eine Seite mit SSL die anderen jedoch normal erreichen.
riedere
 
Posts: 29
Joined: 09. October 2004 16:08
Location: Zürich

Postby deepsurfer » 03. July 2005 09:24

poste mal deine VHOST einträge (eventuelle Namen als domain1.de etc. ändern, für IPs nimmst du einfach am besten 192.168.0.1)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

vhost Abschnitt

Postby riedere » 03. July 2005 10:27

Der Server hat eine öffentliche IP
Die virtuellen Hosts sind im DNS eingetragen
Eingentlich wollte ich dass nur die Subdomain service.itemashop.ch mit https erreichbar ist, alle anderen virtuellen normal mit http


in sssl.conf:
Listen 443


in httpd.conf:

Listen 80
NameVirtualHost *

Alias /phpmyadmin "/opt/lampp/phpmyadmin"
Alias /phpsqliteadmin "/opt/lampp/phpsqliteadmin"

# since XAMPP 1.4.3
<Directory "/opt/lampp/phpmyadmin">
AllowOverride AuthConfig Limit
</Directory>

# since LAMPP 1.0RC1
AddType application/x-httpd-php .php .php3 .php4
# before LAMPP 1.0RC1
#<Files ~ "\.(php|php3|php4)$">
# SetOutputFilter PHP
# SetInputFilter PHP
#</Files>

XBitHack on

# since 0.9.8 we've mod_perl
PerlModule Apache2


<VirtualHost *:80>
DocumentRoot /opt/lampp/htdocs/officetime
ServerName www.officetime.ch
<Directory "/opt/lampp/htdocs/officetime">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /opt/lampp/htdocs/tonerhandel
ServerName www.toner-handel.ch
<Directory "/opt/lampp/htdocs/tonerhandel">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /opt/lampp/htdocs/itemashop
ServerName www.itemashop.ch
<Directory "/opt/lampp/htdocs/itemashop">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:443>
DocumentRoot /opt/lampp/htdocs
ServerName service.itemashop.ch
<Directory "/opt/lampp/htdocs">
allow from all
Options +Indexes
</Directory>
</VirtualHost>
riedere
 
Posts: 29
Joined: 09. October 2004 16:08
Location: Zürich

Postby deepsurfer » 03. July 2005 10:36

aha, das heisst du möchtest die verschieden VHOST mit SSL ausstatten aber beim Aufruf springt der browser immer auf die hauptdomain im https

Dazu wird hier was erklärt.
http://community.apachefriends.org/f/viewtopi ... c&start=15
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Nicht ganz so

Postby riedere » 03. July 2005 10:57

Die Domains funktionieren aber nur mit SSL
mit http gehts nicht - er kommt dann immer mit "Bad Request Try https..."

Ansonsten schmeiss ich SSL raus (wollte ich eigentlich nur für die Admin Tool Seite obwol dort alles per Passwort gesichert ist aber es wäre eine zusä.Sicherheit.
riedere
 
Posts: 29
Joined: 09. October 2004 16:08
Location: Zürich

Postby riedere » 03. July 2005 11:06

Hab das Ganze ohne SSL gestartet und plötzlich gehts...
(einfach alles ohne SSL aber so auch ok, nur würd mich wunder nehmen warum)


- nun mache demnächt einen produktiven Debian Server mal sehen wie es dann dort geht.

Danke
riedere
 
Posts: 29
Joined: 09. October 2004 16:08
Location: Zürich


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests