Errorpage bei ungültiger Subdomain - Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

Errorpage bei ungültiger Subdomain - Problem

Postby brushi » 15. June 2005 10:03

hallo,
bin seit tagen daran den apache so zu konfigurieren, dass subdomains die keinen wildcardeintrag haben und falsch eingegeben werden, zu einer errorpage geleitet werden.

bsp.: domain.de ist existent und hat keinen wildcard eintrag

dann soll bei der eingabe von schmarn.domain.de eine errorpage geschalten werden.

da ich alle domains als vhost eingetragen habe, habe ich das documentroot vom apache auf dieses errorpage directory gesetzt. das fuktioniert auch alles super gut nur bei einer domain funktioniert die ganze sache nicht. ich weiß nicht an was das liegen könnte.

die betreffende domain ist gleichzeitig auch servername. irgendwie denk ich das das damit etwas zu tun hat. den servername vom apache hab ich aber auch schonmal geändert. brachte aber keinen erfolg.

habt ihr einen anderen ansatz wie ich dieses errorpage problem lösen könnte? mit nem alternativen vhost irgendwie?

für ideen wäre ich dankbar.

michael
brushi
 
Posts: 7
Joined: 15. June 2005 09:53

Postby Wiedmann » 15. June 2005 10:19

da ich alle domains als vhost eingetragen habe, habe ich das documentroot vom apache auf dieses errorpage directory gesetzt.

Sofern du mit "NameVirtualHost *:80" arbeitest, muss das DocumentRoot von deinem ersten VHosts auf das Verzeichnis zeigen, was als DocumentIndex dann die Fehlerseite (nicht vorhandene Domain) liefert.

(BTW sollte in diesem VHost auch das ErrorDocument für 404 auf diese Seite zeigen. Es ist auch eine gute Idee, mit PHP in beiden Fällen den 404 zu setzten.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests