Apache (1.3.26) Performance Probleme

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache (1.3.26) Performance Probleme

Postby c-we » 08. June 2005 13:07

Hi Leute,

vielleicht kann mir ja von euch jemand helfen:

Ich habe einen Server (Strato Root Server)
Celeron 2,4/ 512 MB Ram / Suse 8.1 / PHP 4.2.2 / Mysql 3.23.52

Auf dem laufen z.z. 3 Typo3s (3.8/3.7) und 6 PphpBBs mit ca. 600 Zugriffen insgesamt am Tag.

Da mein Apache immer gemeckert hat er habe zuwenig Prozesse habe ich ihn wie folgt konfiguriert:

Code: Select all
MinSpareServers 30
MaxSpareServers 60
StartServers 50
MaxClients 256
MaxRequestsPerChild 0

KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15


Nun frage ich ob es normal ist, dass der Apache z.z. 37! prozesse mit mehr als 10 MB Ram auf hat? Zum Teil sogar mit über 20 MB ! Zusätzlich noch ein Haufen Prozesse mit weniger als 10 MB ....
Trotz oder gerade auf Grund dieser hohen Resourcen Nutzung wird der Seitenaufruf immer langsamer ... bis er dann per Hand neugestartet wird !?

Hat jemand ne Ahnung ob das normal ist?
Oder ob ich an der Config noch was verbessern/tunen kann?

Vielen Dank im vorraus für jeden Tipp!
c-we
 
Posts: 22
Joined: 29. September 2004 14:55

Postby c-we » 19. June 2005 22:45

Hat denn niemand ne Idee?

Z.Z. experimentiere ich ein wenig mit der Config ... und je höher ich die Werte StartServers, or Min/MaxSpareServers setzte desto öfter erscheint eine Fehlermeldung im Logfile das ich diese Werte höher setzten soll .... ich raffs nicht mehr ...

Code: Select all
[Sun Jun 19 23:31:58 2005] [info] server seems busy, (you may need to increase StartServers, or Min/MaxSpareServers), spawning 32 children, there are 123 idle, and 131 total children
c-we
 
Posts: 22
Joined: 29. September 2004 14:55


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests