htaccess Probleme bei Bilderschutz (Trafficklau)

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess Probleme bei Bilderschutz (Trafficklau)

Postby Fox » 27. May 2005 09:14

Hi,

da mein Forum mittlerweile eine gewisse Userzahl erreicht hat, und ich viele Möglichkeiten den Usern biete Bilder hochzuladen, steigt auch das Problem des unnötigen Trafficklaus, d.h. Fremdverlinkung von Bildern etc., das übliche eben. Dies möchte ich aber unterbinden, und zwar mit htaccess wie es ja so üblich ist und hier eben eine Ersatzgrafik anzeigen lassen. Folgenden Inhalt habe ich in der .htaccess drin:

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?kadett-forum\.de(/.*)?$ [NC]
RewriteRule \.(gif|jpg|GIF|JPG)$ http://www.kadett-forum.de/bilder/banner.jpg [R,L]


Die .htaccess liegt auch im richtigen Verzeichnis. Jedoch wird auf Fremdseiten dann gar kein Bild mehr angezeigt. Stattdessen zeigt der Firefox das Zeichen das die Grafik (bzw. der Link da hin) defekt ist, aber keine keine Ersatzgrafik wie angewiesen. Dazu kommt dann noch das die Bilder aus dem Galerie-Verzeichnis, die auf meiner Domain Kadett-Forum.de geladen werden sollen und dürfen, auch NICHT mehr geladen werden, es wird auch kein Fehler-Icon gezeigt.

Nun hab ich bei meiner Recherche im Netz auch nicht sehr viel mehr gefunden als die oben gezeigten Zeilen. Hin und wieder der Hinweis das es an Apache bzw. der httpd.conf liegen könnte das es nicht geht.

.htaccess an sich geht jedoch. Denn beim Aufruf der Domain kadett-forum.de greift bereits eine .htaccess und öffnet die main.php statt der index.php.

Ich weiß nicht mehr weiter, evtl kann mir einer von euch helfen...

Ach ja, falls nötig, hier noch folgende Info: Root-Server auf Linux 9.0, Apache Version Apache/2.0.48 (Linux/SuSE)

Danke schon mal für die Hilfe,

Gruß Manu
Fox
 
Posts: 10
Joined: 18. January 2005 22:36

Postby Dj_GL » 27. May 2005 09:46

Bei meiner Page habe ich das so gelöst:

Code: Select all
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^http://www.gleitgeb.at
RewriteCond %{REQUEST_URI} !^.+ban_image.+$
RewriteRule ^.+\.(gif|GIF|jpg|JPG|jpeg|JPEG)$ http://www.gleitgeb.at/stop.jpg [redirect,last]


wobei http://www.gleitgeb.at/stop.jpg die Datei ist die angezeigt wird wenn die Grafik woanders eingebaut wird
User avatar
Dj_GL
 
Posts: 41
Joined: 07. June 2003 23:57

Postby Fox » 27. May 2005 10:40

Danke Dj_GL deine Variante habe ich eben auch getestet. Das Ergebnis bleibt aber gleich. In der Galerie meines Forums werden die Bilder gar nicht mehr geladen (kein Rotes X oder dergleichen) und auf Fremdseiten kommt das bekannte Rote X, die Ersatzgrafik wird nicht gezeigt.

Sehr seltsam.
Fox
 
Posts: 10
Joined: 18. January 2005 22:36

Postby deepsurfer » 27. May 2005 12:02

schau mal bei http://www.modrewrite.de/ vorbei, die haben fähige Leute und dort ist auch dieses Script erklärt (wenn ich mich recht entsinne)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Fox » 27. May 2005 12:27

Das habe ich jetzt bereits getan. Und tatsächlich war mod_rewrite nicht geladen. Aber selbst nach dem dies geladen ist, bringt das Resultet keinerlei unterschiede. Öffnet man das Bild direkt, kommt ein Forbidden-403 heraus. Aber direkt im Browser zu öffnen sollte ja dennoch gehen. Bzw. öffnen auf der eigenen Domain, aber dies bringt auch nur 403-Fehler pro Bild. Bin schon langsam am verzwifeln.
Fox
 
Posts: 10
Joined: 18. January 2005 22:36

Postby Dj_GL » 27. May 2005 13:00

Kann ich irgendwie nicht verstehen ...

Bei mir kannst Du es ausprobieren das es funktioniert:

von http://www.gleitgeb.at/photopage/cuttie-angel4u/ kommt man auf die Bilder

Direkt auf zB http://www.gleitgeb.at/photopage/cuttie-angel4u/big/cuttiangel4u-2.jpg nicht.
User avatar
Dj_GL
 
Posts: 41
Joined: 07. June 2003 23:57

Postby Dj_GL » 27. May 2005 13:05

Zum Testen müsste
Code: Select all
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^http://www.kadett-forum.de
RewriteCond %{REQUEST_URI} !^.+ban_image.+$
RewriteRule ^.+\.(gif|GIF|jpg|JPG|jpeg|JPEG)$ http://www.gleitgeb.at/stop.jpg [redirect,last]

reichen.

Wenn das nicht geht liegts wohl kaum an mod_rewrite sondern eher an Deiner Apache Konfiguration.
User avatar
Dj_GL
 
Posts: 41
Joined: 07. June 2003 23:57

Postby Fox » 27. May 2005 13:34

Das hatte auch nicht funktioniert, aber ich habe jetz darin eine passende Lösung gefunden:

<files ~ "\.(gif|jpg|png|JPG|PNG|GIF)$">
ErrorDocument 403 http://www.kadett-forum.de/bilder/traffic.gif
SetEnvIfNoCase Referer "^http://www.kadett-forum.de" local_ref=1
SetEnvIfNoCase Referer "^http://kadett-forum.de" local_ref=1

SetEnvIfNoCase Referer ^$ local_ref=1
Order Allow,Deny
Allow from env=local_ref
</files>


Es funktioniert nun, und ich bin Glücklich...
Fox
 
Posts: 10
Joined: 18. January 2005 22:36


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests