Apache verabschiedet sich...

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache verabschiedet sich...

Postby Ely » 15. May 2005 17:43

in unregelmäßigen Zeitabständen und ich habe keine Erklärung dafür bzw. weiß ich nicht weiter, da ich kein Profi bin.

Heute morgen war es wieder so weit und diese Auszüge habe ich im Error_log gefunden. Kann mir da jemand weiter helfen?

---------------------

[Sun May 15 06:15:15 2005] [warn] child process 708 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 709 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 710 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 711 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 712 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 777 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 801 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 829 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 959 still did not exit, sending a SIGTERM
[Sun May 15 06:15:15 2005] [warn] child process 960 still did not exit, sending a SIGTERM
[Sun May 15 06:15:19 2005] [notice] caught SIGTERM, shutting down
[Sun May 15 06:15:29 2005] [crit] (98)Address already in use: make_sock: could not bind to port 443
[Sun May 15 09:47:40 2005] [notice] Apache configured -- resuming normal operations
[Sun May 15 09:47:40 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun May 15 09:47:40 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)

---------------------------

Um 6:15 hat er sich also wieder einmal verabschiedet. Um 9:47 habe ich den Server neu gestartet. Was mir auch noch aufgefallen ist, ist das ich den Apachen zwar mit "rcapache stop" stoppen kann, aber auf die Befehle "rcapache start" und "rcapache restart" keine Reaktion erhalte.

Ich muss meinen Suse Linux-Server mit Confixx 2 komplett rebooten um den Apachen wieder zum laufen zu bringen.

Auch habe ich noch einen Fehler entdeckt, den ich nicht korrigiert bekomme. Vielleicht weiß auch hier jemand Rat?

Im rcapache_log finde ich diesen Eintrag:

--------------------
Warning: DocumentRoot [/home/www/web18/html/blop] does not exist
Warning: DocumentRoot [/home/www/web18/html/mbit] does not exist
Syntax OK
--------------------

Es stimmt, diese DocumentRoot existieren nicht, aber warum stehen diese Einträge im Log. Normalerweise müsste das doch aktualisiert werden, oder?

Danke für Eure Hilfe.

Gruß
Ely
Ely
 
Posts: 3
Joined: 15. May 2005 17:22

Postby deepsurfer » 17. May 2005 10:39

Kann es sein das du ein CRONJOB am laufen hast ???, schau auch mal da nach.

-----------
Hier vermute ich das irgendeine Seite, sei es von Usern oder eigene, beim Anzeigen zusätzlich in diese Verzeichnisse will.
Viellecht hattest du mal ein Bilderscript oder ähnliches Programmiert.

Durchsuch deine HTMLcodes nach dieser Pfadangabe (grep befehl hilft immer). Zusätzlich schau mal in deine HTTPD.CONF denn der "Warning: DocumentRoot" könnte auch von da kommen.

Warning: DocumentRoot [/home/www/web18/html/blop] does not exist
Warning: DocumentRoot [/home/www/web18/html/mbit] does not exist
Syntax OK
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Ely » 17. May 2005 11:51

Danke Dir für die Antwort.

Eigentlich habe ich nur Cron am laufen die Dumps der Datenbanken erstellen sollen und die liefen bislang einwandfrei.

Jedoch habe ich auch einen der die Up-Time des Servers anzeigt. Diesen habe ich nun einmal deaktiviert. Mal sehen was passiert.

Ich habe gerade noch mal das Error_log durchforstet und bin da noch auf einen Eintrag gestoßen, mit dem ich nicht viel anzufangen weiß.

Kannst Du mir vielleicht sagen was das mit dem Fakename zu bedeuten hat? Die obere und untere Zeile ist mir klar.

[Sun May 15 12:49:29 2005] [error] [client 80.137.137.187] File does not exist: /home/www/web16/html/grafiken/lalmini.gif
==> Fakename: /usr/sbin/httpd PidNum: 2784
==> Fakename: /usr/sbin/httpd PidNum: 2787
[Sun May 15 13:01:15 2005] [error] [client 200.217.10.70] File does not exist: /home/www/web13/html/favicon.ico

Danke für Deine Bemühungen.
Ely
 
Posts: 3
Joined: 15. May 2005 17:22

Postby deepsurfer » 17. May 2005 15:16

hhmmmm.... ist auf jedenfall etwas mit SuSE ! Die benutzen in den Apachen diese Namensgebung bei den Erklärungen.

Bei meiner groben Recherche fand ich heraus das irgendein Script den httpd überprüft und das im Bootvorgang.

Quelle:
http://www.linuxforen.de/forums/showthread.php?t=20568

Es deuten auch einige Texte auf das mod_alias hin, da dort der "Fakename" als Beispiel für die Einstellungen benutzt wird.
Mal in der httpd.conf nochmal nachschauen und nach "Fakename" suchen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Ely » 17. May 2005 18:12

Okay, danke für Deine Bemühungen. Werde mal nachsehen. :)
Ely
 
Posts: 3
Joined: 15. May 2005 17:22


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests