Apache2 + virtueller Server

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 + virtueller Server

Postby mascoxx » 03. May 2005 15:43

Hi!

Ich verwende Apache2 auf einem Debian System und zur Zeit ist meine Homepage im Verzeichnis /var/www.
Jetzt will ich einen virtuellen Server aufziehen, namebased, und die HP liegt dann im Verzeichnis /opt/sites/homepage.
Allerdings kann auf die Page nicht zugegriffen werden.
Nun meine Frage: Muss ich meine jetzige HP auch auf einen virtuellen Server legen??
Ich bitte um Antwort!

MfG
mascoxx
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby Wiedmann » 03. May 2005 15:57

Nun meine Frage: Muss ich meine jetzige HP auch auf einen virtuellen Server legen??

Ja.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mascoxx » 03. May 2005 20:44

OK, alle Seite sind kopiert, allerdings kann meine Hauptseite nicht aufgerufen werden....mir wird lediglich ein leeres Directory angezeigt (siehe www.mascoxx.com)
hmmm, wo liegt der Fehler?

MfG :roll:
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby mascoxx » 04. May 2005 08:02

Also, ich habe jetzt folgendes gemacht:

Meine Website aus /var/www rausgerissen und in /opt/sites/mascoxx reingeknallt; directoryroot in der datei "000-default" angepasst und die hp rennt einwandfrei. allerdings sobald ich einen virtuellen server anlege
und das directoryroot auf /opt/sites/longnights einrichte, wird keine seite
angezeit (obwohl eine index.html drinnen ist).
ich hab das ganze über webmin eingerichtet. er schreibt die einstellungen für den virtuellen server in die /etc/apache2/httpd.conf.
hab auch schon versucht, eine eigene datei anzulegen (zB virtual.conf), diese über die apache2.conf geladen, allerdings ist keine veränderung zu erkennen.

deswegen bitte ich im hilfe...

mfg, clemens
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby deepsurfer » 04. May 2005 13:03

poste mal bitte deine VHOST einträge... (eventuelle Namen und IPs umändern)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mascoxx » 04. May 2005 13:14

Also, meine Einträge (die von Webmin hinzugefügt wurden) in der
httpd.conf:

<VirtualHost www.long-nights.at.tf>
DocumentRoot /opt/sites/longnights
ServerName LongNights
ServerAlias Nights
ServerAlias -
ServerAlias Lan
ServerAlias Party
<Directory "/opt/sites/longnights">
allow from all
Options +Indexes
</Directory>
</VirtualHost>


Das ganze soll namebased laufen....hmmm
habs jetzt temporär mal so geändert, dass auf ein unterverzeichnis meiner hauptseite zugegriffen wird...
ist aber nicht wirklich das wahre?!

mfg :?
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby Wiedmann » 04. May 2005 13:21

Also, meine Einträge (die von Webmin hinzugefügt wurden) in der httpd.conf:

"Einträge"? Ich seh hier nur einen einen VHost.

Das ganze soll namebased laufen....hmmm

So wie du es gepostet hast, ist es auch ein IP-basierender.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mascoxx » 04. May 2005 13:31

ich mein ja auch, dass hat webmin in die datei eingetragen....

gut, und wie stell ich das jetzt auf namebased um??
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby Wiedmann » 04. May 2005 13:48

Wie das im Prinzip funktioniert kannst du hier nachlesen:
http://community.apachefriends.org/f/viewtopi ... host#34538
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mascoxx » 04. May 2005 14:27

hmmm, hab ich mir angesehen, allerdings kommen beim start von apache folgende fehler:

Starting web server: Apache2[Wed May 04 15:25:02 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed May 04 15:25:02 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed May 04 15:25:02 2005] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed May 04 15:25:02 2005] [warn] NameVirtualHost *:80 has no VirtualHosts
.


in meine httpd.conf hab ich einfach folgendes angehängt:

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost:80
DocumentRoot "/etc/apache2/htdocs"
<Directory "/etc/apache2/htdocs">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.mascoxx.com:80
DocumentRoot "/opt/sites/mascoxx"
<Directory "/opt/sites/mascoxx">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.long-nights.at.tf:80
DocumentRoot "/opt/sites/longnights"
<Directory "opt/sites/longnights">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>


:x das ist ja zu junge kriegen :x

mfg :)
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby Wiedmann » 04. May 2005 14:40

Mal abgesehen davon das ein Pfad nicht stimmt, sieht es gut aus.

Es werden wohl wo anders auch noch VHosts definiert, die hier kollidieren (z.B. für SSL).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mascoxx » 04. May 2005 14:53

naja, unter /etc/apache2/sites-enabled hab ich noch eine datei namens
"000-default", die ebenfalls über apache2.conf geladen wird.
in dieser datei findet man:

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /opt/sites/mascoxx/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /opt/sites/mascoxx/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
# RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>



möglicherweise diese??! :roll: :lol:

welcher pfad stimmt nicht?

mfg
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

Postby Wiedmann » 04. May 2005 16:06

unter /etc/apache2/sites-enabled hab ich noch eine datei namens
"000-default", die ebenfalls über apache2.conf geladen wird.
...
möglicherweise diese??!

Ja.

welcher pfad stimmt nicht?

mascoxx wrote:
Code: Select all
<Directory "opt/sites/longnights">
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mascoxx » 04. May 2005 18:21

hi!

soweit ist das ja ganz gut, bis auf ein paar große schönheitsfehler:

www.mascoxx.com: wenn ich die hp aufrufe, will er einen login (wie zb bei .htaccess) und ohne diesen wird sie nicht richtig dargestellt.

www.test21.de.tf: ein leeres fenster wird angezeit, obwohl eine index.html vorhanden ist.

hab der (in meinem fall) vhosts.conf im header auch schon
"DirectoryIndex index.html index.htm index.php" hinzugefügt.
die httpd.conf hab ich schon deaktiviert...leider ohne erfolg....

mfg :)
mascoxx
 
Posts: 18
Joined: 03. May 2005 14:41
Location: Eichgraben

warum eigentlich so kompliziert?

Postby hardy1234 » 09. May 2005 17:08

Hey, hab mir die postings mal angesehen und mich leicht gewundert.

Warum willst Du eigentlich ne Website mit aller gewalt in /opt/...
anlegen?

Normalerweise legt man die komplette in /home /webuser/public_html

Webmin legt das auch so an wenn man den Main-Server ohne Domain anlegt und die Domains dann als virtuelle Host aufbaut. Man sollte vorher nur den Benutzer definieren und dann den virtuellen Host aufsetzen.

Von der Logik her läuft das dann so, das der Host zunächst alle ankommenden Abfragen prüft und entsprechend verzweigt wenn für die Domain ein virtueller Host existiert.

Zusätlich kann man dann noch per .htaccess Zugriffsrechte vergeben und so bestimmte Server für die Öffentlichkeit sperren, z.B. sinvoll für Download-Seiten.

Wenn man das so macht, ist das anlegen der virtuellen Hosts mit Webmin ein klacks und in wenigen Minuten erledigt.
hardy1234
 
Posts: 3
Joined: 09. May 2005 16:50

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests