Fehlereinträge beim Start von Apache im error-log

Alles, was den Apache betrifft, kann hier besprochen werden.

Fehlereinträge beim Start von Apache im error-log

Postby Wraith » 16. April 2005 08:20

Code: Select all
[Fri Apr 15 18:35:24 2005] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Apr 15 18:35:24 2005] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Apr 15 18:35:25 2005] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Apr 15 18:35:25 2005] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Apr 15 18:35:26 2005] [notice] Apache/2.0.53 (Win32) mod_ssl/2.0.53 OpenSSL/0.9.7f PHP/5.0.4 configured -- resuming normal operations
[Fri Apr 15 18:35:26 2005] [notice] Server built: Apr  8 2005 10:55:39
[Fri Apr 15 18:35:26 2005] [notice] Parent: Created child process 2548
[Fri Apr 15 18:35:27 2005] [notice] Child 2548: Child process is running
[Fri Apr 15 18:35:27 2005] [notice] Child 2548: Acquired the start mutex.
[Fri Apr 15 18:35:27 2005] [notice] Child 2548: Starting 250 worker threads.

Das steht nach jedem Start in der error.log. Er läuft zwar problemlos, manchmal sogar einige Stunden. Doch irgendwann bekommen User aus dem I-Net nur noch eine Meldung "--Verbindung wurde zurück gesetzt...". Nachdem ich ihn dann neu starte, geht alles wieder (für eine gewisse Zeit) bis es wieder zum Aussetzer kommt. Ich habe WinXP prof. Als ich vor 2 ca. Jahren mal den Apache allein auf einem Win2000-System laufen hatte, lief der problemlos. hat jemand nen Plan, woran das liegen könnte, dass Apache nach ner Weile einfach keine Lust mehr hat?
User avatar
Wraith
 
Posts: 14
Joined: 10. April 2005 13:48
Location: Bad Tennstedt

Postby Wiedmann » 16. April 2005 09:06

Code: Select all
[Fri Apr 15 18:35:24 2005] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Apr 15 18:35:24 2005] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Apr 15 18:35:25 2005] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Apr 15 18:35:25 2005] [crit] (2)No such file or directory: unable to replace stderr with /dev/null

Diese Einträge kommen vom "xampp-control.exe" und man kann sie ignorieren. Mit deinem Problem haben die weiter nichts zu tun. Die restlichen Einträge sind korrekt und gehören da hin.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

aha

Postby Wraith » 16. April 2005 10:19

Danke!
Ist ja schon mal ein Trost, dass die Fehlermeldungen nix weiter bedeuten. Nun müsste ich nur noch das Problem des Nichterreichbarseins lösen. 8)
User avatar
Wraith
 
Posts: 14
Joined: 10. April 2005 13:48
Location: Bad Tennstedt

Postby deepsurfer » 17. April 2005 15:40

Wird dein XAMPP sehr gut besucht ????
hast du filesharing programme und alles mögliche an anderen Internet-Tool-Programme-Verbesserungs-und-Kommunikations dingens am laufen ???

denn jedes kb, von deiner möglichen bandbreite das du dem xampp wegnimmst kann dazu führen das pages nicht mehr abrufbar sind.

ansonsten testen und erfahrung melden.
http://community.apachefriends.org/f/viewtopi ... 8752#48752
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Erfahrung

Postby Wraith » 18. April 2005 12:00

Ich habe diese Werte in der conf mal geändert, aber es blieb alles beim Alten, bis auf den Umstand, dass ich öfters die berüchtigte Fehlermeldung "Apache.exe: ...Vorgang Read konnte nicht ausgeführt werden...bla bla..Klicken sie OK um das Programm zu beenden".
Apache lief zwar weiter. Aber diese Meldung kam in unregelmäßigen Abständen immer wieder. Erst als ich alle Wert wieder zurückgesetzt habe, ist diese Meldung weg. Ich habe fast das Gefühl, dass XP nicht grad das optimale Betriebsystem ist, wenn man einen Webserver betreiben will, der auch relativ viele Zugriffe hat. Bin am Überlegen, ob ich mir nicht Linux installiere.... :roll:
Die Fehlerquelle eines Computers sitzt meist ca. 50 cm davor :-)
User avatar
Wraith
 
Posts: 14
Joined: 10. April 2005 13:48
Location: Bad Tennstedt

Postby deepsurfer » 18. April 2005 12:05

Ich habe diese Werte in der conf mal geändert, aber es blieb alles beim Alten, bis auf den Umstand, dass ich öfters die berüchtigte Fehlermeldung "Apache.exe: ...Vorgang Read konnte nicht ausgeführt werden...bla bla..Klicken sie OK um das Programm zu beenden".
Apache lief zwar weiter. Aber diese Meldung kam in unregelmäßigen Abständen immer wieder. Erst als ich alle Wert wieder zurückgesetzt habe, ist diese Meldung weg.



hhhhmmmmmmmmmmmm..... bei welchem wert es expliziet auftritt hast du zufälligerweise nicht überprüft ???

In der FAQ von XAMPP stehen zwei Einträge, einmal wegen CPU=99% und einmal wegen nicht vollständigen Bilderübermitlung.
Diese EInträge auch mal checken.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests