Virtual Host & SSI

Alles, was den Apache betrifft, kann hier besprochen werden.

Virtual Host & SSI

Postby MichaLu » 15. April 2005 10:56

Ich nutze intensiv SSI. Bisher hatte ich meine lokale site als Alias /hv, und sowohl dort als auch bei meinem Provider (ohne Alias) läuft alles.
Jetzt wollte ich auf Virtual Host umstellen, und nichts geht mehr, d. h. die Unterordner werden nicht mehr gefunden und SSI wird nicht ausgeführt.
Zur Standard httpd.conf hane ich f. hinzugefügt:

NameVirtualHost *
AddHandler server-parsed .html .htm
<VirtualHost *>
ServerAdmin webmaster at dr-luthardt.de
ServerName luthardt.selfhost.de
DocumentRoot "D:/Daten/WEB/hv"
# ErrorLog logs/dummy-host.example.com-error_log
# CustomLog logs/dummy-host.example.com-access_log common
<Directory "D:/Daten/WEB/hv">
# Options Indexes
# Options MultiViews
# Options ExecCGI
Options FollowSymLinks
Options Includes
AddType text/html .shtml .shtm
AddType image/x-icon .ico
AddHandler server-parsed .html .htm .shtml .shtm
# AddHandler cgi-script .cgi .pl
AllowOverride All
DirectoryIndex pre.htm
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Was fehlt/mache ich falsch?

:(
MichaLu
 
Posts: 6
Joined: 15. April 2005 10:26

Postby deepsurfer » 17. April 2005 15:27

hhmm laut apache.org sollte es gehen

http://httpd.apache.org/docs-2.0/howto/ ... s.html#ssi



gibt da noch einen zweiten hinweis...
http://httpd.apache.org/docs-2.0/howto/ ... onfiguring

dann könnte deine Zeilen so aussehen

Options Includes
AddType text/html .shtml .shtm
AddOutputFilter INCLUDES .shtml
AddType image/x-icon .ico
AddHandler server-parsed .html .htm .shtml .shtm
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

SSI in VirtualHost

Postby MichaLu » 17. April 2005 19:40

Oh nein, wie bin ich blöd!
Dein Hinweis hat mich drauf gebracht, danke.
Ursache/Problem:
SSI geht und ging wohl auch, aber ich habe alle Unterverzeichnisse mit .htacces so geschützt, dass ein Zugriff nur mit bestimmten Referrern möglich ist. Und der hat sich ja mit meinem VH geändert! Dadurch keine Bilder und kein CSS.
:D
MichaLu
 
Posts: 6
Joined: 15. April 2005 10:26

Postby deepsurfer » 18. April 2005 10:41

:D

nun ist es ja gelöst


have fun
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests