Apache unter SuSE 8.2 Pro starten

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache unter SuSE 8.2 Pro starten

Postby Sebastian » 13. May 2003 19:02

Hallo, der betreff sagt schon fast alles, ich hab mir neulich suse 8.2 pro gekauft, soweit läuft alles gut, bei der installation habe ich einfacher webserver mit installiert, allerdings startet apache nciht (automatisch?).

beim aufruf der address http://localhost wird nur angezeigt, das es keine verbindung zum rechner gibt.

Was muß ich machen das der apache endlich m,al startet?
und wie läßt es sich einrichten, das der beim booten automatisch gestartet wird?

muß ich da jetzt erst noch irgendwas konfigurieren, oder wird das ganz (php, mysql) schon bei der aus wahl einfacher webserver vorkonfiguriert, falls das der fall ist bitte ich um einen link zu eibnen guten turtorial, es sollte sich dortr auch direkt mit apache unter suse 8.2 befassen.


Danke schonmal für hilfe
Sebastian
 

Postby AlexPausB » 13. May 2003 19:36

Tach,

also sicherlich kannst Du bei der SuSE Distri den Apache mit MySQL, PHP etc installieren und auch automatisch starten.

Musst Dich halt mal ein wenig mit dem Yast-Ding auseinandersetzten (oder wie das heisst :-)).

Willst Du aber Dein "Ding" einfach selbst konfigurieren, dann saug dir den LAMPP von dieser Seite und fertig.

Damit dieser dann auch automatisch beim Booten startet, mach mal einen auf den hier: ImageSuchen

Ich weiss 100%ig, dass dies - auch in Bezug auf SuSE - hier im Forum irgendwo steht.

Tschöööö, Alex
Last edited by AlexPausB on 13. May 2003 20:16, edited 1 time in total.
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Sebastian » 13. May 2003 20:11

jon danke
womit geht das denn einfach mit dem yast oder diesem wammp teil? :)
Sebastian
 

Postby AlexPausB » 13. May 2003 20:16

naja, ich würde dir den lampp empfehlen. weil du 1. genau weisst was du hast (musst nur mal auf apachefriends.org schauen), 2. hast du kontrolle über alles, 3. liegt alles recht "zentral" zusammen und du musst nich ewig nach verstreuten config-files gucken.

ich denke zum lernen und verstehen, is lampp sinnvoller!
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Guest » 13. May 2003 20:26

und damit kann ich auch apache starten?
Guest
 

Postby AlexPausB » 13. May 2003 20:44

hm - Ja schon :?

ich schlage dir vor, dass du mal die www.apachefriends.org webseite etwas genauer unter die lupe nimmst.

das "LAMPP" paket enthält eigentlich alles was du brauchst!
(L)inux (A)pache (M)ySQL (P)hp (P)erl = LAMPP, comprende?

ganz einfach! runterladen, entpacken und starten - und los gehts.

das ganze hat dann aber nichts mehr mit dem apache zu tun, der schon bei deinem suse dabei ist! is halt die frage, was du willst? einen eigenen bauen, oder ein "fertiges" komplettpaket?!
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Guest » 13. May 2003 21:25

hm, eigentlich will ich ja nur den apache starten um lokal php scripte und mysql auszuführen.

Apache php und mysql ist ja schon drauf, ich hab nur keinen plan wie ich den starten soll.

Mit befehlen wie
/usr/local/apache/blablabla hab ichs ja schon probiert nur es ztut sich nix.

wie gesagt, apache ist drauf, das schließt der punk "einfacher webserver" bei der installation ja schon ein
Guest
 

Postby Guest » 13. May 2003 21:27

Nachtragf:
gibt das keine probleme wenn alles dchon drauf ist und ich dann das lammp paket installiere?
Guest
 

Postby AlexPausB » 13. May 2003 21:30

So lange du den SuSE-Apachen bzw MySQL Server _nicht_ startest, gibt es keine Probleme... Ausnahmen bestätigen die Regel!

Aber es gibt doch bei SuSE sicherlich auch eine zentrale Konfigurationsdatei, die man über YaST etc bearbeiten kann, da lässt sich garantiert auch einstellen, das Apache und MySQL beim Booten automatisch mitstarten.

Schon mal im Handbuch geblättert? Also in Bezug auf die Conf-Datei...
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Guest » 13. May 2003 21:34

jo in den zwei handbüchern steht alles mögliche, wie man den apache konfiguriert, aber es wird nciht ein wort dasrüber verloren wie man ihn startet.

Yast hab ich schon zig mla durchgesucht, nur ioch finde das ncihts was mit autostart zu tun hat/haben könnte.

Ich hab yast2 drauf, ne ahnung wie man da einstellen kann wasd bei booten so alles gestetet wird?
Guest
 

Postby AlexPausB » 13. May 2003 22:00

Ich hab grad mal in der Support-Datenbank bei SuSE geschaut und nur das hier gefunden:

Code: Select all
rcapache  start


probier das doch einfach mal auf der console aus... ich mach mich für heute erstma' - viel Erfolg!
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Guest » 14. May 2003 01:04

ok danke, jetzt eght es. ich hab ein wenig rumgespielt und auf einaml ging es.

hm, jetzt gibts das nächste Prob:
und zwar sagt phpinfo() das das mysql socket im ordner (ähm fällt mir jetzt nicht ein) liegen soll, aber da ist es nicht, auch nciht als versteckte datei.

hm, was soll ich jetzt machen?
Guest
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests