wiedermal Zugriffskontrolle .htaccess...

Alles, was den Apache betrifft, kann hier besprochen werden.

wiedermal Zugriffskontrolle .htaccess...

Postby selaviano » 14. March 2005 15:15

ich hab nen xampp auf einem testrechner und wollte jetzt ne zugangskontrolle via .htacccess .htpasswd machen.
Der testrechner ist ein wampp und da funktioniert alles. Aber auf dem Produktivrechner nicht

Das Problem bei wird User-PW garnicht gefragt. und sofort das index-file angezeigt.

hier die Files auf dem Produktivrechner:

###START###
# .htaccess

AuthType Basic
AuthName "Protected Area"
AuthUserFile /storage/srv/www/htdocs/pwtest/.htpasswd
Require user username

# .htpasswd

username:passwd


#httpd.conf

Include /etc/apache2/uid.conf
Include /etc/apache2/server-tuning.conf
Include /etc/apache2/sysconfig.d/loadmodule.conf
Include /etc/apache2/listen.conf
Include /etc/apache2/mod_log_config.conf
Include /etc/apache2/sysconfig.d/global.conf
Include /etc/apache2/mod_status.conf
Include /etc/apache2/mod_info.conf
Include /etc/apache2/mod_autoindex-defaults.conf

TypesConfig /etc/apache2/mime.types
DefaultType text/plain
Include /etc/apache2/mod_mime-defaults.conf

Include /etc/apache2/errors.conf
Include /etc/apache2/ssl-global.conf

# forbid access to the entire filesystem by default
<Directory />
Options All
AllowOverride All
Order deny,allow
Deny from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

DirectoryIndex index.html index.html.var
Include /etc/apache2/default-server.conf
Include /etc/apache2/sysconfig.d/include.conf
Include /etc/apache2/vhosts.d/*.conf

###END###

meiner meinung muß es an der httpd.conf liegen, da ich ja garnicht bis zur abfrage komme?!

Ich hab mich zwar schon durch mehrere Foren durchgearbeitet, aber:

AllowOverride All

war der einzige Fehler den ich finden konnte und hab das jetzt in meiner config s.o. auch auf 'All' was vorher auf 'None' war.
Wie gesagt, es es wird sofort das index-file angezeigt, ohne iregendeine Passwortabfrage.
die .htaccess und .htpasswd dateien liegen im selben ordner.

MfG+Danke vorweg wenn jemand was weiß.
selaviano
 
Posts: 2
Joined: 08. March 2005 14:00

Postby selaviano » 15. March 2005 10:47

Hallo nochmal,

hab jetzt die letzten Stunden gelesen und gelesen. Kam aber auf keinen grünen Zweig.

Bis ich die 'httpd.conf' ganz durchgelesen hab.

Weiter unten in der 'httpd.conf' ist noch ein 'include' für 'default-server.conf' in der explizit die Direktiven für die 'htdocs' gesetzt wird.

Es war also sch* egal was ich vorher gemacht hab. Da anscheinend immer das zählt was zum Schluß kommt.

So dat wars, vielleicht gibt es da draußen jemanden dem das weiterhilft, da er auch den Wald vor leuter Bäumen nicht sieht.

MfG,
Christopher

p.s.: @apachefriends weiter so, meinen Respekt für euer/e Projekt/e und auch wie hier im Forum Hilfe geleistet wird. Bei mir war ich wohl selber schuld. Es beweist sich wieder:
Wer lesen kann ist klar im Vorteil!!!
selaviano
 
Posts: 2
Joined: 08. March 2005 14:00


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests