Apache als Reverse Proxy

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache als Reverse Proxy

Postby Brainscanner » 02. March 2005 19:14

Also Leute, ich blicke überhaupt nicht mehr durch - bin mit meinem Verständnis am Ende.
Ich versuche meinen "Apache/2.0.49 (Win32) mod_ssl/2.0.49 OpenSSL/0.9.7d PHP/4.3.6 mod_autoindex/color Server at server Port 80" als ReverseProxy einzusetzen, weil ich bestimmte andere Webserver, die auch auf diesem Server laufen aufrufen können möchte, ohne die entsprechenden Ports zum Internet hin zu entblößen.

So, nun versuche ich das schon seit Monaten, krieg's aber einfach nicht hin. Ich hab jetzt mal wieder ein paar bessere Anleitungen gefunden, aber es funktioniert immer noch nicht so ganz. Ich vermute das liegt an ein paar Dateien, die ich noch laden muß, aber nicht kann. Zunächst sei hier mal meine httpd.conf: http://brainscanner.dyndns.org/Download/httpd.txt

Hier werden oben ja ziemlich viele Module geladen. Ich hab mal versucht die relevanten Dateien einigermaßen zu gruppieren:

Code: Select all
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule headers_module modules/mod_headers.so
LoadModule deflate_module modules/mod_deflate.so
#LoadModule proxy_html_module modules/mod_proxy_html.so


Laut den beiden Anleitungen unter:
http://www.apacheweek.com/features/reverseproxies
http://www.icarusindie.com/mod_proxy_html/

besagen, daß ich die mod_proxy_html.so laden muß. Beim Versuch kommt aber die Fehlermeldung:
Code: Select all
The Apache service named  reported the following error:
>>> Cannot load C:/Programme/xampp/apache/modules/mod_proxy_html.so into server: The Apache service named ist keine zul\xe4ssige Win32-Anwendung.


Die beiden Module
Code: Select all
LoadFile "C:/Programme/xampp/apache/bin/iconv.dll"
LoadFile "C:/Programme/xampp/apache/bin/libxml2.dll"


kann ich auch nicht laden. Bei denen kommt die Fehlermeldung
Code: Select all
The Apache service named  reported the following error:
>>> Cannot load C:/Programme/xampp/apache/bin/libxml2.dll into server: Das angegebene Modul wurde nicht gefunden. 


Na ja, der Pfad stimmt aber 100%:
[img]
http://brainscanner.dyndns.org/Download/Apache.gif
[/img]
W: ist es nur, weil ich es über ein Netzlaufwerk anschaue.

So, ich blick hier nicht mehr durch. Hat jemand einen Tip, was ich noch versuchen könnte?
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

Rechte---

Postby Obiator » 03. March 2005 14:16

Hi!

Vielleicht noch einmal über die Berechtigungen schauen, aber so sieht das eigentlich ganz OK aus.
Aber das Kapitel Reverse Proxy ist sowieso gar nicht so leicht. Hab da auch schon Stunden investiert.

Falls dies nicht klappt, vielleicht das ganze mal unter Linux ausprobieren wenn es geht.
Obiator
 
Posts: 22
Joined: 03. March 2005 11:57

Postby Brainscanner » 03. March 2005 17:06

Na ja, ich hab leider kein Linux zur Verfügung und auch keinen freien Rechner, auf dem ich das mal ausprobieren könnte.

Hast Du es unter Windows zum Laufen gebracht?

Was meinst Du mit Berechtigungen?

Ich denke das Problem liegt u.a. bei den beiden LoadFile Befehlen, die nicht ausführbar sind. Aber ich krieg's leider nicht hin. Wäre daher klasse, wenn jemand, der es unter Windows zum Laufen gebracht hat, mal kurz hier posten könnte, dann könnte man configs vergleichen.
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

aach...

Postby Obiator » 03. March 2005 17:47

... ich hab es vielleicht!
In welcher Reihenfolge stehen die Befehle?
Versuch mal den LoadFile befehl mit dem libxml usw. VOR den LoadModule-Befehl einzufügen.
Und nochmal nachschauen ob bei dem Loadfile "\" oder "/" geschrieben werden muss...
Obiator
 
Posts: 22
Joined: 03. March 2005 11:57

Postby Brainscanner » 03. March 2005 18:19

Also diese Zeile hier

LoadFile "C:/Programme/xampp/apache/bin/php4ts.dll"

wird erfolgreich geladen, daher gehe ich von / aus.

Die Position der beiden Dateien scheint leider keinen Einfluß zu haben. Aber die erste Zeile mit der iconv.dll scheint zu funktionieren, da hab ich das Kommentar auch mal entfernt.

Die libxml2.dll geht aber immer noch nicht. Daher meine Frage, ob Du es bei Dir zum Laufen gebracht hast und wenn ja, ob unter Windows? Dann könntest Du mir vielleicht mal Deine Datei schicken. Denn ich gehe eher davon aus, daß ihm die Datei einfach nicht schmeckt, die war auch nicht bei meinem Paket dabei, die hab ich mir nachträglich besorgt.
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

Postby Obiator » 04. March 2005 11:41

Willst du denn auch das Modul mod_proxy_html benutzen oder nur das mod_proxy Modul?
Weil weswegen: soweit ich weiss benötigst du die libxml2.dll nur für das Modul mod_proxy_html. Versuch das einfach mal ohne, und dann Step by Step :)
Leider hab ich mit Apache unter Windows so gut wie keine Erfahrung.
Obiator
 
Posts: 22
Joined: 03. March 2005 11:57

Postby Brainscanner » 04. March 2005 12:27

Okay, dann brauch ich es vielleicht wirklich nicht. Ich hab mich, wie gesagt, an Anleitungen gehalten.
Die Aufgaben der ...html scheinen ja nur regelbasierte Anpassungen an den Links zu sein:
"Parses HTML and XHTML markup, rewriting links according to rules defined by the server admin.
Optionally converts HTML to XHTML or vice versa.
Optionally makes some minor corrections to broken HTML."

Okay, dann brauch ich die nicht. Aber es funktioniert halt immer noch nicht. Ich hab die oben verlinkte Config-Datei mal aktualisiert, also so, wie sie jetzt aussieht. Hast Du noch nen Vorschlag?

Du kannst Dich gerne selbst überzeugen:
http://brainscanner.dyndns.org/exchange/
Da sollte jetzt eigentlich ne Passwortabfrage oder so kommen, aber Du wirst nur eine 404er Meldung bekommen. Wenn ich aber von meinem Server aus http://localhost:81/exchange/ aufrufe, kommt die gewünschte Seite.
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

Postby Obiator » 04. March 2005 12:57

Beim Starten von Apache bekommst du aber im Moment keine Fehlermeldung mehr oder?

Hier mal meine vhost.conf datei.

Code: Select all
NameVirtualHost IP-Adresse

<VirtualHost IP-Adresse>
ServerName brainscanner.dyndns.org

ProxyRequests off

ProxyPass /ordner http://ziel:8080/ordner
ProxyPassReverse /ordner http://ziel:8080/ordner
ProxyPreserveHost On
# ProxyPassReverseCookieDomain (Funzt nicht wirklich, bin noch auf der Suche nach nem mod_proxy wo der Befehl enthalten ist
# ProxyPassReverseCookiePath (ebenso)

<Location /ordner>
 ProxyPass http://ziel:8080/ordner
 ProxyPassReverse /ordner
</Location>

</VirtualHost>

Ist zwar doppelt gemoppelt, aber versuch das einfach mal mit deinen Sachen zu ersetzen. Es sollte eigentlich gehen... eigentlich
Obiator
 
Posts: 22
Joined: 03. March 2005 11:57

Postby Brainscanner » 04. March 2005 13:19

Hm, hab ich was vergessen oder falsch gemacht? Denn so hat sich noch nichts geändert.
Eine vhost.conf Datei hab ich übrigens nicht, ich hab das in die httpd.conf geschrieben.

Code: Select all
<IfModule mod_proxy.so>

#NameVirtualHost IP-Adresse

<VirtualHost brainscanner.dyndns.org>
ServerName brainscanner.dyndns.org

ProxyRequests off

ProxyPass /exchange http://localhost:81/exchange
ProxyPassReverse /exchange http://localhost:81/exchange 
ProxyPreserveHost On
# ProxyPassReverseCookieDomain (Funzt nicht wirklich, bin noch auf der Suche nach nem mod_proxy wo der Befehl enthalten ist
# ProxyPassReverseCookiePath (ebenso)

<Location /exchange>
 ProxyPass http://localhost:81/exchange
 ProxyPassReverse /exchange
</Location>

</VirtualHost>

#ProxyRequests Off

#<Proxy *>

#Order deny,allow
#Allow from all

#</Proxy>

#ProxyBadHeader Ignore

#ProxyPass /emule/ http://localhost:4711
#ProxyPassReverse/ /emule http://localhost:4711

#ProxyPass /exchange/ http://localhost:81/exchange/
#ProxyPassReverse /exchange/ http://localhost:81/exchange/

#ProxyPass /teamspeak/ http://localhost:4534/
#ProxyPassReverse /teamspeak/ http://localhost:4534/

#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
# Set to one of: Off | On | Full | Block
#
ProxyVia On

#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)
#
#CacheRoot "C:/Programme/xampp/apache/proxy"
#CacheSize 5
#CacheGcInterval 4
#CacheMaxExpire 24
#CacheLastModifiedFactor 0.1
#CacheDefaultExpire 1
#NoCache a-domain.com another-domain.edu joes.garage-sale.com

</IfModule>
# End of proxy directives.
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

Postby Obiator » 10. March 2005 15:52

Hast du das Problem schon gelöst?
Wenn nicht: Ich hab zuhause auch den Apache nun unter Windows laufen. Werde dann nachher wohl mal nen ReverseProxy draus machen. Dann kann ich dir wohl weiterhelfen!
Obiator
 
Posts: 22
Joined: 03. March 2005 11:57

Postby Brainscanner » 11. March 2005 17:36

Nein, leider hat sich da nichts getan. Ich hab auch seit dem letzten Post nichts mehr geändert, weil ich die Woche über weg war.
Wär schön, wenn Du das mal bei Dir probieren könntest.
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests