Problem bei Verzeichnis anzeige

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem bei Verzeichnis anzeige

Postby malki » 24. February 2005 19:51

Hallo

Ich hab ein Problem den ich seit 1 woche versuche zu lösen.

Mein Problem ist das ich jetzt ein Server Suse9.2 aufgebaut habe. Leider hab ich ein Problem bei Apache.

Es zeigt nur Index.html seiten an bei den restlichen zum beipiel ordner zeigt er 403 kein Zurgiff.
Ich fand im Forum wohl das ich vor dem indexes multiviwes eine - machen muss. Leider hab ich diesen satz nicht gefunden...


Hier mal mein httpd.conf

[DELETE]
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby deepsurfer » 24. February 2005 20:03

Dieser Lösungsweg ist vor dem Löschen der HTTPD.CONF endstanden, daher bitte nicht verzweifeln wieso ich das ich geschrieben habe.

Code: Select all
# forbid access to the entire filesystem by default
<Directory />
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>


kannst Du in

Code: Select all
# forbid access to the entire filesystem by default
<Directory />
    Options +Indexes MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

Ändern, dann gilt es für den ganzen Server...nicht ratsam

Ansonsten verät dir diese http.conf genau wo du nachschauen sollst

Code: Select all
### 'Main' server configuration #############################################
#
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
#
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
#
Include /etc/apache2/default-server.conf



Auch die Section darunter nachschauen
Last edited by deepsurfer on 25. February 2005 13:51, edited 1 time in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 24. February 2005 20:06

Eine httpd.conf, die nur aus Includes besteht, hilft hier niemanden...

bei den restlichen

Was sind "die Restlichen"?

zum beipiel ordner zeigt er 403 kein Zurgiff.

Damit meinst du Ordner wo keine index.html drin ist?

Ich fand im Forum wohl das ich vor dem indexes multiviwes eine

Wo hast das her? Ich vermute im Moment eher du suchst folgendes:
Code: Select all
Options +Indexes

(das kannst du in der Theorie auch mal direkt in eine .htaccess ins DocumentRoot reintun zum Testen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby malki » 28. February 2005 08:32

Hi nochmals

Ich hab die Einstellugnen vorgenommen die ihr mir geschrieben habt.

das ist der /srv/www/htdocs/Member/.htaccess

AuthUserFile /srv/www/htdocs/Member/.htpasswd
AuthType Basic
AuthName "VIP üyeler icin"
Options +Indexes
require valid-user


der Link dazu ist http://becerenftp.ath.cx/Member/

leider geht es immer noch nicht :(
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby deepsurfer » 28. February 2005 09:12

öhhmm schreib das "+Indexex" erstmal in die httpd.conf in der section wo die grundeinstellung für den Server ist.

Siehe dazu meine Codeschnippsel

testen , melden



wenn das geht dann kommt meine zusatzfrage:
benutzt du gegebenenfalls einen VirtualHost um mittels einem definierten Namen direkt in dieses "Member" verzeichnis zu kommen ??

Sollte das auch bejaht werden, so musst du in der VHOST sektion im bereich <Directory> den "+Indexes" einsetzen.


Noch ein Test für dich in deiner jetzigen .htaccess die du hier gepostet hast.
Duchaus kann es vorkommen das Diestributionen den Eintrag
"+Indexes"
auch nur
"Indexes"
verwenden.

testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby malki » 28. February 2005 09:24

getest habe ich die conf datei passiert ist nichts...

Getest htacess ohne plus zeichnen pasiert wurde nicht.

VHOST konnte ich nicht testen weil ich nicht weis wo ich diese einstellungne machen muss.


hier noch der conf datei

Code: Select all
# forbid access to the entire filesystem by default
<Directory />
    Options +Indexes MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby deepsurfer » 28. February 2005 11:54

Code: Select all
 forbid access to the entire filesystem by default
<Directory />
    Options +Indexes MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>


den
Code: Select all
Deny from all


darunter ergänzen mit "Allow from localhost"
Code: Select all
 forbid access to the entire filesystem by default
<Directory />
    Options +Indexes MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from localhost
</Directory>



Der jetzige eintrag behindert die Directive des Indexes, da alle anfragen durch "Deny from all" blockiert werden.
Mit "Allow from localhost" erlaubst du aber einen Zugang zumindest von Localhost ebene aus. Wenn du über externe PC darauf zugreifen willst
so müsste "Deny from all" gelöscht werden und dann nur "Allow from all" stehen.

Sind sicherheitsparameter mit denen man sehr viel spielen kann ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby malki » 28. February 2005 12:11

Es geht immer noch nicht
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby Wiedmann » 28. February 2005 12:19

Hab jetzt keine Lust zu Quoten...

Aber: Genau das will man an dieser Stelle haben (und nichts anderes):
Code: Select all
forbid access to the entire filesystem by default
<Directory />
   AllowOverride None
   Order Allow,Deny
   Deny from all
</Directory>


Der OP hat aber leider immer noch nicht gesagt, bei welcher URL er genau er den Fehler bekommt (und wo das phys. liegt).

BTW:
normal er muss er die Conf suchen, wo es den Abschnitt "<Directory /foo/htdocs>" gibt. inerhalb dieses Abschnittes muss dann +Indexes in Options gesetzt werden. Danach ist dann das DirectoryListung für das Verzeichnis "/foo/htdocs" und darunter aktiviert. "/foo/htdocs" ist hier das DocumentRoot.
ansonsten: error_log
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby malki » 28. February 2005 12:31

Also die Url ist dies /srv/www/htdocs Alle daten die hier drin sind will ich jetzt listen.
http://becerenftp.ath.cx/Member/ hier die seite

forbid access to the entire filesystem by default
<Directory /srv/www/htdocs>
AllowOverride None
Order Allow,Deny
Deny from all
</Directory>

so hab ich es auch schon probiert aber kommt immer nichts nur error
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby Wiedmann » 28. February 2005 13:00

Code: Select all
forbid access to the entire filesystem by default
<Directory /srv/www/htdocs>
...

so hab ich es auch schon probiert aber kommt immer nichts nur error

Den Eintrag sollt auch nicht verändern. Sondern das in der Conf anpassen, wo es schon diesen Abschnitt "<Directory /srv/www/htdocs>" gibt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby malki » 28. February 2005 13:14

Ich bin am verzweifeln.

Also hier nochmal der Code

Code: Select all
# forbid access to the entire filesystem by default
<Directory /srv/www/htdocs/>
   AllowOverride None
   Order Allow,Deny
   Deny from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\/srv/www/htdocs/Member.ht">
    Order allow,deny
    Allow from all
</Files>


So hab ich es im Moment und leider ist hier immer noch das Error. Hab apache neu gestrartet aber hat sich nicht geändert.

Muss ich noch andere conf editieren hab jetzt nur httpd.conf geändert.

Muss mich entschuldigen bin wirklich ein anfänger. :oops:

hier noch htacces
AuthUserFile /srv/www/htdocs/Member/.htpasswd
AuthType Basic
AuthName "VIP üyeler icin"
Options +Indexes
malki
 
Posts: 9
Joined: 24. February 2005 19:42

Postby Wiedmann » 28. February 2005 13:36

Also hier nochmal der Code

Das du das Codestück wieder in Orginalzustand bringen sollst, sagte ich doch?

Muss ich noch andere conf editieren hab jetzt nur httpd.conf geändert.

Du hast aber schon gelesen was ich geschrieben hab?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby malki » 28. February 2005 13:42

So jetzt hat es geklapt hab es in orginal zustan gebracht. jetzt mit htacces geht alles. :lol:
malki
 
Posts: 9
Joined: 24. February 2005 19:42


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests