XAMPP, WebDAV und Mozilla Sunbird 0.2

Alles, was den Apache betrifft, kann hier besprochen werden.

XAMPP, WebDAV und Mozilla Sunbird 0.2

Postby sky_76 » 12. February 2005 15:07

Ich habe XAMPP für Liux 1.2 auf Debian 3.0 laufen.

Meine httpd.conf:
Code: Select all
LoadModule access_module modules/mod_access.so
LoadModule auth_module modules/mod_auth.so
LoadModule auth_anon_module modules/mod_auth_anon.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule dir_module modules/mod_dir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so

User nobody
Group nogroup
ServerName localhost
DocumentRoot "/opt/lampp/htdocs"

DavLockDB /opt/lampp/var/DavLock

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory "/opt/lampp/htdocs">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all
</Directory>

<Directory /web/www.xxx.at/calendar>
    AllowOverride Options FileInfo AuthConfig
    Dav On
    AuthType Basic
    AuthName WebDAV
    AuthUserFile /web/www.xxx.at/calendar/.htdav

    <LimitExcept GET HEAD POST OPTIONS>
        Require valid-user
    </LimitExcept>
</Directory>


DirectoryIndex index.html index.html.var index.php index.php3 index.php4
AccessFileName .htaccess

<Location /calendar>
    Dav On
</Location>


Ich bekomme allerdings, wenn ich mit Mozilla Sunbird 0.2 auf die Datei
http://user:password@www.xxx.at/calendar/Share.ics schreibend zugreifen will einen Internal Server Error (500). Das Holen des Kalenders funktioniert jedoch.

Liegt es an DAV, an Sunbird oder an den Permissions oder an etwas anderem aus meiner Konfiguration, die dies verhindert? Die Virtual Hosts funktionieren jedenfalls, da ich über einen anderen Virtual Host (www.xyz.at/calendar/Share.ics) die Datei nicht öffnen kann.

Die Datei /web/www.xxx.at/calendar/Share.ics hat die Rechte 777 und die Gruppe nogroup, das Verzeichnis darüber ebenso.

Habe ich einen grundlegenden Fehler bei der Konfiguration von WebDAV gemacht?

Signatur: Apache/2.0.47 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.47 OpenSSL/0.9.7 DAV/2 Server at cp.xxx.at Port 80

Könnte es an Firewall Beschränkungen liegen?

Im Error-Log des Virtual Hosts kommen immer wieder dieselben 3 Fehler:
Code: Select all
[Sat Feb 12 12:35:18 2005] [error] [client 84.112.66.245] The locks could not be queried for verification against a possible "If:" header.  [500, #0]
[Sat Feb 12 12:35:18 2005] [error] [client 84.112.66.245] Could not open the lock database.  [500, #400]
[Sat Feb 12 12:35:18 2005] [error] [client 84.112.66.245] (13)Permission denied: Could not open property database.  [500, #1]


Die Datei /opt/lampp/var/DavLock hat die erechtigungen nobody.nogroup und 777 und liegt innerhalb des Server Root (/opt/lampp), ist aber komplett leer (=mit touch erstellt worden).

Hat jemand eine Idee, wie ich den Sunbird Public Kalender schreibfähig machen könnte?
sky_76
 
Posts: 2
Joined: 12. February 2005 14:25

Postby stoffell » 13. February 2005 11:10

I have installed the same, I have used the following directives in httpd.conf:

# DAVLockDB
DavLockDB /opt/lampp/var/DavLock/DavLock

I then did ;
# mkdir /opt/lampp/var/DavLock
# chown nobody.nobdy /opt/lampp/var/DavLock -R

After this, all seems to work..
User avatar
stoffell
 
Posts: 11
Joined: 12. February 2005 22:57
Location: Belgium

Now it works!

Postby sky_76 » 14. February 2005 08:34

Thanks, I did exactly the same, I made a public writeable directory chowned to nobody.nogroup and placed the Lock File inside.

After all, I renamed the parameter to "DAVLockDB". I don't know whether Options in an Apache Config File are case sensitive, but now it works.
:)
sky_76
 
Posts: 2
Joined: 12. February 2005 14:25


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests