Problem mit deflate

Alles, was den Apache betrifft, kann hier besprochen werden.

Postby LazyOne79 » 11. August 2005 23:19

Code: Select all
output_buffering = 4096
output_handler =
unserialize_callback_func =
zlib.output_compression = Off


das mit der test.html is komisch...
versuch mal das dazu zu tun.. bilder sollte er nicht komprimieren, das regel ich durch expires, sollte flotter sein eigentlich.. (?)

Code: Select all
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png)$ no-gzip dont-vary


und das mal im <directory> wo die test html liegt..

AddOutputFilterByType DEFLATE text/html


was steht bei dir in der phpinfo unter HTTP Headers Information bei accept encoding?


edit:

Code: Select all
"GET /forums.html HTTP/1.1" 9106/54743 (16%)
"GET /do-profiles/what-profil/user-Sanni/community.html HTTP/1.0" 186/236 (78%)


bei mir scheints zu klappen hmm
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 12. August 2005 10:43

Hi

Lokaler aufruf:
"GET /test.html HTTP/1.1" 1807/239915 (0%)
"GET /farben.css HTTP/1.1" 450/1579 (28%)


=> er scheint wieder zu komprimieren - schickt das so aber net raus?

Aufruf von Extern (Testseite; die mir dann auch sagt: nix kompression)
"GET /test.html HTTP/1.0" -/- (-%)


=> da tut sich garnichts. Denke nicht das diese externe Seite sich was in den weg stellt, was die kompression verhindert - die Seite möchte diese ja gerade testen.

Zu den Bildern:
"GET /gallery2/d/390-2/DSCF0073.jpg HTTP/1.1" 3137/3167 (99%)


Wobei ich das glaub (!) ich jetzt begründen kann - es liegt an Gallery - die Bilder die da gezeigt werden, werden über download.php's angezeigt (rewrite) - scheinbar kommt er da durcheinander? Hab jedenfalls mal nen test.jpg in die test.html eingebunden => keine kompression.

php.ini:
HTTP_ACCEPT_ENCODING gzip, deflate
Header .....: Accept-Encoding gzip, deflate
Vary Accept-Encoding
HTTP Response Header:Content-Encoding gzip

... Zlib:
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4

Directive Local Value Master Value
zlib.output_compression Off Off
zlib.output_compression_level -1 -1
zlib.output_handler no value no


Also so wie es sein sollte, oder?

Gruß
Wuppi

PS: edit => hab die test.html mal in test.php umbenannt - gleiches phänomen, diese Datei ist soweit gültiges html - mit den ganzen header-kram und "<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">" - inhaltmässig wiederholt sich ein tectblock ständig und abschließend 2 Bilder
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 12. August 2005 11:38

hm.. komisch.. hab grad ne html bei mir getestet, klappte..kann nur nich soviel rumtesten weil der produktiv is und die leute sonst ausflippen /g

Code: Select all
"GET /deflatetest.html HTTP/1.1" 727/2645 (27%)


probiers mal so.. is meine letze idee.. ansonsten bin ich planlos, sorry :/

Code: Select all
DeflateBufferSize 65536
DeflateCompressionLevel 9
DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio
LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
DeflateMemLevel 9
DeflateWindowSize 15
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch "Windows 98" gzip-only-text/html
BrowserMatch "MSIE [45]" gzip-only-text/html
<Location />
AddOutputFilterByType DEFLATE text/html text/plain application/x-javascript text/css application/x-httpd-php text/xml
SetInputFilter DEFLATE
SetOutputFilter DEFLATE
</Location>


mit mod_rewrite sollte es nicht durcheinander kommen eigentlich, rewrite urls (.html) sollten auch komprimiert werden hm.
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 12. August 2005 11:50

Hi

hab das SetInv noch dazugepappt - sonst werden die jpgs wieder komprimiert.

Lokal:
"GET /test.php HTTP/1.1" 1847/239983 (0%)
"GET /farben.css HTTP/1.1" 450/1579 (28%)


Extern:
"GET /test.php HTTP/1.0" -/- (-%)


Mhh extern ruft die Seite die test.php via http/1.0 auf - denke das egal... Bei anderen Testseiten isses mit 1.1 - und das gleiche Problem.

Hab hier noch nen Router mit integrierter Firewall - aber dem sollte ja egal sein, was auf Port 80 rausgeht - außer es sind Viren - die töten er sofort (glaub aber nur incoming *G*)

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 12. August 2005 12:00

hmm lokal läufts bei mir auch.. ich kapiers nich wieso nicht, sorry *g vieleicht weiß jemand der sich besser auskennt hier noch rat, gibt sicher zig die da bewanderter sind, hoffentlich *g
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 12. August 2005 12:16

Hi

wie? Lokal klappt es bei dir - von Extern auch nicht?

LazyOne79 wrote: gibt sicher zig die da bewanderter sind, hoffentlich *g


Das hoffe ich - deswegen hab ich mich ja hier angemeldet ;))

Lokal bringt mir mod_deflate nichts - bin mit 100mbit an meinem Server, der einen Tisch weiter steht, angebunden ;) ... nur nach draußen hin, hab ich nur 128k - wobei da gut 64k+ permanent belegt sind ...

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 12. August 2005 12:26

doch, extern auch.. und beim rootserver von mir ohne probleme mit obiger config hm. gibt hier sicher welche, bestimmt *g* ansonsten könntest mit file_cache & mmap rumspielen mh.
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 13. August 2005 02:52

Hi

argh ich könnte Amoklaufen ...

was rausgefunden :(

1.
Die test.html war zu GROSS ... 250kb mag der Apache nicht - er macht zwar den Ansatz, verwirft aber dann wohl (daher wohl 1500/240000 (-%)) - hab die Datei jetzt verkleinert - und es läuft.

2.
Das ganze funktioniert nur wenn ich direkt am Apache sitze und dort im Browser was aufrufe. Wenn ich an nen anderen Rechner im LAN gehe und dort was von Apache aufrufe wird nichts komprimiert ... gleiches ja auch bei aufrufen ausm Netz...

Und jetzt das Experiment: Ich schalte meine Router/Firewall-Software aus: Aufruf ausm LAN => KOMPRIMIERUNG! Aufruf ausm Internet => ebenfalls Komprimierung!

Mein Problem liegt also an meine Router/Firewall-Software :( Was ich überhaupt nicht verstehen kann :( Der sollte es doch vollkommen egal sein was mein Apache da macht - scheinbar killt die FW aber die Infos vom Browser das dieser encoding unterstützt ... nur wie fix ich diesen müll? unbekannt :(

Noch ne erkenntnis:
php.ini
Code: Select all
;output_buffering =
;output_handler =

;zlib.output_compression = off
;zlib.output_compression_level = 4

;zlib.output_handler =


Der Block scheint also unwichtig zu sein. Wenn ich ihn so auskommentiere, wird trotzdem komprimiert.

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby Wuppi » 16. August 2005 17:21

Hi

"The webpage is COMPRESSED / GZIPPED!" <- JieHah! ;)

Meine Firewall hat sich alles was über Port 80 rausging etwas genauer "angeschaut" und befunden das es "nicht gut" ist ;) - das hab ich jetzt irgendwie unterbunden bekommen - wie weiß ich net - wahrscheinlich hatse gemerkt das ich gerade nach ner neuen Router/Firewall-Soft geschaut habe ;)

@LazyOne79 - hab jetzt deine Variante - nochmals vielen Dank ;)

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 16. August 2005 17:55

hab ja nich viel gemacht *g würd mich nur interessieren, wie du das nun hinbekommen hast.. war die firewall wohl in panischer angst als du neue firmware/software gesucht hast *g pc-treiber.net is da ne gute anlaufstelle meist.. so genug werbung *g
jetz kannst dir ja file_cache und mmap näher ansehen :D
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 16. August 2005 18:41

LazyOne79 wrote:hab ja nich viel gemacht *g würd mich nur interessieren, wie du das nun hinbekommen hast.. war die firewall wohl in panischer angst als du neue firmware/software gesucht hast *g pc-treiber.net is da ne gute anlaufstelle meist.. so genug werbung *g
jetz kannst dir ja file_cache und mmap näher ansehen :D


*G* als ich das mit der FW entdeckte, hab ich an der Apache-Config NICHTS mehr geändert (=> Frust pur!) - meine Router-FW hat ne Funktion die sich "Protokol-Inspektor" nennt - das prüft IRGENDWAS z.b. bei HTTP - hab da vorgestern durch zufall ne möglichkeit gefunden, dieses auszustellen (für den Server-Port 80 - fürs surfen:80 ist der weiterhin an). Ich weiß leider net was diese funktion genau macht ...? Und zudem hab ich die FW-Rules neu geordnet ;) (und heute dann durch zufall im Log ne externe IP und ne Ratio gesehen *G*). Die Problemlösung kann ich daher nicht wirklich sauber eingrenzen - denke wird anderen die mit mod_deflate probleme haben, wahrscheinlich eh nicht weiterhelfen...

[ich möchte jetzt lieber nicht drüber nachdenken, wieviele der anderen konfigs vorher schon liefen - nur wg. der blöden FW nicht erkennbar waren - ich prüfe das jetzt auch lieber nicht nach - never change a running mod_deflate *G*]

File_cache mmap? - bringt mir das performance? (mein Server ist nen P3-733, 640MB, Win2kPro *G*) Killer-PHP-App wird wohl Gallery2 sein, die jetzt schon genutzt wird (das braucht nen bissel bis was angezeigt wird; LAHM)

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 16. August 2005 18:57

lol stimmt, hauptsache geht endlich.

When using file caching for Apache 1.3.26 and 2.0.47 ('mmap' parameter in httpd.conf), the performance improves for Apache 1.3.26 up to 45% and for Apache 2.0.47 up to 35%. When comparing Apache 1.3.26 against Apache 2.0.47, the latter is 25% better in non-cached mode and 15% in cached mode.


statische bilder und docs z.b. oder ne index.php deren code sich nimmer ändert, so machs ich jedenfalls.. bin da ja auch newbie *g ansonsten vieleicht noch disk_cache von apache und die settings allg. tunen (maxservers etc..) und mysql my.ini fein einstellen falls Du MySql benutzt, gallery2 kenn ich kaum, hatte nur coppermine und 4images in benutzung ab und an.
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 17. August 2005 11:40

LazyOne79 wrote:lol stimmt, hauptsache geht endlich.

When using file caching for Apache 1.3.26 and 2.0.47 ('mmap' parameter in httpd.conf), the performance improves for Apache 1.3.26 up to 45% and for Apache 2.0.47 up to 35%. When comparing Apache 1.3.26 against Apache 2.0.47, the latter is 25% better in non-cached mode and 15% in cached mode.


statische bilder und docs z.b. oder ne index.php deren code sich nimmer ändert, so machs ich jedenfalls.. bin da ja auch newbie *g ansonsten vieleicht noch disk_cache von apache und die settings allg. tunen (maxservers etc..) und mysql my.ini fein einstellen falls Du MySql benutzt, gallery2 kenn ich kaum, hatte nur coppermine und 4images in benutzung ab und an.


Hört sich an als wäre das sowas wie eAccelerator .. den nutze ich nämlich.

4images fand ich net so pralle - copppermine machte netten eindruck - aber damals konnte der paar sachen net so gut - bin daher damals auf gallery1 umgestiegen - und jetzt auf 2.

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

Postby LazyOne79 » 17. August 2005 11:47

ists auch.. so die art beinah, kannst einfach mal testen mit deiner test.html und mmcache, obs was bringt noch zusätzlich. die neue coppermine soll recht ok sein aber noch buggy die beta.

Code: Select all
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so

<IfModule mod_disk_cache.c>
  CacheRoot /opt/lampp/tmp
  CacheSize 20000000
  CacheEnable disk /
  CacheDirLevels 3
  CacheDirLength 3
  CacheGcInterval 2
  CacheMaxExpire 24
  CacheLastModifiedFactor 0.1
  CacheDefaultExpire 1
  CacheMinFileSize 1
  CacheMaxFileSize 292428
ExpiresActive On
ExpiresByType text/html "access plus 0 seconds"
ExpiresByType text/css "access plus 1 month"
ExpiresByType text/javascript "access plus 1 month"
ExpiresByType image/gif "access plus 2 month"
ExpiresByType image/jpeg "access plus 2 month"
ExpiresByType image/png "access plus 2 month"
<Files ~ "\.(js|css|gif|jpe?g|png)$">
Header append Cache-Control "public"
</Files>
</IfModule>
MMapFile /opt/lampp/htdocs/test.html


so ca..glaub ich *g
LazyOne79
 
Posts: 25
Joined: 17. July 2005 00:34
Location: München

Postby Wuppi » 18. August 2005 15:15

Hi

und wieder zurück zu dieser Baustelle ;)

File-Cache läuft - und mit dem Apache-Bench-Tool (-n 100 -c10) nen bissel gemessen - recht interessant:

Ich nutze File/Diskcache und eAccelerator - beide lagern natürlich auf HD Ihre Temps ab - aus Platzgründen, sind die Ordner bei mir KOMPRIMIERT (win2k; ntfs-kompression). Mal paar Zeiten:

Beide Ordner Komprimiert + Filecache => 746,92kb/s / 1,5sek
Beide Ordner Komprimiert + Filecache-Off => 616,21kb/s / 1,83sek
=> FileCache hat gewonnen ;)

Ok jetzt aber das interessante:
Beide Ordner NICHT Komprimiert + Filecache => 590,53kb/s / 2,09sek
Beide Ordner NICHT Komprimiert + Filecache-Off => 527,99kb/s / 2,24sek

(Alles Mittelwerte aus 3 Tests; auch bei den Einzel-Ergebnissen sah es so aus)

Wenn die Ordner komprimiert sind, hab ich also MEHR speed ... trotz das komprimierte Files bei jedem zugriff dekomprimiert werden müssen ... Hätte ich absolut nicht gedacht!

Also apache/php hab ich schon ein wenig getuned bekommen - glaub jetzt muß ich mal nen Thread im mysql-Forum aufmachen - der müll will nämlich überhaupt nicht so recht ...

Gruß
Wuppi
Wuppi
 
Posts: 25
Joined: 11. August 2005 00:42

PreviousNext

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests