SSL läuft nichts mehr

Alles, was den Apache betrifft, kann hier besprochen werden.

SSL läuft nichts mehr

Postby Antivirus » 05. May 2003 18:17

Ich wollte mir ein Zertifikat machen, genau so wie is Kai erklärt hat.

1. Server Key erstellen mit: /opt/lampp/bin/openssl genrsa 1024 > /opt/lampp/etc/ssl.key/server.key

2. Diesen Key signieren: /opt/lampp/bin/openssl req -new -x509 -key /opt/lampp/etc/ssl.key/server.key -out /opt/lampp/etc/ssl.crt/server.crt

alles ging gut bei Common name habe ich http://10.0.0.10 (locale Adresse) eingegeben.

als ich Apache reloaden wollte kam ein error....

Code: Select all
[Mon May 05 19:09:15 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon May 05 19:09:15 2003] [error] Unable to configure RSA server private key
[Mon May 05 19:09:15 2003] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
[Mon May 05 19:12:15 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)


danach habe ich mit dem Zertifikat nochmals angefangen und bei Common name https://10.0.0.10 eingegeben

Jetzt läuft Apache wenigstens wieder aber ich habe immer noch diesen Fehler:

Code: Select all
[Mon May 05 19:12:15 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon May 05 19:12:15 2003] [warn] RSA server certificate CommonName (CN) `https://10.0.0.10' does NOT match server name!?
[Mon May 05 19:12:16 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon May 05 19:12:16 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon May 05 19:12:16 2003] [warn] RSA server certificate CommonName (CN) `https://10.0.0.10' does NOT match server name!?
[Mon May 05 19:12:16 2003] [notice] Digest: generating secret for digest authentication ...
[Mon May 05 19:12:16 2003] [notice] Digest: done
[Mon May 05 19:12:17 2003] [notice] Apache/2.0.44 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.44 OpenSSL/0.9.7 PHP/4.3.1 DAV/2 configured -- resuming normal operations



Jemand eine Idee.....?
User avatar
Antivirus
 
Posts: 124
Joined: 11. April 2003 19:33

Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests