htaccess: Verzeichnis schützen Unterverzeichnis aber nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess: Verzeichnis schützen Unterverzeichnis aber nicht

Postby mdg-webmaster » 04. February 2005 14:24

Hallo,

ich habe ein kleines Problem. Ich habe ein Privatverzeichnis, das über ssl läuft auf meinen Apache angelegt .../privat

Dieses Verzeichnis ist htaccess Passwortgeschützt. Das funktioniert auch alles wunderbar.

Jetzt habe ich ein Unterverzeichnis erstellt, das aber wiederum offen sein soll. .../privat/unterverzeichnis, aber es wird auch nach dem Usernamen und Passwort gefragt.

Ich habe jetzt noch eine .httaccess Datei erstellt mit folgendem Inhalt in dem Unterverzeichnis erstellt:

AuthUserFile /dev/null
AuthGroupFile /dev/null
AuthName DenyViaWeb
AuthType Basic


<Limit GET>
order allow,deny
deny from all
</Limit>

Die Passwortabfrage kommt zwar nicht mehr, aber ich habe da kein Zugriff auf das Verzeichnis. Das Unterverzeichnis sollte aufgelistet werden, weil ich das auch in der httpd.conf so eingerichtet habe.

Kann mir eienr helfen und sagen was in der htaccess noch fehlt damit das Unterverzeichnis ohne Abfrage aufgelistet wird ?

Vorweg: Alle Verzeichnisse werden laut httpd.conf nicht gelistet. Es muss immer eine index.php, html... vorhanden sein. Nur die, bei denen ich es ausdrücklich erlaube.

Grüße
mdg-webmaster
mdg-webmaster
 
Posts: 21
Joined: 24. January 2005 00:31

Postby glitzi85 » 04. February 2005 15:52

Wenn du diese Datei in's Unterverzeichnis gestellt hast, dann ist schon klar, dass da nix mehr geht. Ich weiß nicht genau wie man die Authentifizierung wieder abschaltet, aber probier es mal entweder so:

AuthType none
Order allow,deny
allow from all

oder einfach ohne AuthType. Das was du geschrieben hast:

<Limit GET>
order allow,deny
deny from all
</Limit>


bedeutet, dass alle Anfragen (normale Seitenaufrufe laufen per GET) abgewiesen werden.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby mdg-webmaster » 04. February 2005 16:10

Hallo glitzi85,

1. Variante bringt Error 500
2. Variante bringt Error 403

Wenn ich bei 2. 'deny from all' in 'allow from all' ändere, kommt wieder die Abfrage, aber man erreicht damit nix, weil ja keine pwd verlinkt ist.

Danke trotzdem.

mdg-webmaster
mdg-webmaster
 
Posts: 21
Joined: 24. January 2005 00:31

Postby Wiedmann » 04. February 2005 16:10

Jetzt habe ich ein Unterverzeichnis erstellt, das aber wiederum offen sein soll. .../privat/unterverzeichnis, aber es wird auch nach dem Usernamen und Passwort gefragt.

Am einfachsten legst du "/unterverzeichnis" erst gar nicht als Subdir zu "/privat" an. Ansonten benutze Satisfy.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mdg-webmaster » 04. February 2005 16:35

Vielen dank. Statisfy war das Stichwort. Jetzt klappt es.

mdg-webmaster
mdg-webmaster
 
Posts: 21
Joined: 24. January 2005 00:31


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests