Installationsanleitung MySQL als Dienst nach Anleitung

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Installationsanleitung MySQL als Dienst nach Anleitung

Postby Walter_vdV » 20. January 2005 21:01

Habe, wie in der Readme-Datei beschrieben, my.cnf bzw. my nach C:\ kopiert und mit dem Batch-File MySQL als Dienst eingerichtet. MySQL ist gestartet alles wunderbar. Als ich dann in my.cnf was ändern wollte war die Datei weg und eine Datei my.cnf.old da. Änderung vorgenommen Datei in my bzw. my.cnf geändert, Dienst beendet u. Dienst wieder hochgefahren, MySQL wollte nicht mehr starten. Dienst deinstalliert und wieder installiert. das gleiche wieder, habe aber dann festgestellt, dass in C:\Windows eine my.ini angelegt wurde und diese auch für Änderungen zuständig ist. Ist das Verhalten normal. Wenns funktioniert ist ja gut, aber mich stören immer Dateien die nur so da sind und eigentlich keinen rechten Sinn ergeben, wie die my.cnf.old. und vielleicht dann evtl. bei einer anderen Änderung dann doch wieder zuständig sind.
Gruss Walter (übrigens habe ich XP Prof SP2)
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09

Postby Wiedmann » 20. January 2005 21:11

Der MySQL von XAMPP benutzt normal die "my.cnf" in "\xampp\apache\bin".

Nur wer unbedingt dieses unsägliche Tool "WinMySQLAdmin" benutzen will, muss diese Datei erst nach "C:\" kopieren, damit dieses Tool diese dann nach "%WINDIR%\my.ini" kopieren und umbenennen kann. Dort legt dieses Tool dann seine Einstellungen ab.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Walter_vdV » 21. January 2005 09:44

@Wiedmann
Sorry, was Du sagst ist schlichtweg falsch. Im Verzeichnis "\xampp\apache\bin" gibt es keine einzige Datei (auch in "\xampp\apache" nicht) die auf eine Konfigurationsdatei von MySQL hinweist. Ausserdem dieses komische Tool "WinMySQLAdmin" (wenn man sowas überhaupt als Tool bezeichnen darf) benutze ich gar nicht. Es geht eigentlich nur darum, dass es eine einzige zuständige Konfigurationsdatei gibt (für MySQl als Dienst) egal mit Suffix oder ohne und in welches Verzeichnis das gelegt wird. Aber ich werde das am Wochenende noch mal durchtesten.
Gruss Walter.
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09

Postby Wiedmann » 21. January 2005 10:46

yup, der Pfad war wirklich falsch. Sorry.

Die Datei liegt in "\xampp\mysql\bin".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Walter_vdV » 21. January 2005 11:06

Keine Ursache. Habe nur darauf hingewiesen, damit kein anderer auf ein falsche Fährte gelockt wird.
Gruss Walter
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09

Postby Walter_vdV » 25. January 2005 20:06

Ich hab das jetzt am Wochenende noch mal getestet. Also wenn MySQL als Dienst laufen soll, dann ist bei W2k die Datei C:\my.cnf (habe nicht probiert ob sie auch my.ini heissen kann) und bei WXP die Datei C:\Windows\my.ini notwendig. So ist es wenigstens bei mir.
Gruss Walter
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09

Postby Wiedmann » 25. January 2005 20:12

Dann ist der Dienst aber nicht auf einem jungfräulichem System mit der Batchdatei vom XAMPP eingerichtet worden...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Walter_vdV » 25. January 2005 20:41

Also auf dem Win2k hatte ich vorher MySQL installiert. Bevor ich dann xammp genommen habe, habe ich MySQL zuerst deinstalliert aber mit einem Installationsüberwachungstool, dass wirklich auch den letzten Rest einer Installation rausschmeisst (siehe meinen Beitrag zu Zonelabs). Habe aber dann trotzdem noch mal die Registry durchforstet und die Verzeichnisse, ob nicht doch noch irgendwie ein Hinweis steht (mach ich immer wenn so ein Dienst läuft). Bei meinem WXP war wirklich nichts mehr drauf, da ich den PC vorher platt gemacht habe (format c:) und völlig neu aufgesetzt habe. War ja auch der Grund warum ich jetzt mal xampp probiert habe, bevor ich die anderen Sachen wieder drauf lade. Von xampp habe ich NICHT die Inst.-Version benutzt. Kann natürlich sein, dass ich nicht die Vers. v. 29.12.04 drauf habe, weil ich gerade in einem Beitrag gelesen habe, dass bei meinem Download noch nicht alle Mirrors die neueste Vers. hatten und es gab ja schon mal einen Beitrag wo auf das angebliche Wirrwar (für NewBies) mit den Konfigurationsdateien für MySQL hingewiesen wurde, mit dem Hinweis, das in der allerletzten Vers. in dieser Hinsicht noch mal was geändert wurde.
Gruss Walter
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09

Postby Wiedmann » 25. January 2005 20:53

Bei meinem WXP war wirklich nichts mehr drauf, da ich den PC vorher platt gemacht habe (format c: und völlig neu aufgesetzt habe.

Dann hast du zumindest zuerst einmal den WinMYSQLAdmin aufgerufen bevor du die Batchdatei "mysqk_installservice.bat" benutzt hast.

a) Über die Batchdatei wird dem Dienst bei der Installation gesagt wo die Optionsdatei zu finden ist. Gibt es bereits einen Diensteintrag für MySQL, wird dieser Eintrag durch die Batch nicht gändert oder ergänzt.

b) Der Dienst nimmt die Optionsdatei die bei der Installation angegenen wurde. Gibt es die angegebene Datei nicht, oder der Eintrag für die Optionsdatei ist nicht vorhanden, sucht MySQL erst in "C:\" und danach in "%systemroot%".

c) wird auf diese Weise keine gültige Optionsdatei gefunden, kann der Dienst nicht starten. (Als Konsolenanwendung würde MySQL auch ohne diese Datei starten).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Walter_vdV » 25. January 2005 21:06

Sorry, habe ich nicht gemacht. Ich habe die my oder my.cnf nach C: kopiert, die Batch-Datei für das Einrichten als Dienst aufgerufen und wie schon oben gesagt, danach war auf meinem System die Datei C:\my.cnf.old und in Windows die My.ini aber erst nach dem ich den Dienst einmal beendet und wieder gestartet habe. Diese komische Admin-Tool benutze ich schon seit mind. 2 Jahren nicht mehr. Übrigens die ....old kann ich mittlerweile löschen ohne das es Probleme gibt.
Walter_vdV
 
Posts: 48
Joined: 20. January 2005 20:09


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests