Ordneranischt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Ordneranischt

Postby Brueckenhauer » 13. January 2005 17:43

Ist es möglich die Ordneransicht im Browser irgendwie auszustellen???
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Wiedmann » 13. January 2005 17:49

die Ordneransicht

:?:

Du meinst die Auflistung des Verzeichnisinhaltes (mod_autoindex)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Brueckenhauer » 13. January 2005 17:50

genau, wie kann ich das ausschalten?
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Wiedmann » 13. January 2005 18:14

Steht im Manual.

(Der Link vorher war nicht umsonst dort...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Brueckenhauer » 13. January 2005 18:22

auf deutsch ???
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby thor » 13. January 2005 18:47

Das Manual ist etwas gewöhnungsbedürftig....

Hier ein Beispiel:
http://localhost/pdf
zeigt normalerweise den Inhaltes des Verzeichnisses /xampp/htdocs/pdf an.

Ändere in httpd.conf den Eintrag für das Verzeichnis htdocs/pdf:
Code: Select all
    Alias /pdf "D:/Xampp/htdocs/pdf/"

    <Directory "D:/Xampp/htdocs/pdf/">
        Options Indexes MultiViews ExecCGI
        AddHandler cgi-script .cgi .exe
        Order allow,deny
        Allow from all
    </Directory>

in
Code: Select all
    Alias /pdf "D:/Xampp/htdocs/pdf/"

    <Directory "D:/Xampp/htdocs/pdf/">
        Options  MultiViews ExecCGI
        AddHandler cgi-script .cgi .exe
        Order allow,deny
        Allow from all
    </Directory>

Jetzt wird der Verzeichnisinhalt nicht mehr angezeigt. (Neustart von Apache nach Änderung nicht vergessen.)

Thorsten
thor
 
Posts: 13
Joined: 07. September 2004 13:07

Postby Brueckenhauer » 13. January 2005 18:58

thx für die beschreibung, wie kann ich das für alle unterverzeichnisse sperren?
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby thor » 13. January 2005 19:27

Ca. bei Zeile 340 in httpd.conf steht:
Code: Select all
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "D:/Xampp/htdocs">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI Multiviews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs-2.0/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks MultiViews Includes ExecCGI
   AddType text/html .shtml
        AddHandler server-parsed .shtml
        AddHandler cgi-script .cgi .pl
...

Hier wieder die "Indexes" herausschmeißen.

Thorsten
thor
 
Posts: 13
Joined: 07. September 2004 13:07

Postby Brueckenhauer » 14. January 2005 06:19

hab ich gemacht, klappt aber irgendwie nicht...
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby deepsurfer » 14. January 2005 15:46

Code: Select all
Options Indexes FollowSymLinks MultiViews Includes ExecCGI



in

Code: Select all
Options FollowSymLinks MultiViews Includes ExecCGI

ändern (also Indexes weg)

oder
Code: Select all
Options -Indexes FollowSymLinks MultiViews Includes ExecCGI

(ein minus vor dem Indexes setzen)

testen und wieder melden

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Brueckenhauer » 14. January 2005 22:45

funktioniert irgendwie nicht.... :(
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby Rolidor » 15. January 2005 01:15

Moin.

Browser-Cache geleert? Apache neu gestartet?
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby deepsurfer » 15. January 2005 09:40

benutzt du ein VHOST ??????

dann solltest du im VHOST in der kategorie <Directory>
den INDEXES Befehl herausnehmen bzw. ein minus davor setzen.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Brueckenhauer » 15. January 2005 10:02

also, ich habe in dem Ordner php -> php4 -> http4.conf beide sachen probiert, habe dann den apache neu gestartet und es ändert sich nix... ich habs einmal über localhost und einmal über mk.ath.cx ausprobiert, aber bei beiden das gleiche....
Mfg
Brueckenhauer
Brueckenhauer
 
Posts: 20
Joined: 12. February 2004 17:36

Postby deepsurfer » 15. January 2005 10:06

php -> php4 -> http4.con


Sorry, aber wer sprach von dieser datei ?????????

Es geht um die \xampp\apache\conf\httpd.conf

Diesen Hinweiss als solches ist auch in dem LINK von Wiedmann, zur Dokumentation vorhanden...

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests