MySQL meldet: Dokumentation #2003 - Der Server antwortet...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL meldet: Dokumentation #2003 - Der Server antwortet...

Postby Duddits » 12. January 2005 18:37

hallo zusammen

xampp version 1.4.11 [php: 5.0.3]
windows xp home sp2

xampp installiert und gestartet. alles funktioniert aber sobald ich phpmyadmin anklicke kommt diese meldung:

MySQL meldet: ?
#2003 - Der Server antwortet nicht.

hier die my.ini :

#This File was made using the WinMySQLAdmin 1.4 Tool
#12.01.2005 16:11:32

#Uncomment or Add only the keys that you know how works.
#Read the MySQL Manual for instructions

[mysqld]
basedir=C:/apachefriends/xampp/mysql
bind-address=127.0.0.1
datadir=C:/apachefriends/xampp/mysql/data
language=C:/apachefriends/xampp/mysql/share/german
#slow query log#=
tmpdir=C:/tmp
port=3306
set-variable=key_buffer=16M
[WinMySQLadmin]
Server=C:/apachefriends/xampp/mysql/bin/mysqld-nt.exe
user=***
password=***

bitte helft mir.

mfg Duddits
Duddits
 
Posts: 3
Joined: 12. January 2005 18:23

Postby Wiedmann » 12. January 2005 18:44

xampp installiert und gestartet.

Wie?

alles funktioniert aber sobald ich phpmyadmin anklicke kommt diese meldung:

Irgendwas geändert? (z.B. Rechte)

user=***
password=***

Die hast MySQL als Dienst installiert? (Update oder Neuinstall?)

hier die my.ini :

XAMPP benutzt normal die my.cnf ("\xampp\mysql\bin")

BTW:
was steht in der Logdatei *.err ("\xampp\mysql\data")?
(Bei Dienst auch in der Windows Ereignisanzeige schauen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Duddits » 12. January 2005 21:40

hallo wiedmann

also ich habe alles gelöscht und nochmal neu installiert. xampp mit xampp basic start gestartet und wieder die gleiche meldung bei phpmyadmin bekommen. ich habe nirgendwo etwas verändert. hier das errorlog :

mysql\bin\mysqld.exe: ready for connections.
Version: '4.1.8' socket: '' port: 3306 Source distribution
mysql\bin\mysqld: ready for connections.
Version: '4.1.8' socket: '' port: 3306 Source distribution
mysql\bin\mysqld.exe: ready for connections.
Version: '4.1.8' socket: '' port: 3306 Source distribution
mysql\bin\mysqld.exe: ready for connections.
Version: '4.1.8' socket: '' port: 3306 Source distribution

mfg Duddits
Duddits
 
Posts: 3
Joined: 12. January 2005 18:23

Postby Wiedmann » 13. January 2005 11:48

Hmm. Wenn der XAMPP neu installiert wurde und noch keine Einstellungen gemacht wurden, sollte das doch eigentlich gehen,,, *grübel*

Das Log sieht jedenfalls normal aus.

Hast du die my.* - Dateien in "C:\" und "C:\Windows" auch gelöscht? Schau auch mal unter Dienste nach, ob da nicht noch ein alter MySQL als Dienst eingetragen ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Duddits » 13. January 2005 12:22

hallo wiedmann

alles zurück! hab den fehler gefunden! wiedmann vielen dank für deine mühe. der fehler lag an meine norton firewall. wenn ich sie deaktiviere funzt alles. also vielen dank nochmal für deine mühe.

mfg Duddits
Duddits
 
Posts: 3
Joined: 12. January 2005 18:23


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests