php - Browser will Datei speichern?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php - Browser will Datei speichern?

Postby otoo » 11. January 2005 12:07

Hallo,

hab xampp installiert. Läuft, meine mysql Anwendungen funktionieren (hatte vorher Foxserv). :D

Wollte jetzt ein neues Gästebuch installieren (local zum Testen)
und beim Installieren führen die Browser (IE o. Firefox egal)
die nächste php Datei nicht aus, sondern bieten mir den Speichern unter/Öffnen Dialog an.
Kann dann den Link nur kopieren und in der Adresszeile einfügen
und dann starten :?

Wie kann ich das wieder ändern/reparieren :?:

CU otoo

neueste Xampp Version, PHP Version 5.0.3, Win XP Pro XP1 u.a. Updates
otoo
 
Posts: 4
Joined: 11. January 2005 11:55

Postby PF4 » 11. January 2005 13:11

Was gibste den in den Browser ein?
schon http://localhost/datei.php oder?
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby otoo » 11. January 2005 13:56

PF4 wrote:Was gibste den in den Browser ein?
schon http://localhost/datei.php oder?

Ja, genauso. Nur dann kommt:Bild mit Fehler

CU otoo
otoo
 
Posts: 4
Joined: 11. January 2005 11:55

Postby PF4 » 11. January 2005 14:06

sehr hilftreicht wenn du alles wichtige wegkillst!
Sicher das da nen XAMPP läuft und ned nen anderer Apache?
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby otoo » 11. January 2005 14:20

Ja, mein Foxserv hab ich komplett gelöscht und jetzt läuft eine andere Version als vorher:
XAMPP Version 1.4.11
[PHP: 5.0.3]

Bild mit Fehler
Auch ein Neustart hat nichts geändert.

Besten Dank, für die schnellen Hilfeversuche!

CU otoo
otoo
 
Posts: 4
Joined: 11. January 2005 11:55

Postby Dschingis » 11. January 2005 14:30

soll mal einer verstehen, wieso du das C: oder D: wegstreichst :roll:

ansonsten sieht es so aus als ob das php nicht richtif funktioniert, und er dir die komplette php datei anzeigt - sie runterladen will

das der server hinhaut sollte eigentlich mit dem nicht mehr existenten foxserv und dem localhost richtiggestellt sein :)
Dschingis
 
Posts: 14
Joined: 09. January 2005 01:22

Postby otoo » 11. January 2005 14:53

Dschingis wrote:soll mal einer verstehen, wieso du das C: oder D: wegstreichst :roll:
--> Na gut war zuviel des Löschens :oops:
Hilft irgend eine Änderung in der registry weiter?
otoo
 
Posts: 4
Joined: 11. January 2005 11:55

Postby BMF » 11. January 2005 14:59

Hi,

hast du angst wir würden deinen PC hacken oder wie :shock:
1. machen wir sowas nicht
2. ist dein apache nicht im Internet erreichbar
3. deine Router Firewall ist an
4. die Ports sind nicht frei

Fazit: man kann deinen PC hacken, deswegen doch auf Nummer sicher gehen :D :D :D
Irren ist menschlich. Aber um richtigen Mist zu bauen, braucht man einen Computer.
User avatar
BMF
 
Posts: 101
Joined: 29. December 2004 18:19
Location: NRW

Postby Wiedmann » 11. January 2005 15:00

Wollte jetzt ein neues Gästebuch installieren (local zum Testen)

- Welches?
- In welchem Verzeichnis ist der Apache/das Gästebuch installiert?

und beim Installieren führen die Browser (IE o. Firefox egal)
die nächste php Datei nicht aus, sondern bieten mir den Speichern unter/Öffnen Dialog an.

- ein Browser führt keine PHP-Datei aus, sondern zeigt an/downloaded was der Server ihm schickt.
- Wie sieht der Link genau aus auf den du da klickst?

Kann dann den Link nur kopieren und in der Adresszeile einfügen
und dann starten

Wie sieht die URL aus, die du in der Adresszeile einfügst?

Hilft irgend eine Änderung in der registry weiter?

Nein

hatte vorher Foxserv

Was wird bei phpinfo() angezeigt unter:
- "SERVER_SIGNATURE"
- "DOCUMENT_ROOT"
- "Configuration File (php.ini) Path"
?

Wie kann ich das wieder ändern/reparieren

Welche Änderungen hast du an der Apache-Config vogenommen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests