Probleme mit Namebased-Virtual-Hosts

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit Namebased-Virtual-Hosts

Postby winnie » 29. April 2003 21:32

Moin, Moin,

ich habe bislang bereits den Apache eingesetzt und dort sog. namebased Virtual-Hosts gefahren, bei denen mehrere Websites auf einer IP-Adresse lauten. Dabei sind für alle verwendeten lokalen Domain-Namen im ebenfalls lokalen DNS-Server die gleiche IP-Adresse des Servers hinterlegt. Wenn das richtig eingestellt ist, erkennt der Apache ansich bei HTTP 1.1 welche Domin ursprünglich angefordert wurde und unterscheidet dadurch die Virtual-Hosts. ...soweit die Theorie (bzw. die Vergangenheit, weil bisher hat das Prima funktioniert) !

Mit WAMPP (das ich als solches sehr begrüße) funktioniert alles ganz prima .... bis auf meine Namebased Virtual-Hosts. Dabei liegt das ganz offensichtlich an der http.conf, denn wenn ich die alte Konfigurationsdatei verwendete, funzt alles wieder (dafür aber andere Sachen nicht mehr, wie Perl, Web-Analyzer .....).

Ich schätze, dass sich irgend eine der vielen Einstellungen der hfftp.conf aus WAMPP mit dem Prinzip der Namebased Virtual-Hosts beisst, denn sobald die Zeile "NameVirtualHost *" nicht mehr auskommentiert ist, erhalte ich auf alle Web-Anfragen an den Apache den Fehlcode "400 - Bad Request".

Hat jemand eine Idee ???
winnie
 
Posts: 1
Joined: 29. April 2003 21:22

namebased VH

Postby Michael » 30. April 2003 05:30

Hi

koüier doch einfach, aus deine "alten" http.conf den Bereich der Virtualhosts, also (bei mir) Sektion 3 Virtualhosts in deine neue. Eigentlich sind alle Einstellungen wie
NameVirtualHost *

<Virtualhost * >
ServerName deine.domain.de
DocumentRoot c:/was/weis/ich/wo/die/liegen
..
..
</Virtualhost>
<Virtualhost * >
ServerName deine.2domain.de
DocumentRoot c:/was/weis/ich/wo/diese/liegen
..
..
</Virtualhost>

etc dort drinnen
Michael
 

Postby Guest » 01. May 2003 21:16

Michael wrote:koüier doch einfach, aus deine "alten" http.conf den Bereich der Virtualhosts, also (bei mir) Sektion 3 Virtualhosts in deine neue.


Das scheint er ja wohl schon ausprobiert zu haben:

winnie wrote:Ich schätze, dass sich irgend eine der vielen Einstellungen der hfftp.conf aus WAMPP mit dem Prinzip der Namebased Virtual-Hosts beisst, denn sobald die Zeile "NameVirtualHost *" nicht mehr auskommentiert ist, erhalte ich auf alle Web-Anfragen an den Apache den Fehlcode "400 - Bad Request".
Guest
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests