PHP-Scripts per Scheduled Task starten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP-Scripts per Scheduled Task starten

Postby jrt » 03. January 2005 16:26

Hi!

Nach einem Update auf XAMPP WIN32 1.4.10a habe ich ein neues Problemchen und komme damit einfach nicht weiter:
Meine PHP-Dateien funktionieren zwar ganz normal, wenn sie per Browser/HTTP abgerufen werden, aber nicht mehr, wenn der Server sie per Scheduled Task selbst startet.

Bisher ging das z.B. mit folgender Befehlszeile in einer BAT-Datei:
D:\xampp\apache\bin\php -f D:\xampp\htdocs\meinedatei.php

Der Server zeigt die folgende Fehlermeldung:
---------
PHP Warning: PHP Startup: +y??+?
?: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP compiled with module API=20041030, debug=0, thread-safety=1
These options need to match
---------


Leider wird nicht angezeigt, WELCHES Modul das Problem verursacht. Handelt es sich vielleicht um eine PHP Extension?
In meiner PHP.INI sind nur zwei Extensions aktiviert: php_gd2.dll und mmcache.dll
Die erste brauche ich unbedingt, das Abschalten der zweiten Extension macht keinen Unterschied. Auch dann erscheint die Fehlermeldung und das PHP-Script wird nicht ausgeführt. :(

Hat jemand eine zündende Idee?

Vielen Dank im voraus für jegliche Hilfe!

Rene
jrt
 
Posts: 6
Joined: 30. March 2004 15:34

Postby Wiedmann » 03. January 2005 16:37

Nach einem Update auf XAMPP WIN32 1.4.10a

aktuell wäre Version 1.4.11

Führe mal den php-switch 2x aus und probiers nochmal.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

php-switch funktioniert!

Postby jrt » 04. January 2005 08:23

Danke :D
jrt
 
Posts: 6
Joined: 30. March 2004 15:34


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests