Problem mit 1.4.11 und MySQL -> Error 1067

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit 1.4.11 und MySQL -> Error 1067

Postby CrazyWolf1981 » 29. December 2004 18:21

Hi,

seit der neusten Version kann ich MySQL nicht mehr starten. Weiß jemand woran das liegt?


Installing MySQL as an Service
1 Datei(en) kopiert.
Service successfully installed.
Try to start the MySQL deamon as service ...
mysql wird gestartet.
mysql konnte nicht gestartet werden.

Ein Systemfehler ist aufgetreten.

Systemfehler 1067 aufgetreten.

Der Prozess wurde unerwartet beendet.



Hab ein Update gemacht aber auch bei der Neuinstallation das gleiche. Woran kann das liegen?

Danke schonmal,
Wolf
CrazyWolf1981
 
Posts: 23
Joined: 03. October 2004 21:51

Postby Wiedmann » 29. December 2004 18:36

Was steht in der Ereignisanzeige von Windows?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CrazyWolf1981 » 29. December 2004 19:01

Da ist ein Fehler aufgeführt:

Do you already have another mysqld server running on port: 3306 ?



aber es läuft kein anderes mysql.

edit: es war doch ein Dienst am laufen. Komisch, hatte mysql vorher deinstalliert. Jetzt gehts. Danke.
CrazyWolf1981
 
Posts: 23
Joined: 03. October 2004 21:51

Postby N'exito » 30. December 2004 00:46

Hallo,

ich habe genau das gleiche Problem, aber bei mir ist nur dieser eine mysql Dienst in der Liste.

Kann mir jemand einen Tipp geben, wie ich das hinbekomme?

Gruß,
Roman
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Postby deepsurfer » 30. December 2004 12:32

habt ihr vielleicht mal zu testzwecken den APACHEN und den MYSQL als "Service" installieren lassen,
dann aber nur den Apachen wieder DEinstalliert und den Mysql vergessen. ???

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby BMF » 30. December 2004 12:41

Hi,

das Problem hatte ich auch mal, man denkt MySQL läuft nicht mehr, aber öffne mal den Taskmanager und da siehste dann MYSQL.exe oder mysql.exe einfach den Task beenden und dann auf "XAMPP start" dann funktioniert wieder alles.

Viele Grüße
BMF
User avatar
BMF
 
Posts: 101
Joined: 29. December 2004 18:19
Location: NRW

Postby N'exito » 30. December 2004 12:42

Ich glaube ihr versteht das falsch.

Ich habe Apache sowie MySQL absichtlich als Service installiert, damit ich Xampp nicht immer starten muss. Aber der Service, den ich mithilfe von xampp installiert hab, lässt sich nicht starten.
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Postby deepsurfer » 30. December 2004 13:12

Ich glaube ihr versteht das falsch.


dann hast du es halt falsch beschrieben.... 8)

denn aus deiner Fehlermeldung geht nicht hervor WIE du xampp startest.
Es gibt bekanntlich drei variationen.

Mein Hinweiss sollte ein Dich / jemandem dazu bringen zu überlegen ob er nicht etwas vergessen hat.

Ansonsten wäre der zweite Hinweis und Lösungsweg BMF nachzugehen um auszuschliessen das MySQL nicht DOCH noch im hintergrund läuft.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby N'exito » 30. December 2004 13:16

Laso im Hintergrund laufen nur Apache und Filezilla, habs gerade im Taskmanager getestet. Wenn ich in die Dienste Verwaltung von Windows XP Professional gehe ist da auch der Dienst MySQL aufgelistet, den ich wie in der Anleitung von xampp als Dienst installiert habe.

Aber dieser Dienst lässt sich nicht starten.

Der Webserver läuft auch bis auf MySQL einwandfrei ohne jegliche Probleme.
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Postby deepsurfer » 30. December 2004 13:21

mach bitte eine DEinstallation mit mysql_uninstallservice.bat

dann schau ob der Eintrag in der Dienst-Liste verschwunden ist.

meld dich..
chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby N'exito » 30. December 2004 13:36

Hab das jetzt gemacht und der Service ist raus.

Gibt es denn noch ne andere Möglichkeit MySQL als Service laufen zu lassen?
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Postby deepsurfer » 30. December 2004 14:14

so.... da du nun den service raus hast aus der DIENST-liste, starte den MySQL testweise mit der mysql_start.bat im xampp verzeichniss.

Wenn jetzt MySQL hochfährt ist schonmal ein gewaltiger schritt getan.

testen ....



wenn es geht mit mysql_stop.bat erstmal den MySQL schliessen und dann
im /mysql Verzeichnis den mysql_installservice.bat benutzen.


Warum dieser umweg !?!
wie ich vermute hast du vor dem update mal den xampp über die service installer gestartet, aber vor dem update diese nicht wieder gestoppt.

testen und melden.
chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby N'exito » 30. December 2004 14:53

Also das starten darüber geht.

Leider funktioniert das starten des Dienstes danach immer noch nicht.
Das stoppen des Services funktioniert auch nicht. Ich konnte ihn nur manuell über den Taskmanager stoppen.

Danke schonmal für deine Hilfe.

Gruß,
Roman
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Postby deepsurfer » 30. December 2004 15:05

ok jetzt haben wir aber eine grundstufe erreicht, worauf mann die fehlererscheinung eventuell nachvollziehen kann.

welches system benutzt du...hast du etwaige scanner/blocker etc im hintergrund laufen?
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby N'exito » 30. December 2004 16:32

Hab Windows XP Professional SP2

Im Hintergrund laufen nur Norton Antivirus 2005, Trillian, nen Konfigurationsprogramm von meiner Soundkarte und noch Apache und Filezilla als Dienst. Das ist alles.

Gruß,
Roman

PS: Danke für deine Bemühungen
N'exito
 
Posts: 22
Joined: 30. December 2004 00:35

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests