Problemen mit mambo sql

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problemen mit mambo sql

Postby xanadu » 29. December 2004 07:22

Sali zäme habe folgendes problem. Mambo installer kann den sql datenbank nicht herstellen mit grund

SQL=Specified key was too long; max key length is 1000 bytes:
- - - - - - - - - -
# Table structure for table `mos_core_acl_aro`

Code: Select all
CREATE TABLE `mos_core_acl_aro` (
  `aro_id` int(11) NOT NULL auto_increment,
  `section_value` varchar(240) NOT NULL default '0',
  `value` varchar(240) NOT NULL default '',
  `order_value` int(11) NOT NULL default '0',
  `name` varchar(255) NOT NULL default '',
  `hidden` int(11) NOT NULL default '0',
  PRIMARY KEY  (`aro_id`),
  UNIQUE KEY `section_value_value_aro` (`section_value`,`value`),
  UNIQUE KEY `mos_gacl_section_value_value_aro` (`section_value`,`value`),
  KEY `hidden_aro` (`hidden`),
  KEY `mos_gacl_hidden_aro` (`hidden`)
) TYPE=MyISAM
= = = = = = = = = =

Habe auch parr lösungen aus probiert von forum das man ihn my.cnf folgender zeile einfügt

character-set-server = latin1
collation-server = latin1_general_ci


hilft leider auch nicht mein my.cnf sieht volgender masse aus gerade

# The MySQL client
Code: Select all
[client]
# password       = your_password
port            = 3306
socket          = mysql

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port            = 3306
socket          = mysql
skip-locking
character-set-server = latin1
collation-server = latin1_general_ci
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
net_buffer_length = 8K
myisam_sort_buffer_size = 64M
log-bin
server-id       = 1
thread_cache = 8

basedir=/xampp/mysql
tmpdir=/xampp/tmp
datadir=/xampp/mysql/data

#bind-address=192.168.1.1
#log-update     = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable   = bdb_cache_size=4M
#set-variable   = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /xampp/mysql/
#innodb_log_arch_dir = /xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[myisamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=/xampp/mysql/bin/mysqld-nt.exe



Wen jemand wirklich lösüng vorschläge hat bin ich wirklich sehr dank bar
xanadu
 
Posts: 4
Joined: 29. December 2004 07:02

Postby Wiedmann » 29. December 2004 07:51

Obiges SQL geht bei mir ohne Probleme wenn die zwei Einstellungen aktiv sind.

MySQL hast du neu gestartet? MySQL benutzt auch die "my.ncf" die du editiert hast (frag die Server-Variablen ab, und schau ob die Einstellungen gesetzt sind).

Auf welches Charset ist denn die Datenbank eingestellt, wohin diese Tabelle rein soll? Evtl. diese DB einfach nochmal neu anlegen mit den aktuellen MySQL-Einstellungen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

jupi jupi jupi

Postby xanadu » 29. December 2004 09:48

Hattest recht nach dem neustart funkz einwandfrei.
herzlichen dank

Leider funkz die oberen menus nicht beim adminberich
zp. Teplates Manager -->Installieren Geht nichts mehr
Vielleicht kannst du da auch ein kleinen tip geben mit Big apache hatte vohrer alles funkz.. ( :
xanadu
 
Posts: 4
Joined: 29. December 2004 07:02

Postby Wiedmann » 29. December 2004 09:54

Sorry, Mambo kenn ich nur dem Namen nach.

Gibts keine Fehlermeldungen oder Einträge im error.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xanadu » 29. December 2004 09:56

Noch kleine frage vielleichts liegts daran wen ich xampp_start `e
hab ich folgende meldung ihn dos fenster


Diese Eingabeforderung nicht waehrend des Runnings beenden ...
Zum stoppen bitte die xampp_stop benutzen!
Please do not close this window while running ...
Use the xampp_stop for shutdown!

Please wait [Bitte warten] ..Can't start server: Bind on TCP/IP port: No error
041229 9:38:41 [ERROR] Do you already have another mysqld server running on por
t: 3306 ?
041229 9:38:41 [ERROR] Aborting

041229 9:38:41 [Note] mysql\bin\mysqld.exe: Shutdown complete

.

### APACHE + MYSQL IS STARTING NOW ###


Ist das schlimm oder kann ich es so lassen wen ich http://localhost eingebe sehe ich die seiten darum wollte ich sicher gehen
xanadu
 
Posts: 4
Joined: 29. December 2004 07:02

Postby Wiedmann » 29. December 2004 10:07

Mit XAMPP-Start wird der Apache und MySQL gestartet. MySQL lief zu diesem Zeitpunkt aber schon. deshalb die Meldung.

Jetzt bleibt die Frage, wie du XAMPP das letzte mal beendet hast? (oder du hast noch einen anderen MySQL installiert der nicht zum XAMPP gehört.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xanadu » 29. December 2004 15:48

Ich Danke nochmals herzlich Wiedmann


Ich hab das problem lössen können mit mambo menüs und dachte wen jemand das gleiche problem hat kanns ja nur nützlich sein
es ist der norton internet security, eomfach popup blocker deaktifieren und funktz .. alles
entlich bin ich wieder gklücklich

Nochmals Danke
xanadu
 
Posts: 4
Joined: 29. December 2004 07:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests