Fehler OS 10038 bei Win ME

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler OS 10038 bei Win ME

Postby Knecky » 17. December 2004 23:22

Hallo, ich habe heute versucht XAMP 1.4.10a auf meinem Laptop zu installieren, da ich dort eine mit Mambo erstellt Website local ausführen möchte. Auf dem Laptop ist als Betriebssytem Win ME installiert.
Nach dem Start von Apache kommt folgende Fehlermeldung:

<OS 10038> Socket operation on non-socket: make_sock: for adress 0.0.0:443, apr_socket_opt_set: <SO_KEEPALIVE> no listening sockets availiable, shutting down.

Was will mir Apache damit sagen? Wie kann ich ihm auf die Sprünge helfen? Ich bin halt nicht so bewandert auf dem Gebiet und auch 5 Stunden Threads lesen und googeln haben mich nicht wirklich schlauer gemacht.
Was habe ich bisher schon versucht und verstellt ;-) ?
Ich habe an 2 Stellen in der httpd.conv den Wert 80 auf 81 und 8080 gestellt. Leider ohne Erfolg.
Ich habe Teamspeak und ICQ deinstalliert. Ich habe unter Systemsteuerung/Software/Windows Setup/Verbindungen alle Komponenten installiert/deinstalliert usw.
Ich habe kein AntiVirus Programm laufen.
IIS läuft bei mir auch nicht (wenn ich http://localhost eingebe kommt Seite nicht gefunden, und wenn es installiert wäre, müsste ich wohl was anderes sehen hatte ich in einem Beitrag gelesen. Daher denke ich ich habs nicht laufen. Mir wäre auch nicht bekannt, das ein anderes Webserver Proggi auf dem Laptop installiert ist.
Es wäre supernett, wenn mir jemand bei dem Problem helfen könnte. Ich verzeifele hier noch :-(
Schonmal Danke im Voraus!
Knecky
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Postby Rolidor » 17. December 2004 23:46

Hi.

Irgend ein anderer Prozess belegt bei dir den HTTP-Port 443. Lade mal die httpd.conf (unter xampp\apache\conf) in einen Editor und suche folgende Zeile
Code: Select all
Include conf/ssl.conf
Die kommentierst du aus (#davor), speicherst das Ganze und startest den Apachen neu.

Damit hast du den Apachen dann allerdings seiner Fähigkeit beraubt, Zugriffe über HTTPS (SSL) zu bedienen. Wenn du das nicht brauchst, kannst du's so lassen. Ansonsten musst du den Störenfried finden.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Port 80 Problem

Postby Knecky » 18. December 2004 08:37

Danke für die schnelle Antwort.
Ich habe die Zeile auskommentiert, und nun bekomme ich die Fehlermeldung für 0.0.0:80

Was muss ich nun machen?
(Sorry, bin halt ein Noob ;-) )
Ich habe in der Zeile Listen 80 schon den Wert auf 81 gesetzt, dann erscheint die Fehlermeldung mit 81 und bei 8080 erscheint die Fehlermeldung mit 8080.
Etwas tiefer steht AuthremotePort, dort habe ich auch auf 81 und 8080 gesetzt, und auch alle Kombinationen ausprobiert, aber immer mit dem gleichen Fehler (bei 81 halt 81 und bei 8080 halt mit 8080)
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Postby Rolidor » 18. December 2004 15:37

Servus.

Ich kann mich erinnern, dass es hier threads gab, in denen (ich glaube unlösbare) Probleme mit Win ME besprochen wurden. Aber gucken wir mal weiter.

Wenn der Apache weder Port 80 noch 443 besetzen kann (evt. auch noch andere), dann gibt es mit an Sicherheit grenzender Wahrscheinlichkeit einen anderen Prozess, der das tut. Schau doch mal im Taskmanager, was da alles läuft und poste die Liste hier. Möglicherweise hattest du auch etwas auf der Platte, dass sich nicht sauber deinstalliert hat.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Wiedmann » 18. December 2004 15:54

Irgend ein anderer Prozess belegt bei dir den HTTP-Port 443

Das wäre dann der Fehler "OS 10048".

"OS 10038" bedeutet i.d.R. eine inkompatible Winsock, oder ein nicht korrektes installiertes TCP/IP.

Ich kann mich erinnern, dass es hier threads gab, in denen (ich glaube unlösbare) Probleme mit Win ME besprochen wurden.

Hab ich auch so in Erinnerung. Habe leider auch kein ME zur Hand...

Würde also erstmal schauen, ob TCP/IP korrekt installiert ist. Evtl. VPN und ICS deaktivieren. Gibts noch eine Firewall?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Taskmanager

Postby Knecky » 18. December 2004 18:48

Also im Taskmanager sind folgende Prozesse aktiv:
Explorer
Winmgmt
Wincinemamgr
Naviclient
Naviagent
Systray
Hpztsb04

was immer das auch bedeuten mag.
zu TCP/IP:
folgende Sachen sind installiert:
TCP/IP-> DFÜ Adapter
TCP/IP-> DFÜ Adapter #2 (VPN-Unterstützung)
TCP/IP-> Internetverbindungsfreigabe
TCP/IP-> SiS 900 PCI Fast Ethernet Adapter

Eine Firewall ist meines Wissens nicht aktiv.
Wie deaktiviere ich denn ICS?

Den TCP/IP-> DFÜ Adapter #2 (VPN-Unterstützung) habe ich nun deinstalliert, aber es erscheint noch immer die gleiche Fehlermeldung :-(

Danke schonmal für eure Hilfe bis hierhin!
Knecky
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Postby Wiedmann » 18. December 2004 19:02

TCP/IP-> DFÜ Adapter #2 (VPN-Unterstützung)
TCP/IP-> Internetverbindungsfreigabe
TCP/IP-> SiS 900 PCI Fast Ethernet Adapter

Der VPN Adapter dürfte nicht das Problem sein.
Die Internetverbindungsfreigabe (ICS) kann man bestimmt an dieser Stelle oder über Software deinstallieren.
Hat der EthernetAdapter eine korrekte IP-Adresse in den TCP/IP Settings eingetragen? (mit winipcfg kann man das überprüfen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Ethernet Netzwerkkarten Info

Postby Knecky » 18. December 2004 19:34

Hab nun den Ip Konfigurator aufgerufen. Dort steht:
Netzwerkkartenadresse: 00-A0-CC-C8-14-A7
IP-Adresse: 192.168.1.33
Subnetmask 255.255.255.0
Standard Gateway: 192.168.1.1

Bei IP-Routing ist übrigens ein Häckchen bei aktiviert.

Die Internetverbindungsfreigabe habe ich nun auch deinstalliert.
Es erscheint noch immer der gleiche Fehler :-(
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Postby Rolidor » 18. December 2004 22:08

Hi.

Noch ein Tipp von der anderen Seite: Wie ich sehe, hast du i-Nav installiert. Deinstalliere das doch mal testweise.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

I Nav ist deinstalliert

Postby Knecky » 19. December 2004 00:52

Hi, nun habe ich I Nav deinstalliert und habe immernoch die gleiche Fehlermeldung wie vorher :-(
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Postby Wiedmann » 19. December 2004 01:33

Versuch:
Mach mal an den Anfang der Datei "httpd.conf" (\xampp\apache\conf) folgende Zeile rein:
Win32DisableAcceptEx
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Gleicher Fehler

Postby Knecky » 19. December 2004 10:33

So, habe ich eingefügt, an der Fehlermeldung ändert sich aber nichts. Ich versuche jetzt mal den Rechner zu formatieren und als Betriebssystem Win 2k aufzuspielen. Mal sehen obs klappt.
Ich melde mich dann wieder, wenn ich soweit bin!
Bis gleich dann!
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03

Alles läuft!

Postby Knecky » 19. December 2004 23:20

Sorry, das es etwas länger mit der Antwort gedauert hat. Dauert halt was wenn man den ganzen Rechner platt machen muss. Habe nun Win 2K und XAMP installiert und alles klappt auf Anhieb!
Nochmal vielen Dank für eure Hilfe und große Bereitschaft mir bei meinem Problem zu helfen. Das war echt nett!
Viele Grüße!
Knecky
Knecky
 
Posts: 7
Joined: 17. December 2004 23:03


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests