Fehler bei einer SQL Abfrage #1071 unter 1.4.10a

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler bei einer SQL Abfrage #1071 unter 1.4.10a

Postby zottl » 13. December 2004 12:24

Hallo
Setze die neueste Windows Xampp-Version (1.4.10a) ein. Wenn ich diese Abfrage ausführe, bekomme ich den Fehler:
#1071 - Specified key was too long; max key length is 1000 bytes

Code: Select all
DROP TABLE IF EXISTS `mos_core_acl_aro`;
CREATE TABLE IF NOT EXISTS `mos_core_acl_aro` (
  `aro_id` int(11) NOT NULL auto_increment,
  `section_value` varchar(240) NOT NULL default '0',
  `value` varchar(240) NOT NULL default '',
  `order_value` int(11) NOT NULL default '0',
  `name` varchar(255) NOT NULL default '',
  `hidden` int(11) NOT NULL default '0',
  PRIMARY KEY  (`aro_id`),
  UNIQUE KEY `mos_gacl_section_value_value_aro` (`section_value`,`value`),
  UNIQUE KEY `section_value_value_aro` (`section_value`,`value`),
  KEY `hidden_aro` (`hidden`),
  KEY `mos_gacl_hidden_aro` (`hidden`)
) TYPE=MyISAM AUTO_INCREMENT=18 ;


Kann man das irgendwo einstellen, dass die Byte z.B. 2000 sind??

In der Xampp-Version 1.4.5 funktioniert die Abfrage. Kann mir jemand helfen??
Nachtrag: In der Xampp Version 1.4.9 funktioniert es auch.

Vielen Dank für Eure Hilfe
Gruß Zottl
zottl
 
Posts: 1
Joined: 13. December 2004 12:01

Postby Wiedmann » 15. December 2004 10:54

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 19 guests