XAMPP und MapGuide Server

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP und MapGuide Server

Postby hd-andi » 08. December 2004 13:45

Hallo liebe Apache/XAMPP-Gemeinde,

ich setzte den XAMPP für Windows ein. Hier läuft der Apache 2 sehr sauber und stabil.
Nun hat sich für mich ein weiteres Thema ergeben - GIS (Grafische Informationssysteme). Da gibt es von Autodesk den MapGuide-Server, der standardmäßig für den IIS vorkonfiguriert ist. Soweit so gut. MapGuide ist in Ordnung :D der IIS nicht unbedingt :( , also: MapGuide unter dem Apache laufen lassen. :idea:

Jetzt breche ich mir aber seit einiger Zeit die Finger an der Einstellung in der httpd.conf. Daher mein Hilferuf:

Ich benötige ein virtuelles Verzeichnis zu dieser ausführbaren Datei: "D:\Programme\Autodesk\MapGuideServer6.3\MapAgents\MapAgent.exe"
Diese ausführbare Datei übersetzt ein Datenformat namens MWF und stellt dann die entsprechende grafische Information im Browser dar.

Beim Erstellen dieser MWF-Datei wird über eine URL angegeben wo die Datei MapAgent.exe zu finden ist. Diese URL sollte http://localhost/mapguide/mapagent.exe lauten.
Also müssten doch folgende Einstellungen richtig sein?

Code: Select all
#-----------------------------------------------------------------------------------------
# MapGuide 6.3
# Konfiguration und Einstellungen für den MapGuide Server 6.3
#-----------------------------------------------------------------------------------------
# Virtuelles Verzeichnis anlegen
#
Alias /mapguide "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/"

<Directory "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/">
   Options Indexes MultiViews ExecCGI
   Order allow,deny
   Allow from all
</Directory>
#-----------------------------------------------------------------------------------------
# Test-Datenbereich für MapGuide
#-----------------------------------------------------------------------------------------
Alias /mg_data "D:/public_html/webmaster/web/"

<Directory "D:/public_html/webmaster/web/">
   Options Indexes MultiViews
   Order allow,deny
   Allow from all
</Directory>

Im Test-Datenbereich liegt die MWF-Datei, die ich dann per Klick "ausführe".
Anschließend kommt eine Fehlermeldung, das die URL http://localhost/mapguide/mapagent.exe nicht gültig sei.
Was mache ich falsch :!: :?:
Wenn ich den Verweis auf http://www.mapguide.com/mapguide6/mapagent.exe setze, also zum Hersteller, dann funzt alles. Dort läuft der IIS. :evil:

Für die Hilfe schon mal Dank ... :D
HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby deepsurfer » 08. December 2004 14:06

Theorie: Rechteproblem bei der Übergabe von Exe Anweisung in den XAMPP Prozess.

Klick die MapGuide.exe mit rechter Maustaste mal an und stelle unter "Eigenschaften" die rechte zum ausführen neu ein.

Bevor du etwas änderst schreib dir die ablesbaren Einstellungen auf ein Zettel, damit du immer wieder es in den Ausgangzustand bringen kannst.


chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hd-andi » 08. December 2004 14:17

Hi deepsurfer,

Danke für die schnelle Antwort, doch in den Eigenschaften der Datei unter WinXP Pro kann ich soetwas nicht sehen oder einstellen.
Bitte etwas genauer ...

HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby deepsurfer » 08. December 2004 14:49

kommt beim aufruf mit rechter maustaste und eigenschaften ein hinweiss das du keine berechtigung dafür hast und das du dich bitte an den administrator wenden sollst ???????

Wenn ja, dann musst du dich in deinem XP system als Administrator anmelden nicht als User. (es sei denn es ist ein Firmenrechner wo du keinen Adminzugang erhältst)

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hd-andi » 08. December 2004 14:58

Hi,

bin lokaler Admin auf meinem Notebook. Ich darf eigentlich alles auf Localhost! Ich sehe aber nichts zum Thema Rechte bezüglich Ausführen von Dateien in den Eigenschaften. Meines Wissens gibt es sowas in den Eigenschaften auch nicht.

Die Einstellungen in der httpd.conf sind aber ok?

HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby deepsurfer » 08. December 2004 17:06

Also wenn ich als Admin auf eine "exe" datei mit rechter maustaste klicke dort in den eigenschaften oben auf "Sicherheit" gehe, so erscheint bei mir sehr wohl eine möglichkeit dieser Datei """Rechte""" zu vergeben.


Dein Script sieht augenscheinlich gut aus, worum es in meiner Theorie geht ist das der IIS auf einer Windowsrechtevergabe basiert und sich um viele kleine Details von Dateien einen dreck schert.

Der XAMPP (Apache) ist in der vorgehensweise zu dateien wesentlich defizieler, daher mein anliegen die rechte nachzuschauen.

Da ich wohl mit meiner Theorie nicht unbedingt falsch liege sieht man daran das sonst Oswald / KriS oder einer von Profis sich schon gemeldet hätten.
Viele Erklärungen beruhen auf Erfahrungen bzw. von gelesenen Hilfen die auch noch so komisch klingen mögen. Hinzukommt das man vor lauter Bäumen mal den Wald nicht sieht und dann sind einige Hilfen halt ein Denkanstoss in die richtige Richtung.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 08. December 2004 18:51

öhhmmm noch ein gedanken sprung...

schau mal ob du die Gross und klein Schreibung beachtet hast !!!

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 08. December 2004 19:20

öhhmm noch was zu deinem script...

wenn ich mich jetzt nicht irre müsste dein ALIAS direkt auf die exe datei verweisen, da du ja einen direkten aufruf auf diesen Alias machst um die MWF dateien hinzudrücken...


teste das mal gegen und meld dich

Code: Select all
Alias /mapguide "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/mapguide.exe"

Da die Directory im VHOST deklariert wird und somit in den windowsspeicher übergeben wird.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hd-andi » 09. December 2004 09:27

Hi deepsurfer,

deepsurfer wrote:Also wenn ich als Admin auf eine "exe" datei mit rechter maustaste klicke dort in den eigenschaften oben auf "Sicherheit" gehe, so erscheint bei mir sehr wohl eine möglichkeit dieser Datei """Rechte""" zu vergeben.


Mein Notebook hängt in einem Novell-Netzwerk und ich habe von unserem Novell-Admin eine Berechtigung zur lokalen Administration meines Notebooks erhalten. Ich sehe aber dieses Register "Sicherheit" überhaupt nicht. Das heißt für mich, dass der novellgesteuerte lokale Admin wohl nicht mit dem "echten" lokalen Administrator zu vergleichen ist.

Ich werde das überprüfen ... Den Rest werde ich checken ... Danke schon mal ...
HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby hd-andi » 09. December 2004 09:43

Hi deepsurfer,

also habe den Alias gecheckt und auf die EXE verwiesen, aber das funzt garnicht. Kam mir auch etwas komisch vor. habe es wieder zurückgesetzt und habe jetzt ein komischen Phänomen. :?:
Und zwar:

In MapGuide gibt es einen sogenannten Author. Mit diesem Tool kann man das Kartenwerk und zugehörige Datenbankdaten für das Publizieren in MapGuide vorbereiten. Heraus purzelt dann solch eine MWF-Datei, die MapGuide dann interpretiert und anzeigt.
In einem der Konfigurationseinstellungen muss man die URL zu der besagten Datei mapagent.exe (nicht wie Du versehentlich geschrieben hast mapguide.exe) einstellen. Setze ich die URL auf http://localhost/mapguide/mapagent.exe (hier muss die mapagent.exe mit angegeben werden), dann öffnet mir der Author den Browser und zeigt die mapagent.exe binär an, also so, als wenn Du im Editor ein Binär-File anzeigen läßt. Ist doch komisch, oder?

Das heißt aber für mich, dass der Alias stimmt. Was wäre denn mit einem ScriptAlias :?:
Das probiere ich mal aus ...
HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby hd-andi » 09. December 2004 10:26

ja, also das mit dem ScriptAlias bringt mich nicht unbedingt weiter ... :(

HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby deepsurfer » 09. December 2004 10:56

Poste mal deine Änderungen der HTTPD.CONF die du gemacht hast.

Kriege nämlich das gesamtbild nicht so richtig im Kopf zusammen.
Generell kann man mit der Beschreibung von Mguide etwas anfangen.
Die Frage ist jetzt nur wie Du es gemacht hast.

Zudem gehe ich von einem frisch Installiertem XAMPP aus ohne jeglichen schnick schnack.

Das die EXE als Binär aufgezeigt wird ist zumindest ein hinweis, da im normalfall ein Download gestartet werden solle, dies kann man aber in der httpd.conf deklarieren.(wenn ich mich nicht irre)

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hd-andi » 09. December 2004 11:04

Hi deepsurfer,

also als erstes hat mein Novell-Admin mir die Augen geöffnet - sprich das Register Sicherheit hergezaubert. Da darf ich ... der lokale Admin und User ... ALLES.

Hier der Teil aus der httpd.conf für MapGuide ...

Code: Select all
#-----------------------------------------------------------------------------------------
# MapGuide 6.3
# Konfiguration und Einstellungen für den MapGuide Server 6.3
#-----------------------------------------------------------------------------------------
# Virtuelles Verzeichnis anlegen
#
Alias /mapguide "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/"

<Directory "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>
#-----------------------------------------------------------------------------------------
# Test-Datenbereich für MapGuide
#-----------------------------------------------------------------------------------------
Alias /mg_data "D:/public_html/webmaster/web/"

<Directory "D:/public_html/webmaster/web/">
   Options Indexes MultiViews
   AllowOverride None
   Order deny,allow
   Allow from all
</Directory>
#-----------------------------------------------------------------------------------------
#  ScriptAlias für MapGuide
#-----------------------------------------------------------------------------------------
#ScriptAlias /mapguide/ "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents/"

#<Directory "D:/Programme/Autodesk/MapGuideServer6.3/MapAgents">
#    AllowOverride None
#   Options None
#    Options Indexes MultiViews ExecCGI
#   Options MultiViews ExecCGI
#   Options ExecCGI
#    Order allow,deny
#    Allow from all
#</Directory>
#-----------------------------------------------------------------------------------------
#  MIME-Typ für MapGuide anlegen
#-----------------------------------------------------------------------------------------
AddType application/x-mwf .mwf
#-----------------------------------------------------------------------------------------


Habe den ScriptAlias wieder rauskommentiert. Also so wie die Einstellungen jetzt sind läuft zur zeit der Apache. Tschau ...

HD-Andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Postby deepsurfer » 20. December 2004 17:52

hast sich die sache erledigt ??????

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hd-andi » 21. December 2004 10:12

Hallo deepsurfer,

leider noch nicht ... versuche es jetzt mit der Version 6.5.

Tschau
hd-andi
hd-andi
 
Posts: 10
Joined: 08. December 2004 12:44
Location: Datteln

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests