Illegal mix of collations

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Illegal mix of collations

Postby waitsee » 06. December 2004 19:12

Gerade XAMPP Version 1.4.10 installiert.

Wenn Ich mit phpMyAdmin arbeiten will und zb. Tabelle "user" anschauen will, dann zeigt sich diesen Fehler:

" SQL-query: DocumentatieWijzigen

SELECT column_name, mimetype, transformation, transformation_options
FROM `PMA_column_info`
WHERE db_name = 'mysql'
AND table_name = 'user'
AND (
mimetype != ''
)

MySQL retourneerde: Documentatie
#1267 - Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_unicode_ci,COERCIBLE) for operation '='
"


Wie kann Ich e loessen?[/b]
waitsee
 
Posts: 2
Joined: 06. December 2004 17:09
Location: Hengelo, the Netherlands

Postby kvo » 06. December 2004 19:48

Hi waitsee!

das könnte auch mit dem Versäumnis in der "my.cnf" zu finden unter \xampp\mysql\bin\my.cnf zusammenhängen. Hintergrund: Der neue MySQL 4.1.7 hat bei (auch vermeidlich) nicht unterstützten Zeichensätzen Probleme, automatisch einen Standard Zeichensatz zu laden. Die Zeile

set-variable = default-character-set=utf8

muss in der "my.cnf" im Abschnitt [mysqld] zu finden sein , wie hier:

[mysqld]
port = 3306
socket = mysql
skip-locking
set-variable = default-character-set=utf8
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
log-bin
server-id = 1
(usw.)

Wenn nicht, dann die Zeile bitte selbst nachtragen. In den nochmals heute um 17:00 Uhr aktualisierten Paketen der Version 1.4.10 ist diese Zeile aber bereits vorhanden. Ich habe nochmal mit PHPMyAdmin auf mysql/user zugegriffen (w2k und dt.) und konnte keine Probleme mit dem JETZT aktuellen XAMPP feststellen.

Vielleicht ist es aber auch wirklich ein anderer Fehler ...
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Problem ist geloesst

Postby waitsee » 06. December 2004 20:14

Man schwer die Deutsche Sprache.

Kay vielen Dank fuer dass Schnelle Antwort. Ich habe die version von nach 17.00 Uhr installiert und dass Problem ist weg.

Klasse!
waitsee
 
Posts: 2
Joined: 06. December 2004 17:09
Location: Hengelo, the Netherlands


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests