MySQL Problem!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL Problem!

Postby EvilDivel » 30. November 2004 14:29

Habe Xampp installiert läuft auch soweit.
Allerdings gibt es ein Problem mit MySQL was allerdings auch seltsam ist

PhpMyAdmin klappt mit den Daten
localhost
root
wunderbar dann hab ich meine php dateien in den htdocs ordner gezogen

folgende funktion verwende ich

Code: Select all
function loginconnect()
{
$con = mysql_connect("localhost","root","") or die(mysql_error());
mysql_select_db("mww_top",$con) or die(mysql_error());
}


Wie gesagt PhpMyAdmin funktioniert aber bei allen scripten auch myphpbb usw bekomm ich folgendes

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'localhost@localhost' (Using password: NO) in C:\server\xampp\htdocs\mww_top100\admin\inc\config.inc.php on line 26
EvilDivel
 
Posts: 5
Joined: 30. November 2004 14:15
Location: Neuss

Postby Wiedmann » 30. November 2004 14:38

$con = mysql_connect("localhost","root","") or die(mysql_error());

Diese Zeile steht 1 zu 1 (ohne Änderung) so in:
C:\server\xampp\htdocs\mww_top100\admin\inc\config.inc.php on line 26
:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby myvIsIOn » 30. November 2004 14:54

Vergib ein PW für den User "root". Dann gibst Du es mit dem Aufruf mit, dass sollte auf jeden Fall klappen. Anscheinend hat er Probleme, wenn das PW bei dem localhost frei bleibt!
myvIsIOn
 
Posts: 4
Joined: 28. November 2004 13:40

Postby EvilDivel » 30. November 2004 15:04

Das Passwort vergeb ich in PhpMyAdmin unter Rechte richtig?
EvilDivel
 
Posts: 5
Joined: 30. November 2004 14:15
Location: Neuss

Postby Wiedmann » 30. November 2004 15:17

Das Passwort vergeb ich in PhpMyAdmin unter Rechte richtig?

Ja, aber das ist nicht dein Problem.

Warte immer noch auf Antwort.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby EvilDivel » 30. November 2004 16:29

Achso ja sorry steht genauso in der Datei

bei meiner alten Xampp version gings auch bestens seit dem formatieren nimmt der nichts mehr an
EvilDivel
 
Posts: 5
Joined: 30. November 2004 14:15
Location: Neuss

Postby Wiedmann » 30. November 2004 16:39

Achso ja sorry steht genauso in der Datei

Das glaub ich schon. Ist das aber auch die Zeile 26 in dieser Datei?

Der von dir gepostete Code kann jedenfalls nicht diesen Fehler erzeugen:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'localhost@localhost' (Using password: NO) in C:\server\xampp\htdocs\mww_top100\admin\inc\config.inc.php on line 26
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby EvilDivel » 30. November 2004 17:35

Ok problem hat sich gelöst bin in eigener Dummheit erstickt *g*

War in der falschen datei weil ich das ganze einmal für den adminbereich habe und für die seite selber war aber in der datei für den adminbereich sowas is mir noch nie passiert richtig peinlich aber trotzdem danke an alle :)
EvilDivel
 
Posts: 5
Joined: 30. November 2004 14:15
Location: Neuss


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests