vHosts: Fehlermeldung bei "Listen"

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

vHosts: Fehlermeldung bei "Listen"

Postby blueshark » 28. November 2004 19:42

Hi!

Ich habe folgendes Problem:

Habe eine Domain bei DynDNS.org und will nun, dass wenn ich z.B. example.dyndns.or:444 eingebe, eine andere Seite angezeigt wird, als ohne den Port-Zusatz.

Habe zu diesem Zweck in die httpd.conf folgendes geschrieben:

Code: Select all
Listen 80
Listen 444

NameVirtualHost *:80
NameVirtualHost *:444

<VirtualHost *:80>
ServerName blueshark.dyndns.org
DocumentRoot F:/blueshark/xampp/htdocs/user/blueshark/html
</VirtualHost>

<VirtualHost *:444>
ServerName blueshark.dyndns.org
DocumentRoot F:/blueshark/xampp/htdocs/admin
</VirtualHost>


Wenn ich nun den Apache neu starte, erhalte ich folgende Fehlermeldung:

"The requested operation has failed."

Sobald ich die "Listen" entferne, startet der Server wieder.

Kann mir jemand helfen?

CU, blueshark
blueshark
 
Posts: 6
Joined: 28. November 2004 19:16
Location: Mönchengladbach

Postby Wiedmann » 28. November 2004 20:38

"The requested operation has failed."

Und die genaue Fehlermeldung vom Apache?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby blueshark » 28. November 2004 20:54

In der Error.log steht von heute:

Code: Select all
[Sun Nov 28 15:02:25 2004] [notice] Parent: Created child process 1656
[Sun Nov 28 15:02:28 2004] [notice] Child 1656: Child process is running
[Sun Nov 28 15:02:28 2004] [notice] Child 1656: Acquired the start mutex.
[Sun Nov 28 15:02:28 2004] [notice] Child 1656: Starting 250 worker threads.
[Sun Nov 28 19:39:51 2004] [notice] Parent: Received restart signal -- Restarting the server.
[Sun Nov 28 19:39:51 2004] [notice] Child 1656: Exit event signaled. Child process is ending.
[Sun Nov 28 19:39:52 2004] [notice] Child 1656: Released the start mutex
[Sun Nov 28 19:39:55 2004] [notice] Child 1656: Waiting for 250 worker threads to exit.
[Sun Nov 28 19:39:55 2004] [notice] Child 1656: All worker threads have exited.
[Sun Nov 28 19:39:56 2004] [notice] Child 1656: Child process is exiting


Da ich Apache als Dienst installiert hab, wollte ich ihn über den Apachemonitor neu starten, und dann kam halt diese Fehlermeldung.

Ach ja, ich habe WinXP Home SP1, Dienstinstallation funzt trotzdem.
(Apache/2.0.52 (Win32) mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.2)

CU, blueshark
blueshark
 
Posts: 6
Joined: 28. November 2004 19:16
Location: Mönchengladbach

Postby Wiedmann » 28. November 2004 21:09

Da ich Apache als Dienst installiert hab,

Dann steht die entsprechende Meldung im Ereignisprotokoll von Windows (wie immer bei Diensten).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby blueshark » 28. November 2004 21:36

Muss amn auch erstmal wissen :-)

Hab mir die Fehlerberichte mal angeschaut, da stand was von, ein Port kann nur einmal verwendet werden.
Habe darauf hin "Listen 80" entfernt und schon gabs keine Fehlermeldung mehr.

Erstmal vielen Dank.

Hab jetzt aber ein neues Problem:
Ich habe einen vHost für einen Ordner namens admin erstellt (siehe oben),
In diesem sind unter anderem die xampp Status-Checks. Wenn ich diese extern ohne vhost öffne, wird alles korrekt angezeigt. Mit vhost nicht, wahrscheinlich weil man nicht mehr auf Verzeichnisse zugreifen kann, die über dem vhost liegen. Wie kann ich nun eine vhost ähnliche Weiterleitung einrichten, ohne dass nun ein Host simuliert wird?

Cu, blueshark
blueshark
 
Posts: 6
Joined: 28. November 2004 19:16
Location: Mönchengladbach

Postby deepsurfer » 29. November 2004 09:16

Ändere Deine VHOST Typologie, wie ich sehe machst du den selben klassischen Fehler wie viele andere auch.

Erklärung:
XAMPP ist mit seiner Grundinstalltion für eine Webumgebung gedacht.
Dies ist somit die Oberste Ebene.

Viele gehen hin und schreiben nun eine eigene Oberfläche in das von XAMPP vorgegebene Verzeichniss und wollen nun mittels VHOST neue/zusätzliche Bereiche anbieten. Hier kommt der von mir angesprochener Denkfehler.

Sobald man mit mehreren Bereichen (VHOST) arbeiten möchte, sollte auch das eigene Webprojekt in einem VHOST stehen und die Oberste Ebene dient als absoluter ROOT (Admin) Bereich.

Damit erleichterst Du dir das Anbieten verschiedener Bereiche mit Sortierung und spätere Administration des Systems.

Ansonsten lasse dein ADMIN VHOST auf das x:\htdocs\xampp\ auflaufen


Ein Denkanstoss an Oswald für eine neue Final (oder testweise in einer Beta)
Bau direkt einen VHOST ein z.b.
- localhost = /htdocs mit leerer "Hallo" Page
- VHOST status.localhost = /htdocs/xampp = das bekannte xampp verzeichniss mit Inhalten.

Damit haben die User einen direkten Einblick in die VHOST Typologie und können mit dieser Grundvorlage ohne Probleme eigene Bereiche von vorn herein unterteilen.

( uppss kan sein das ich da nun etwas ausschweife.... ich arbeite immer named basierent, da ist es etwas anders......dumdideldum)



chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby blueshark » 29. November 2004 16:03

Tja, der Mensch ist eben ein Herdentier :D !

Die vHosts scheinen das häufigste Problem zu sein, sollte unbedingt mit in Xampp aufgenommen werden.

Vielen Dank für eure Hilfe. Ist ein echt super Service hier. Weiter so!!! :D

Schöne Grüße, blueshark
blueshark
 
Posts: 6
Joined: 28. November 2004 19:16
Location: Mönchengladbach

Postby deepsurfer » 29. November 2004 16:54

http://community.apachefriends.org/f/viewtopi ... host#34538


schau mal hier, vielleicht hilft das etwas besser....
Im grunde genau das von dir, aber vielleicht siehst du einen Unterschied

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests