ISO 8859

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

ISO 8859

Postby kig » 22. November 2004 20:00

Hallo zusammen

Ich benutze Win XP SP 2 mit XAMPP 1.49.
Bei meinem installierten MAMBO 4.51 a tritt bei den
RSS Feeds der Fehler auf, dass die Umlaute nicht korrekt angezeigt werden, obwohl eigentlich alles mit charset=iso-8859-1 abgehandelt wird.
Bei meinem Provider funzt das alles perfekt.
Da hab ich zwar eine alte Version Apache und auch PHP 4.3...
aber daran sollte das ja nicht liegen...

Wo kann ich denn diese Einstellungen vornehmen?
Danke für Euer Feedback.

Gruss
JK
Grüsse aus der Innerschweiz :)
JK
kig
 
Posts: 21
Joined: 27. February 2004 14:49

Postby Wiedmann » 22. November 2004 20:32

Bei meinem installierten MAMBO 4.51 a tritt bei den
RSS Feeds der Fehler auf, dass die Umlaute nicht korrekt angezeigt werden, obwohl eigentlich alles mit charset=iso-8859-1 abgehandelt wird.

Bist du da sicher? RSS-Dateien basieren auf XML und sind somit grundsätzlich erst einmal UTF-8 kodiert.

Da dürfte dann dieser Eintrag in der "httpd.conf" vom XAMPP eher hinderlich sein:
AddDefaultCharset ISO-8859-1

Da somit ja grundsätlich erst mal ein "Content-Type"-Header mit "charset=ISO-8859-1" gesendet wird. Kommentier den mal testweise aus.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

encoding

Postby kig » 22. November 2004 21:30

Hallo zusammen

Das müsste eigentlich schon so sein... aber mann weiss ja nie :)
Anbei der Auszug aus der site
<?xml version="1.0" encoding="iso-8859-1"?>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

Und genau das läuft ja bei meinem Provider korrekt, nur bei mir auf dem XP mit XAMPP 1.49 nicht :?
Was nun?
Danke für Euer Feedback
Grüsse aus der Innerschweiz :)
JK
kig
 
Posts: 21
Joined: 27. February 2004 14:49

Postby Wiedmann » 22. November 2004 21:49

<?xml version="1.0" encoding="iso-8859-1"?>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

Gut. Das steht in der Seite die im Browser angezeigt wird (*.html). Und die tut ja wohl?

Deine Aussage im ersten Post bezog sich auch auf die RSS-Feeds (*.rdf)?

Wo hast du denn jetzt eigentlich falsche Zeichen und mit welchem Programm?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

encoding

Postby kig » 22. November 2004 21:52

hallo zusammen

Noch ein kleiner Nachtrag damits eindeutig wird.
Hier ein Teil der angezeigten Daten:

Kurz und übersichtlich: Meldungen über aktuelle Geschehnisse in der digitalen Welt - mit Fokus auf die Schweiz.


Neuer Sober-Wurm macht das Netz unsicher
Zurzeit verbreitet sich die neue Variante I des Sober-Wurms rasch. Da noch nicht alle Antiviren-Hersteller ihre Signaturen aktualisiert haben, ist besondere Vorsicht angebracht.


Online-Shopping: LeShop.ch und Migros erweitern Liefergebiet
Das gemeinsame Portal der beiden Detailhändler beliefert seit dieser Woche 1,9 Millionen Schweizer Haushalte.


Die Messe der Zukunft?
Der «Verein für digitale Kultur» setzt auf ein neues Messekonzept: Es verbindet Fachveranstaltung, Consumer-Messe und Lifestyle-Event.

und hier die Newsfeed-XML-Adresse mit dem XML Header:
http://www.pctipp.ch/newsfeed/pctipp.rss
<?xml version="1.0" encoding="ISO-8859-1" ?>
- <rss version="2.0">
- <channel>
<title>PCtipp.ch Webnews</title>
<link>http://www.pctipp.ch</link>

Wo ich immer noch nicht durchblicke ist, dass es bei meinem Provider korrekt angezeigt wird, aber bei mir auf dem XAMPP 1.49 nicht.
Liegt das evtl. an PHP 5? :roll:

cheers
Grüsse aus der Innerschweiz :)
JK
kig
 
Posts: 21
Joined: 27. February 2004 14:49

Postby Wiedmann » 22. November 2004 22:42

Hmm,

du bist sicher, dass dein lokales Mambo auch wirklich mit "ISO-8859-1" arbeitet?

Der «Verein für digitale Kultur» setzt auf ein neues Messekonzept

Deine Anwendung liesst den Feed korrekt ein und liefert den Text dann konvertiert als UTF-8 aus. Als Content-Typ wird aber wohl "ISO-8859-1" angegeben. :?:

Interessant ist der Orginalfeed:
Der «Verein für digitale Kultur»

Würde den deine Anwenung 1zu1 übernehmen, wäre der Content-Typ egal, und es würde trotzdem korrekt angezeigt werden.

Liegt das evtl. an PHP 5?

Das kannst du ja ziemlich schnell herausfinden...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

ISO 8859

Postby kig » 23. November 2004 07:51

Hallo Wiedmann

Wenn Mambo meine Anwendung wäre, wüsste ich es....

Gemäss der httpd.conf ist ja per Default AddDefaultCharset ISO-8859-1 gesetzt.
Du sagst nun, dass MAMBO das in UTF-8 convertiert und ausgibt.
Dann bin ich hier wohl im falschen Forum. :?

Trotzdem danke für Eure Hilfe.

cheers
Grüsse aus der Innerschweiz :)
JK
kig
 
Posts: 21
Joined: 27. February 2004 14:49

ISO 8859-1

Postby kig » 23. November 2004 19:09

Hallo zusammen

Noch eine abschliessende Frage.
Warum gehts beim WIN XP mit XAMPP 1.49 nicht und auf

PHP built auf: FreeBSD ... 4.7-RELEASE-p27 FreeBSD 4.7-RELEASE-p27 #33: Mo i386
Datenbank Version: 3.23.58
PHP Version: 4.3.8
Web Server: Apache/1.3.33 (Unix) PHP/4.3.8 FrontPage/5.0.2.2634
WebServer to PHP interface: apache
Version Version: Mambo 4.5.1a Stable [Three For Rum] 05/10/2004 16:12 GMT
gehts dann doch....? :?:
Grüsse aus der Innerschweiz :)
JK
kig
 
Posts: 21
Joined: 27. February 2004 14:49

Postby Wiedmann » 23. November 2004 19:12

Wenn du mal für beide Systeme reale URL's hast, könnte man da vielleicht eine Antwort geben.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests