Session BUG in PHP auf WIN32?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Session BUG in PHP auf WIN32?

Postby ganjamann » 22. November 2004 01:11

Hallo Leute,

gibt es einen Bug in der Session funktionalität von PHP (WIN32/aktueller XAMMP)?

Ich habe hier die db_esessions class im Einsatz.. kann auch sessionvariablen lesen und schreiben, aber nur auf der selben php datei.

sobald ich eine sessionvariable in einem include setze, kann ich nicht mehr drauf zugreifen und bekomme stattdessen ein leeres ergebnis...


ich bin am verzweifeln :-(

Hat jemand einen Tipp?

Thx.
Ganja
ganjamann
 
Posts: 3
Joined: 22. November 2004 01:05

Postby Wiedmann » 22. November 2004 01:38

Gibts da ein Minimalbeispiel (Mini!) zum Nachvollziehen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

redirect und sessions

Postby ganjamann » 22. November 2004 23:00

ich glaube das problem identifiziert zu haben.
es tritt dann auf, wenn während einer gestarteten session per redirect auf eine andere seite umgeleitet wird.

dieses problem taucht in diversen boards und auch bei php selbst in der buglist auf....
dachte eigentlich, dies sei behoben worden.

kann das mal jemand austesten?

also ne session starten, ein zwei variablen setzen auf eine andere seite redirecten und dieselben zwei variablen wieder auslesen?

Das ganze unter xampp auf win32.

thx
ganja
ganjamann
 
Posts: 3
Joined: 22. November 2004 01:05

Postby Wiedmann » 23. November 2004 01:05

also ne session starten, ein zwei variablen setzen auf eine andere seite redirecten und dieselben zwei variablen wieder auslesen?

Kann ich nicht nachvollziehen.
Hast du ein Codebeispiel?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kev » 23. November 2004 15:08

das gleiche prob hab ich auch seit längerem aber erst seit der zeit umstellung also mit winter und so um 1h kp wieso auf einmal erst seit dem is es bei mir habs auch a um 1h zurück gestellt aber prob is trotzdem gelöst habs immer noch net
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby Kev » 24. November 2004 20:07

pls helft ma^^,
also das is weiß net seit wann, ja seit dem ich das neue xampp 1.9 drauf gemacht hab habs sogar neu geladen ging trotzdem net...-.-Ich hoffe es hat wer eine lösung
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby Wiedmann » 24. November 2004 20:16

das gleiche prob hab ich auch seit längerem
...
pls helft ma^^,

Welches Problem hast du (genau)?

Ansonsten gilt für dich das Selbe wie für deinen Vorredner. Poste ein Beispiel zum Nachvollziehen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kev » 24. November 2004 20:38

AAAAAAAAAAAlso...
Ich habe ein browsergame und dort kommt der fehler mehr oder weniger seit dem ich xampp 1.9 drauf hab...es is nicht nur bei dem game es is generell so...

Hier der fehler
Code: Select all
Warning: date() [function.date]: Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in C:\SERVER\xampp\htdocs\logd\user.php on line 198

Warning: Cannot modify header information - headers already sent by (output started at C:\SERVER\xampp\htdocs\logd\user.php:198) in C:\SERVER\xampp\htdocs\logd\functions\redirect.php on line 11
user.phpRedirected to user.php from user.php?op=special&userid=402.


Dies weißt darauf hin das die redirectet net funzt....aber ich hab schon alles nach geguckt alle scripte es liegt net an den scripten es liegt an der funktion und in meiner funktion redirect.php is folgendes:

Code: Select all
function redirect($location,$reason=false){
    global $session,$REQUEST_URI;
    if ($location!="badnav.php"){
        $session[allowednavs]=array();
        addnav("",$location);
    }
    if (strpos($location,"badnav.php")===false) $session[output]="<a href=\"".HTMLEntities($location)."\">Hier klicken</a>";
    $session['debug'].="Redirected to $location from $REQUEST_URI.  $reason\n";
    saveuser();
    header("Location: $location");
    echo $location;
    echo $session['debug'];
    exit();
}

Ich hoffe das reicht die funktion is aus dem game, sie ist orginal und wurde nicht verändert!
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby Wiedmann » 24. November 2004 21:13

:?: Der Fehler wird doch schön angegeben, und auch warum der Redirect nicht geht...

Warning: Cannot modify header information - headers already sent by (output started at C:\SERVER\xampp\htdocs\logd\user.php:198) in

Wie allseits bekannt, darf beim Einsatz der Header() Funktion, davor nichts zum Browser ausgegeben werden. Das schliesst natürlich auch Fehlermeldungen von PHP mit ein. Die Zeile die für die Ausgabe verantwortlich war, ist Zeile 198.

Ach ja, dazu gab es ja auch schon eine Fehlermeldung: :idea:
Warning: date() [function.date]: Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in C:\SERVER\xampp\htdocs\logd\user.php on line 198

In dieser Zeile wird die Funktion date() fehlerhaft benutzt. Deshalb wird etwas zum Browser ausgegeben und die Funktion header() gibt danach ihrerseits wieder einen Fehler aus (und funktioniert nicht).

Du kannst jetzt natürlich die fehlerhafte Zeile korrigieren, oder display_errors auf 0 setzten.

Man könnte beim Hersteller natürlich auch auf ein fehlerfreies Machwerk pochen. ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kev » 24. November 2004 21:36

Wow danke danke danke, hast mein prob gelöst^^
das mit den display war schuld^^, nu geht alles wieder einwandfrei thx!!!!!
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby Wiedmann » 24. November 2004 21:50

hast mein prob gelöst

Freut mich :-)

das mit den display war schuld

Nö. Das Script ist fehlerhaft. So merkt es nur keiner ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kev » 25. November 2004 12:41

das script is nicht fehler haft is das orginale habs sogar von dem machen nachgucken lassen is wohl einwandfrei^^, egal solange es funzt is gut und diese fehler nicht kommen
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby Wiedmann » 25. November 2004 14:03

das script is nicht fehler haft is das orginale habs sogar von dem machen nachgucken lassen is wohl einwandfrei

Himmel hilf :(

Ein Script erzeugt einen Error und der "Macher" behauptet es sei fehlerfrei?

Naja. Hauptsache du bist zufrieden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kev » 25. November 2004 14:05

jop hauptsache es funzt^^
User avatar
Kev
 
Posts: 269
Joined: 09. October 2004 13:25
Location: NRW/Hamm

Postby deepsurfer » 25. November 2004 15:29

Ein Script erzeugt einen Error und der "Macher" behauptet es sei fehlerfrei?



:lol: Flieskommafehler :D


spass muss sein sprach wallenstein und schob die e..r mit hinein
chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests