mail() wie nutze ich das?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

DANKE

Postby miguelMadam » 15. November 2004 17:19

Ich glaube, daß ich es jetzt kapiert habe.

Ich brauche nur einen Mailserver auf meine Kiste zu installieren. Mercury scheint so ein Mailserver zu sein. Der macht dann das, was mein Provider mit seinem Mailserver bewerkstelligt, halt nur „local“. Wirklich simpel. Darauf hätte ich auch kommen können.

Aber ich bin’s nicht. Daher ein herzliches Danke an alle, die mir auf die Sprünge geholfen haben.

Auch wenn ich nun einen Hauch von Durchblick habe, werde ich doch keinen Mailserver installieren. 1. befürchte ich, daß meine alte Kisten dann zusammenbricht. 2. würde ich bereits bei der Installation kläglich scheitern, weil’s mit dem Durchblick bei mir doch nicht so weit her ist, und ich das Forum ständig belagern müßte. Gerade mal froh, mit php was auf die Beine zu kriegen, war XAMPP schon ein Abenteuer, was aber sein mußte, da ich mich mit try and error so durchschlage, und ohne XAMPP richtig aufgeschmissen wäre.

Daß XAMPP selbst von mir ohne jede blasse Ahnung ERFOLGREICH installiert werden konnte, beweist, daß die XAMPP-Programmierer besser drauf sind als die meisten MS-Programmierer. Nur das mit den Mails könnte man vielleicht doch noch in die FAQ aufnehmen. Dann würden so Keine-Ahnung-Von-Nix- Frager hier nicht so rumhängen.

Also nichts für ungut und danke.
miguelMadam
 
Posts: 3
Joined: 14. November 2004 13:12

Postby romi » 15. November 2004 17:24

will ich euch also mal unterbrechen :lol:

ich hab mir jetzt dieses oben genannte miniRelay installiert und in meinem mailclient localhost als smtp angegeben.
das versenden vom client aus geht an gmx-adressen und auch an meine webspac3e-emailaddy. das tolle ist, die kommen auch an.
wäre also das erste problem gelöst, oder?
dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby romi » 15. November 2004 17:55

also ich hab hier nun wohl eine für mich funktionierende lösung gefunden.

1. MiniRelay installieren:
http://www.batworld.net/modules.php?op=modload&name=Sections&file=index&req=printpage&artid=58

2. in der php.ini die emailadresse postmaster@localhost in eine syntaxgerechte abändern.

und schon klappts mit dem nachbarn.

!!!!!!!!!! bemerkt sei aber, beispielsweise web-adressen nehmen die emails nicht an. gmx hingegen schon und die meines providers auch.
zum testen für mich also die ideallösung und senden via php und mail() gehen auch von xampp :lol: :lol: :lol: :lol: :lol:
dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby romi » 15. November 2004 18:21

dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby Bandylegs » 25. November 2004 16:28

Nur mal ganz blöde gefragt:
Was heißt: "emailadresse postmaster@localhost in eine syntaxgerechte abändern" ??

Ansonsten hab ich nämlich das selbe Problem, mir grad die oben genannten Dateien runter geladen und nun will ich mal gucken ob ich das mit der Installation hin krieg.
Gruß, Bandy
Bandylegs
 
Posts: 4
Joined: 13. October 2004 14:15

Postby romi » 25. November 2004 16:40

gib dort einfach deine emailaddy an oder schreib ein ".de" hinten dran ;)
dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby Bandylegs » 25. November 2004 17:08

Danke!
Also in dem Fall also nur ein ".de" dran weil ich ja von meinem Rechner aus sende?
Gruß, Bandy
Bandylegs
 
Posts: 4
Joined: 13. October 2004 14:15

Postby deepsurfer » 25. November 2004 17:41

also kam nur eine fehlermeldung vom mercury ???

nimm statt @localhost mal IP @127.0.0.1
wenn mercury dann auch motzt nochmal melden..

ich kenn mercury nicht, gehe aber davon aus das er für sich selber einfach nur den @localhost nicht auflösen konnte und daher etwas bemängelt.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Bandylegs » 25. November 2004 17:56

Also bei mir funzt jetzt alles. Hab in der php.ini aus "postmaster@localhost" nur "postmaster@localhost.de" gemacht, gespeichert. Dann miniRelay und XAMPP gestartet, über php ne mail an yahoo.de verschickt und dann über meinen Account wie gewünscht empfangen. Also alles supi!

Danke
Gruß, Bandy
Bandylegs
 
Posts: 4
Joined: 13. October 2004 14:15

Postby romi » 25. November 2004 18:25

na bitte :D

soll nochmal einer sagen das geht nich :lol: :lol: :lol:
dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby deepsurfer » 25. November 2004 21:07

ohh... cool hast gerade einen offen Relayer aufgespiest. :shock:

Code: Select all
; <<>> DiG 9.2.1 <<>> localhost.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60176
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;localhost.de.                  IN      A

;; ANSWER SECTION:
localhost.de.           86337   IN      A       212.202.26.68

;; AUTHORITY SECTION:
localhost.de.           86337   IN      NS      ns.ginko.net.
localhost.de.           86337   IN      NS      ns2.ginko.net.

;; ADDITIONAL SECTION:
ns.ginko.net.           172737  IN      A       212.202.63.51
ns2.ginko.net.          172737  IN      A       213.148.129.71

;; Query time: 1 msec
;; SERVER: xxx.xxx.xxx.xxx#53(xxx.xxx.xxx.xxx)
;; WHEN: Thu Nov 25 21:04:19 2004
;; MSG SIZE  rcvd: 122



Da wird sich CyberCity aber gar nicht freuen.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby romi » 25. November 2004 21:26

wer???
dumm ist der, der nicht fragt :)
romi
 
Posts: 14
Joined: 11. November 2004 08:42

Postby deepsurfer » 25. November 2004 21:29

romi wrote:wer???


ich dachte das wäre klar... wer versucht und benutzt denn postmaster@localhost.de, soweit ich diesen thread verfolgt habe ist es der Bandylegs

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Bandylegs » 26. November 2004 03:58

Was ist mit mir?
Gruß, Bandy
Bandylegs
 
Posts: 4
Joined: 13. October 2004 14:15

Postby PF4 » 26. November 2004 11:18

deepsurfer wrote:ohh... cool hast gerade einen offen Relayer aufgespiest. :shock:

Code: Select all
; <<>> DiG 9.2.1 <<>> localhost.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60176
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;localhost.de.                  IN      A

;; ANSWER SECTION:
localhost.de.           86337   IN      A       212.202.26.68

;; AUTHORITY SECTION:
localhost.de.           86337   IN      NS      ns.ginko.net.
localhost.de.           86337   IN      NS      ns2.ginko.net.

;; ADDITIONAL SECTION:
ns.ginko.net.           172737  IN      A       212.202.63.51
ns2.ginko.net.          172737  IN      A       213.148.129.71

;; Query time: 1 msec
;; SERVER: xxx.xxx.xxx.xxx#53(xxx.xxx.xxx.xxx)
;; WHEN: Thu Nov 25 21:04:19 2004
;; MSG SIZE  rcvd: 122



Da wird sich CyberCity aber gar nicht freuen.

chirio
Deep



Was hat den das mit einem OpenRelay zu tun?
Nur weil der als Abesender ne Fremde domain eingetragen hat?
Der Mailserver von localhost.de hat damit garnix zu tun, lies mal die SMTP Specs vor der nächsten Aussage.

Aber man sollte es trozdem ned machen.
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests