Welche XAMPP-Version für Win XP Prof. nehmen ?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby cnoopi » 05. November 2004 17:30

Ah ja...
Wirde ich es noch eines Tages hinbekommen :cry:
Ich hab langsam aber sicher die nase voll. Unter Win 2000 läuft es gut.
Aber unter XP Prof. will es einfach nicht. Unter Status ist alles AKTIV, ausser SQL!

Kann mir bitte bitte einer helfen?
Muss heute noch fertig werden :roll: :?

Nachtrag:
Kann einer mit dieser Fehlermeldung was anfangen?

Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on 'localhost' (10061) in C:\xampp\xampp\htdocs\xampp\cds.php on line 65
cnoopi
 
Posts: 13
Joined: 04. November 2004 16:33

Postby pm27a » 05. November 2004 17:40

Wegen deiner Frage, hast du Service Pack 2 installiert? Wenn ja setze diese mal auf inaktiv und versuche es dann nochmal. Ich selber habe XP Pro mit SP2 und alles läuft rund.

Hoffe es liegt an dem.

mfg
pm27a
 
Posts: 13
Joined: 04. November 2004 12:11

Postby MoC » 05. November 2004 17:41

cnoopi wrote:[...]
Nachtrag:
Kann einer mit dieser Fehlermeldung was anfangen?

Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on 'localhost' (10061) in C:\xampp\xampp\htdocs\xampp\cds.php on line 65


mhm. also daraus lässt sich bloß schließen, dass der MySQL server nicht erreichbar ist. wenn (10061) den Port darstellt würde es mich nicht wundern, der normale MySQL port wäre 3... jedenfalls vierstellig, aber vlt. is die config vom Xampp MySQL anders. Aber da, aus vorausgehendem folgerbar, gar kein MySQL Dämon läuft, kann er sich auch mit keinem verbinden.
User avatar
MoC
 
Posts: 25
Joined: 02. September 2004 14:26

Postby cnoopi » 05. November 2004 17:53

Muss mich bei euch allen erstmal bedanken, das ihr so aktiv mir hilft !!!

@pm27a:
SP2 hab ich nicht. Ich habe gehört, das danach vielles daneben geht.
Deshalb will erstmal kein SP2 (wenn es nur möglich ist).
Welche Version hast du? die 1.4.9? oder die 1.4.7
Die 1.4.7 läuft auch gut. aber nicht die neue Vers.

@MoC:
Kann ich den das ganze auch irgendwie ändern? auf 3306 oder so?
cnoopi
 
Posts: 13
Joined: 04. November 2004 16:33

Postby pm27a » 05. November 2004 17:58

ich habe die Version 1.4.9, ohne installer. Bis jetzt richtete ich nichts grosses ein, auser dem root Passwort für SQL.

mfg
pm27a
 
Posts: 13
Joined: 04. November 2004 12:11

Postby MoC » 05. November 2004 18:10

cnoopi wrote:Muss mich bei euch allen erstmal bedanken, das ihr so aktiv mir hilft !!!

@pm27a:
SP2 hab ich nicht. Ich habe gehört, das danach vielles daneben geht.
Deshalb will erstmal kein SP2 (wenn es nur möglich ist).
Welche Version hast du? die 1.4.9? oder die 1.4.7
Die 1.4.7 läuft auch gut. aber nicht die neue Vers.

@MoC:
Kann ich den das ganze auch irgendwie ändern? auf 3306 oder so?


würd ich vorerst nich machen, das könnte auch ne fehlernummer etc. sein. ich denk auch nich, dass es daran liegt.
User avatar
MoC
 
Posts: 25
Joined: 02. September 2004 14:26

Postby cnoopi » 05. November 2004 18:25

pm27a wrote:ich habe die Version 1.4.9, ohne installer. Bis jetzt richtete ich nichts grosses ein, auser dem root Passwort für SQL.

mfg


Wie machst du das ohne Installer? Ist das kompliziert?
Oder genauso einfach?
Denn dan versuch mal damit. Vielleicht hab ich damit etwas mehr glück ;-)
cnoopi
 
Posts: 13
Joined: 04. November 2004 16:33

Postby pm27a » 05. November 2004 18:50

einfach herunterladen, entzippen, und starten (xampp_start.exe) und wie schon oft erwähnt, das Fenster offen lassen.

mfg
pm27a
 
Posts: 13
Joined: 04. November 2004 12:11

Postby cnoopi » 11. November 2004 20:37

Hallo alle zusammen !
Ich glaube, ich hab den Fehler gefunden! Bitte prüfen, ob es richtig ist:
Um eine Verbindung von einem Programm zu einer DB, z.B. MySQL, herzustellen, muss doch der Treiber von ODBC installiert sein.
Dieser Treiber fehlt mir wahrscheinlich.

So ! Jetzt will ich die Meinung der Profis hören, ob das o. g. stimmt :roll:

Danke im Voraus !
mfg : cnoopi ::.
cnoopi
 
Posts: 13
Joined: 04. November 2004 16:33

Postby Jan H. Krüger » 11. November 2004 21:16

Der ODBC-Treiber ist nur dann von nöten wenn die Verbindung auch über eben jenen hergestellt werden soll.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby cnoopi » 11. November 2004 23:01

Ach ja :cry:
Dann ist es doch nicht... LEIDER !
Ob ich den Fehler noch in diesem Jahr finde :?: :roll: :x :shock:

Seit Wochen auf der Suche nach dem Fehler - und immer noch nicht fundig geworden. Es wird wohl an meiner WIN XP Prof liegen. Sonst kann ich es mir nicht vorstellen.

Hatt einer vielleicht die vorgänger Version von XAMPP? Ich glaube: 1.4.7 ?!

Vielleicht liegt es ja daran. Wer weisssss?????!!!

mfg : cnoopi ::..|..::
cnoopi
 
Posts: 13
Joined: 04. November 2004 16:33

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests