Keine Verbindung zu Mysql möglich

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Keine Verbindung zu Mysql möglich

Postby Gonzo666 » 28. October 2004 10:39

Servus, bin neu im Xampp-Bereich (habe nix passendes zu meinem Problem im Forum gefunden) und habe ein großes Problem:
Folgender Fehler erscheint wenn ich im IE localhost eingebe und dann meine PHP-Datei starten will

TAG IMPORT
---------------------------------------------------------------------------------------------------------------

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES) in C:\Programme\xampp\htdocs\Mp3 Tag Editor\anmeldung_DB.php on line 3
Keine Verbindung möglich

Zuerst was ich getan habe,
1. ich habe Xampp in das Verzeichnis C:\Programme\xampp extrahiert
2. setup_xampp.bat gestartet
3. my.cnf in C:\ Verzeichnis kopiert
4. meine Datenbank in mysql importiert mit mysql<mp3.txt
5. Unter C:\Programme\xampp\htdocs hab ich mir einen Ordner angelegt mit meinen Php-Dateien
6. apache_start.bat und mysql_start.bat ausgeführt
7. apache_start.bat bleibt Fenster offen denkmal dass es funktioniert, aber mysql_start.bat startet und dann erscheint im Fenster Beendet – Mysql_start
“Diese Eingabeaufforderung nicht während des Running beenden
Please don’t close...
Mysql is trying to start …
Mysql is starting with mysql\bin\my.cnf (console)“
à und dann ändert sich das Fenster in Beendet – Mysql_start
8. Wenn ich jetzt im IE localhost eingebe werden meine php-Dateien angezeigt und dann wähl ich eine Datei an und dann erscheint oben beschriebener Fehler „Keine Verbindung möglich“ < PHP-Dateien funktionieren bei einem Freund einwandfrei!!>
9. meine my.ini-Datei sieht so aus:
#This File was made using the WinMySQLAdmin 1.4 Tool
#15.09.04 18:06:29

#Uncomment or Add only the keys that you know how works.
#Read the MySQL Manual for instructions


[mysqld]
basedir=C:/PROGRAMME/XAMPP/MYSQL
#bind-address=192.168.0.1
datadir=C:/PROGRAMME/XAMPP/MYSQL/data
#language=C:/PROGRAMME/XAMPP/MYSQL/share/german
#slow query log#=
#tmpdir#=C:/Programme/xampp/tmp
#port=3306
#set-variable=key_buffer=16M

[WinMySQLadmin]
Server=C:/PROGRAMME/XAMPP/MYSQL/bin/mysqld.exe
#user=root
#password=
QueryInterval=10

10. Außerdem ist meine Firewall deaktiviert
11. Die Tests in apache friends Startfenster funktionieren alle!
Unter phpmyadmin kann ich mir meine Datenbank auch anschauen!
12. Winmysqladmin zeigt mir ne grüne Ampel
Unter Databases sieht man meine Datenbank
Start check passt auch alles (yes, yes, ok, ok, ok)
13. Mein System ist Windows 98 SE und hab den myodbc 3.51 installiert :x
Gonzo666
 
Posts: 3
Joined: 28. October 2004 09:07

Postby Wiedmann » 28. October 2004 13:24

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES) in C:\Programme\xampp\htdocs\Mp3 Tag Editor\anmeldung_DB.php on line 3

Diese Meldung sagt ja eigentlich schon alles:
Dein Script benutzt zur Anmeldung an MySQL ein Passwort, dass mit dem aktuellen Passwort für diesen Benutzer nicht übereinstimmt.

(XAMPP Standard: "root" hat kein Passwort)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gonzo666 » 28. October 2004 16:28

Danke, für den Tipp
- habe zuerst jetzt den my.cnf die Verknüpfung als Kurzwahleintrag entfernt
- dann habe ich die my.cnf bearbeitet und der my.ini angepasst
(Frage darf die my.ini im Windows Verzeichnis bleiben oder muss ich diese löschen) habe Xampp 1.2
- my.ini hat jetzt ein Passwort und in localhost/phpmyadmin habe ich dasselbe Passwort angegeben!
- und in der config.inc.php habe ich auch dasselbe Passwort vergeben und unter auth_typ "http" angegeben (muss ich sonst noch wo ein Passwort eingeben????)

$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = ''; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables)
$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = 'MeinPasswort'; // MySQL password (only needed
// with 'config' auth_type)
$cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only
// this db is displayed
// at left frame
// It may also be an array
// of db-names

Aber folgender Fehler bleibt beim Aufrufen meiner PHP-Datei

TAG IMPORT

---------------------------------------------------------------------------------------------------------------

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES) in C:\Programme\xampp\htdocs\Mp3 Tag Editor\anmeldung_DB.php on line 3
Keine Verbindung möglich

Bin für jede Hilfe dankbar
Gruß gonzo666
Gonzo666
 
Posts: 3
Joined: 28. October 2004 09:07

Postby Wiedmann » 28. October 2004 16:45

Wo änderst denn du überall was rum? Ich hab nur von einem geschrieben:
Wiedmann wrote:Dein Script...

--> "C:\Programme\xampp\htdocs\Mp3 Tag Editor\anmeldung_DB.php"

Ansonsten findest du in der FAQ eine Anleitung wie man in/für MySQL Passwörter vergibt
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests