Localhost nicht erreichbar

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Localhost nicht erreichbar

Postby diamond2010 » 27. October 2004 09:13

Hallo Leute,

ich bin neu und hab von Apache nicht viel Ahnung. Da ich aber einen PHP Lehrgang gemacht habe und mein wissen vertiefen will, hab ich mir xampp
von eure Seite geladen und installiert.
Jetz zu meinem Problem.
Apache startet zwar und MySQL auch, nur wenn ich in Firefox auf den localhost gehen will kann er den nicht öffnen.

Meine Daten
Notebook amd 1500+
xp home mit zonealarm firefox hat zugang xp firewall aus.
internet anonym : aus

localhost kann ich anpingen.
Bitte HELP

Danke und
Gruß Diamond
diamond2010
 
Posts: 1
Joined: 27. October 2004 09:01

Versuch mal...

Postby neotoma » 29. October 2004 17:28

Hi,
folgender Eintrag aus der FAQ hat mir geholfen :
Bitte in der Datei \xampp\apache\conf\httpd.conf die Zeile => # Win32DisableAcceptEx ON entkommentieren. Also richtig:

Win32DisableAcceptEx ON

Standardgemäß ist im Apache seit jüngster Zeit eine verbesserte Winsock 2 - AcceptEx() Unterstützung etabliert, die aber nicht auf den Homevarianten (98/ME usw.) funktioniert. Leider sind ab und zu auch NT Systeme (2000 und Xp Professional) davon betroffen. Die Anweisung "Win32DisableAcceptEx ON" deaktiviert nun den eigentlich verbesserten Socket Zugriff bei Problemen.


Danach lief es bei mir (Athlon 1800/XP).

Vielleicht sollte man dieses in einer Art Hilfe-Paket bei XAMPP anbieten.
Also vorgefertigte Lösungen wie oben. Dann muss man nicht mehr solange suchen.

Mike
neotoma
 
Posts: 1
Joined: 29. October 2004 16:25
Location: Mechernich

Postby Hollodrio » 31. October 2004 08:37

hallo
Ich habe das gleiche Problem, aber bei mir hat der Tip nicht geholfen.
Ich häng mal ein Bild meines Fehlers an.
PS.: Habe weder in der FAQ noch hier im Forum was darüber gefunden...
Image
Hollodrio
 
Posts: 8
Joined: 31. October 2004 07:33
Location: Thueringen

Postby Kristian Marcroft » 31. October 2004 09:41

Hi,

bei dir blockiert etwas Port 443 und 3306.
Vermutlich eine Firewall?
Evtl. die von XP?

Ansonsten müsstest du halt herausfinden welches Prog. das ist.
Hier im Forum gibt es ein Link zu einem Tool names YAPS such da mal nach.

Beende diese Programme/Firewall richtig configurieren

und versuch dann nochmal XAMPP zu starten.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Hollodrio » 31. October 2004 10:32

laut Yaps ist weder der eine noch der andere Port belegt.
Kann man xampp nicht irgentwie sagen auf welchem port es laufen soll?
PS.: habe das Problem erst seit SP 2
Hollodrio
 
Posts: 8
Joined: 31. October 2004 07:33
Location: Thueringen

Postby Hollodrio » 31. October 2004 10:49

so habs zum laufen bekommen es war der IIS Admin.
Aber es wird ja auch der Dienst für das empfangen für Emails unter Outlook beendet.
Gibt es alternativen?
Hollodrio
 
Posts: 8
Joined: 31. October 2004 07:33
Location: Thueringen

Postby franzi_thebest » 31. October 2004 14:06

Ich hatte das gleiche problem. Bei mir hat das geklappt:

Tools>Internet Options>Tab "Connections">Klicke "Lan Settings">"Use a proxy server for your LAN" deaktivieren.

Viel Gluck!
franzi_thebest
 
Posts: 5
Joined: 30. October 2004 21:18

Postby Hollodrio » 31. October 2004 16:03

Danke funktioniert jetzt alles.
Hollodrio
 
Posts: 8
Joined: 31. October 2004 07:33
Location: Thueringen


Return to XAMPP für Windows

Who is online

Users browsing this forum: jacktherapper and 10 guests