vhosts zum 23836367mal

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

vhosts zum 23836367mal

Postby fchojinski » 24. August 2020 16:32

Hallo zusammen,

sorry, ich weiß, dieses Thema wurde schon x-mal gezeigt. Trotzdem bitte ich euch um Hilfe. Ich habe folgendes getan:

1. Aufsetzen einer VM mit Windows 10 als Ersatz unseres bisherigen Intranetservers
2. Installation xammp in d:\xampp
Server läuft und zeigt xampp dashboard.

Der Server soll mehrere verschiedene Intranetseiten zeigen. Der Einfachheit halber habe ich sie mal test1 und test2 genannt. In die Windows Hosts Datei habe ich eingetragen:

# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
127.0.0.1 test1
127.0.0.1 test2

In die http-vhosts.conf habe ich eingetragen:
#
# Use name-based virtual hosting.
#
NameVirtualHost *:80
#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ##ServerName or ##ServerAlias in any <VirtualHost> block.
#


<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/test1"
ServerName test1
<directory "D:/xampp/htdocs/test1">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/test2"
ServerName test2
<directory "D:/xampp/htdocs/test2">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</directory>
</VirtualHost>

In der httpd.conf steht
# Virtual hosts
Include conf/extra/httpd-vhosts.conf

Nach endlosen Versuchen ist es nun so, dass er bei Eingabe von test1 und test2 (http://test1) immer auf der index.php von test1 landet. Vielleicht weiß jemand wo der Fehler steckt.

Wie muss ich vorgehen, wenn ich aus test1 www.test1.beispiel-gmbh.de machen will? (Das Routing erledigt unsere Firewall, das funktioniert, allerdings nur mit www vorne dran).

Bisher hatte ich mamp im einsatz, ist zwar schön zum Anklicken aber leider unendlich lahm. Und leider bleibt man beim Klicken auch doof. :-(

Vielleicht könnt ihr mir die entscheidenden Hinweise geben. Vielen Dank schon mal vorab.

Gruß
Frank Chojinski
fchojinski
 
Posts: 8
Joined: 13. February 2017 17:21
XAMPP version: 3.2.4
Operating System: Windows S10 pro

Re: vhosts zum 23836367mal

Postby Altrea » 24. August 2020 16:47

Hallo,

Bei vhosts ist es so, dass Aufrufe die bei keinem vhost Eintrag treffen, immer der oberste vhost genommen wird.
Daher ist es immer ratsam, als obersten vhost einen Catchall vhost zu definieren.
Denn nun weißt du nicht, trifft nur der zweite vhost nicht oder vielleicht auch der erste nicht und du hast ein generelleres Problem?

Dann solltest du zwei Kommandozeilen Parameter ungedingt kennen (kannst du am besten über die XAMPP Shell eingeben, oder in der normalen Kommandozeile wenn du vorher ins apache\bin navigierst):
Config Syntax überprüfen
Code: Select all
httpd -t


Alle virtual hosts die Apache in der Konfiguration aufgenommen hat ausgeben
Code: Select all
httpd -S


Die Zeile NameVirtualHost ist mit Apache 2.4 obsolet und sollte auskommentiert werden.

Weiterhin bietet es sich an, für jeden vhost eigene access und error logs zu definieren, und das Logging so hochzuschrauben, dass auch rewrites und redirects ausgegeben werden. In einigen Fällen kann es nämlich sein, dass du wie blöd einen Fehler suchst und am Ende steckt der in einer Umleitung die in einer .htaccess definiert ist.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10342
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: vhosts zum 23836367mal

Postby fchojinski » 26. August 2020 14:01

Hallo Altrea,

vielen Dank für deine Hilfe, jetzt bin ich schon viel weiter. Es funktioniert soweit mit dem catchall und mit dem test1. Der test2 springt aber auch aufs default (xampp) und ich weiß nicht warum. Hier mal die Ausgabe von httpd -S:

# httpd -S
VirtualHost configuration:
*:80 is a NameVirtualHost
default server xampp (D:/xampp/apache/conf/extra/httpd-vhosts.conf:27)
port 80 namevhost xampp (D:/xampp/apache/conf/extra/httpd-vhosts.conf:27)
port 80 namevhost www.test1.kleiner-gmbh.de (D:/xampp/apache/conf/extra/httpd-vhosts.conf:39)
port 80 namevhost www.test2.kleiner-gmbh.de (D:/xampp/apache/conf/extra/httpd-vhosts.conf:49)
*:443 www.example.com (D:/xampp/apache/conf/extra/httpd-ssl.conf:121)
ServerRoot: "D:/xampp/apache"
Main DocumentRoot: "D:/xampp/htdocs"
Main ErrorLog: "D:/xampp/apache/logs/error.log"
Mutex ssl-stapling-refresh: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="D:/xampp/apache/logs/" mechanism=default
PidFile: "D:/xampp/apache/logs/httpd.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: SRVROOT=D:/xampp/apache


Die httpd-vhosts.conf sieht so aus:

<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs"
ServerName xampp
<directory "D:/xampp/htdocs/">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/test1"
ServerName www.test1.kleiner-gmbh.de
<directory "D:/xampp/htdocs/test1">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/test2"
ServerName www.test2.kleiner-gmbh.de
<directory "D:/xampp/htdocs/test2">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</directory>
</VirtualHost>

hosts:

# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
127.0.0.1 www.test1.kleiner-gmbh.de
127.0.0.1 www.test2.kleiner-gmbh.de

Kannst Du mir bitte nochmal helfen?

Gruß
Frank
fchojinski
 
Posts: 8
Joined: 13. February 2017 17:21
XAMPP version: 3.2.4
Operating System: Windows S10 pro

Re: vhosts zum 23836367mal

Postby Altrea » 26. August 2020 14:34

Ich vermute immernoch, dass von deiner Anwendung oder einer .htaccess Datei ein Redirect ausgelöst wird.

Ich würde das Logging in den vhosts hochschrauben, in etwa so, nur halt für alle vhosts einzeln:

Code: Select all
<VirtualHost *:80>
  DocumentRoot "D:/xampp/htdocs/test1"
  ServerName www.test1.kleiner-gmbh.de
 
  ErrorLog "logs/test1-error.log"
  CustomLog "logs/test1-access.log" common
  LogLevel notice rewrite:trace5

  <directory "D:/xampp/htdocs/test1">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Require all granted
  </directory>
</VirtualHost>


Dann hast du für jeden vhost eigene Log-Dateien, siehst also auch, wenn ein Request ursprünglich zwar vom vhost angenommen wird, dann aber woanders weitergeleitet wird.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10342
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: vhosts zum 23836367mal

Postby fchojinski » 26. August 2020 15:51

Hi Altrea,

jetzt klappt alles, vielen Dank. Ich habe den Eindruck, dass meine Änderungen teilweise ein paar Stunden gedauert haben, bevor sie wirksam wurden (Cache oder weiß der Geier was). Ich habe das logging eingebaut und lasse es mal aktiviwert, damit ich auch weiterhin beobachten kann, wie es läuft.

Vielen Dank nochmal für deine Unterstützung.

Viele Grüße
Frank
fchojinski
 
Posts: 8
Joined: 13. February 2017 17:21
XAMPP version: 3.2.4
Operating System: Windows S10 pro


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 38 guests