Fehlermeldung direkt nach Neuinstallation

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung direkt nach Neuinstallation

Postby MarcoS63 » 12. August 2019 11:15

Hallo, direkt nach der Neuinstallation (Version 7.3.8) erscheinenen diverse Fehlermeldungen und man kann keine Datenbank anlegen bzw. damit arbeiten. Diese Meldungen erscheinen beim Aufruf von phpMyadmin:

1. Der phpMyAdmin-Konfigurationsspeicher ist nicht vollständig konfiguriert, einige erweiterte Funktionen wurden deaktiviert. Finden Sie heraus warum.
Oder wechseln Sie in einer beliebigen Datenbank zum Tab „Operationen“, um die Einstellung dort vorzunehmen.

2. mysqli_real_connect(): (HY000/1045): Access denied for user 'pma'@'localhost' (using password: NO)

3. Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen.

Meldung 2. und 3. erscheinen jeweils 3x nacheinander.

Wenn man eine Datenbank öffnen will, erscheint u.a. folgende Meldung:

#1932 - Table 'phpmyadmin.pma__tracking' doesn't exist in engine

DIe Hinweise zum Beheben der Probleme helfen mir leider nicht weiter. Ich hatte eine ältere xampp-Version vor ca. 1,5 Jahren problemlos zum Laufen gebracht, nun blockieren mich diese Meldungen gleich zu Anfang. Könnte mir jemand helfen?

Danke dun Gruß, Marco
MarcoS63
 
Posts: 3
Joined: 12. August 2019 11:02
XAMPP version: 7.3.8
Operating System: WIN 10

Re: Fehlermeldung direkt nach Neuinstallation

Postby Altrea » 12. August 2019 11:49

Hallo Marco,

Kurze Antwort: Nutze lieber XAMPP 7.3.5.
Alle später erschienenen Versionen haben große Probleme mit MariaDB 10.3 (korrupte Datenbanken, etc.).

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9741
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fehlermeldung direkt nach Neuinstallation

Postby Nobbie » 12. August 2019 12:00

Ich frage mich echt, was Bitname sich da für ein Zeug zusammengeholzt hat. Habe gerade die 7.3.8 unter Linux installiert, da ist tatsächlich in mysql.proc eine Spalte zu wenig in der Tabelle (die Spalte "aggregate" ist neu dazu gekommen, fehlt aber).

Und wenn ich diese Fehlermeldung sehe " Table 'phpmyadmin.pma__tracking' doesn't exist in engine" - da erinnere mich daran, dass das vor Jahren schon einmal das Problem war, ich weiß die Ursache nicht mehr, da werden zwei Unterstriche generiert statt einem Unterstrich (pma__tracking vs. pma_tracking). Ein uralter Bug, der jetzt wieder drin ist...

Sowieso scheint die 10.3.8 Version von MariaDB unter Windows mit Xampp nicht zu harmonieren, das ist ja ätzend wie oft hier dieselbe Fehlermeldung kommt. Ein wenig mehr Sorgfalt bei neuen Releases wäre hilfreich.
Nobbie
 
Posts: 11052
Joined: 09. March 2008 13:04

Re: Fehlermeldung direkt nach Neuinstallation

Postby Altrea » 12. August 2019 12:25

Das mit den zwei Unterstrichen ist nicht primär Bitnami anzulasten. Die Satdardtabellen einer frischen phpMyAdmin Installation haben alle zwei Unterstriche.
Aber viel Ärgerlicher ist, dass das MariaDB Problem noch nicht gelöst ist, weiter Aktualisierte XAMPP Versionen rausgehauen werden und das ganze ohne jedlichen Hinweis darauf, dass diese Versionen fehlerhaft sind.

Ich habe mir gerade XAMPP 7.3.8 frisch installiert, die Datenbanktabellen über das mysql_upgrade Script geradegezogen und phpmyadmin frisch neuinstalliert. Obwohl ich die Datenbank anschließend über den SHUTDOWN Befehl heruntergefahren habe, kam MariaDB anschließend nichtmehr hoch, mysql.user Tabelle korrupt.

Man sollte zuerst einmal das Problem lösen und die fehlerhaften Versionen auch als solche Kennzeichnen, bzw. auf der Homepage wieder die Versionen von Mai als Standarddownload einstellen.
Das Supportaufkommen hier besteht zu 90% aus diesen Ursachen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9741
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fehlermeldung direkt nach Neuinstallation

Postby MarcoS63 » 12. August 2019 12:43

Mit der älteren Version 7.2.21 sieht es ganz genauso aus. Mit 7.1. ebenso. Leider weiß ich nicht, wie ich die fehlenden/falschen Einstellungen "gerade ziehen" soll.
MarcoS63
 
Posts: 3
Joined: 12. August 2019 11:02
XAMPP version: 7.3.8
Operating System: WIN 10

Re: Fehlermeldung direkt nach Neuinstallation

Postby Altrea » 12. August 2019 12:52

XAMPP 7.2.21 ist NICHT älter, es ist lediglich eine andere PHP Minor Version enthalten.
PHP unterhält derzeit 3 (bald 4) aktive Versionsstränge.

Für ältere Versionen, schau bitte hier: https://sourceforge.net/projects/xampp/ ... 20Windows/
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9741
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fehlermeldung direkt nach Neuinstallation

Postby MarcoS63 » 12. August 2019 13:41

Danke, Altrea! Hab die 7.3.5 installiert und es geht! Die Versionsnummerierung muss man ja nicht unbedingt verstehen...
MarcoS63
 
Posts: 3
Joined: 12. August 2019 11:02
XAMPP version: 7.3.8
Operating System: WIN 10

Re: Fehlermeldung direkt nach Neuinstallation

Postby Nobbie » 12. August 2019 17:21

MarcoS63 wrote:Danke, Altrea! Hab die 7.3.5 installiert und es geht! Die Versionsnummerierung muss man ja nicht unbedingt verstehen...


Eigentlich ist sie primitiv: schlicht und ergreifend identisch mit dem Release der ausgelieferten PHP Version. Du hast also PHP 7.3.5 installiert und "irgendeinen Apache plus irgendeine MariaDB".
Nobbie
 
Posts: 11052
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests