phpMyAdmin: Nur Probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin: Nur Probleme

Postby Maexchen144 » 07. July 2019 09:21

Hallo Leute,
bin wirklich am Ende meines Lateins angelangt, versuche schon seit Tagen folgendes Problem zu lösen:

mysql_error.log:
2019-07-07 10:18:18 10552 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2019-07-07 10:18:18 10552 [Note] InnoDB: The InnoDB memory heap is disabled
2019-07-07 10:18:18 10552 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-07-07 10:18:18 10552 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2019-07-07 10:18:18 10552 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-07-07 10:18:18 10552 [Note] InnoDB: Using generic crc32 instructions
2019-07-07 10:18:18 10552 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2019-07-07 10:18:19 10552 [Note] InnoDB: Completed initialization of buffer pool
2019-07-07 10:18:19 10552 [Note] InnoDB: Highest supported file format is Barracuda.
2019-07-07 10:18:19 10552 [Note] InnoDB: The log sequence number 1835047 in ibdata file do not match the log sequence number 1835057 in the ib_logfiles!
2019-07-07 10:18:19 10552 [Note] InnoDB: Restoring possible half-written data pages from the doublewrite buffer...
2019-07-07 10:18:19 10552 [Note] InnoDB: 128 rollback segment(s) are active.
2019-07-07 10:18:19 10552 [Note] InnoDB: Waiting for purge to start
2019-07-07 10:18:19 10552 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.41-84.1 started; log sequence number 1835057
2019-07-07 10:18:19 20012 [Note] InnoDB: Dumping buffer pool(s) not yet started
2019-07-07 10:18:19 10552 [Note] Plugin 'FEEDBACK' is disabled.
2019-07-07 10:18:19 10552 [Note] Server socket created on IP: '::'.
2019-07-07 10:18:19 10552 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '10.1.37-MariaDB' socket: '' port: 3307 mariadb.org binary distribution

Ich habe es mit der neuseten Version versucht, jetzt mit 5.6.39 und immer wieder kann ich via phpMyAdmin nicht auf die DB zugreifen.

Apache (error.log):
[Sun Jul 07 10:14:41.717157 2019] [ssl:warn] [pid 14668:tid 692] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:14:41.893686 2019] [ssl:warn] [pid 14668:tid 692] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:14:41.934578 2019] [mpm_winnt:notice] [pid 14668:tid 692] AH00455: Apache/2.4.37 (Win32) OpenSSL/1.0.2p PHP/5.6.39 configured -- resuming normal operations
[Sun Jul 07 10:14:41.934578 2019] [mpm_winnt:notice] [pid 14668:tid 692] AH00456: Apache Lounge VC11 Server built: Oct 22 2018 14:14:30
[Sun Jul 07 10:14:41.935578 2019] [core:notice] [pid 14668:tid 692] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jul 07 10:14:41.939563 2019] [mpm_winnt:notice] [pid 14668:tid 692] AH00418: Parent: Created child process 2696
[Sun Jul 07 10:14:42.700529 2019] [ssl:warn] [pid 2696:tid 628] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:14:42.856123 2019] [ssl:warn] [pid 2696:tid 628] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:14:42.896010 2019] [mpm_winnt:notice] [pid 2696:tid 628] AH00354: Child: Starting 150 worker threads.
[Sun Jul 07 10:18:19.182390 2019] [ssl:warn] [pid 10392:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:18:19.241237 2019] [core:warn] [pid 10392:tid 604] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jul 07 10:18:19.337976 2019] [ssl:warn] [pid 10392:tid 604] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:18:19.371883 2019] [mpm_winnt:notice] [pid 10392:tid 604] AH00455: Apache/2.4.37 (Win32) OpenSSL/1.0.2p PHP/5.6.39 configured -- resuming normal operations
[Sun Jul 07 10:18:19.371883 2019] [mpm_winnt:notice] [pid 10392:tid 604] AH00456: Apache Lounge VC11 Server built: Oct 22 2018 14:14:30
[Sun Jul 07 10:18:19.371883 2019] [core:notice] [pid 10392:tid 604] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jul 07 10:18:19.375877 2019] [mpm_winnt:notice] [pid 10392:tid 604] AH00418: Parent: Created child process 14920
[Sun Jul 07 10:18:20.158777 2019] [ssl:warn] [pid 14920:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:18:20.308383 2019] [ssl:warn] [pid 14920:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Jul 07 10:18:20.368219 2019] [mpm_winnt:notice] [pid 14920:tid 632] AH00354: Child: Starting 150 worker threads.

Fehlermeldung beim Start von phpMyAdmin:
MySQL meldet: Dokumentation
Die Verbindung konnte aufgrund von ungültigen Einstellungen nicht hergestellt werden.
mysqli_real_connect(): Server sent charset (255) unknown to the client. Please, report to the developers
mysqli_real_connect(): (HY000/2054): Server sent charset unknown to the client. Please, report to the developers
Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen.
mysqli_real_connect(): Server sent charset (255) unknown to the client. Please, report to the developers
mysqli_real_connect(): (HY000/2054): Server sent charset unknown to the client. Please, report to the developers
phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen und die Verbindung wurde zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Passwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, die Sie vom Administrator erhalten haben, entsprechen.

Also wo soll ich noch überall nachschauen, dass ich das zum Laufen bekomme?
Danke und Grüße,
Markus
Maexchen144
 
Posts: 4
Joined: 06. July 2019 17:54
XAMPP version: 3.2.4
Operating System: Windows 10

Re: phpMyAdmin: Nur Probleme

Postby Altrea » 07. July 2019 17:16

Hast du phpMyAdmin den neuen Port 3307 mitgeteilt?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9768
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin: Nur Probleme

Postby Maexchen144 » 07. July 2019 22:47

Hallo ALtrea,
Danke für deinen wirklich sehr guten Hinweis! Habe nun in der "config.inc.php" folgende Zeile geändert:
$cfg['Servers'][$i]['host'] = '127.0.0.1:3307';
und siehe da, ich kann wieder auf phpMyAdmin zugreifen.
Danke!
Ich arbeite mit dem MySQL-Workbench, da er mir wirklich gut gefällt.
Ich habe eine DB angelegt und kann auch Tables createn, jedoch erhalte ich hier immer die Angabe: Tables could not be fetched!
Wenn ich eine Abfrage mache erhalte ich folgende Fehlermeldung:

Error Code: 1146 Table 'performance_schema.user_variables_by_thread' doesn't exist

Bei phpMyAdmin habe ich das nicht. Sollte hierzu jemand schon eine Lösung haben, dann jetzt schon danke, ansonsten mache ich mich wieder auf die Suche.
Danke nochmals für die obere Lösung,
Grüße,
Markus
Maexchen144
 
Posts: 4
Joined: 06. July 2019 17:54
XAMPP version: 3.2.4
Operating System: Windows 10

Re: phpMyAdmin: Nur Probleme

Postby Altrea » 07. July 2019 22:57

Es gibt für die phpMyAdmin Konfigurationsdatei auch ein eigenes Setting für den Port, diese Angabe gehört eigentlich nicht in den Host.

Nach meinem letzten Kenntnisstand ist die MySQL Workbench nicht zu 100% Kompatibel mit MariaDB zu betreiben.
Wenn ich im Internet suche finde ich folgenden Eintrag der auf einen Bug in MySQL Workbench 8.0.16 hindeutet: https://stackoverflow.com/questions/562 ... chema-user
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9768
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests