Nach Umzug weiße Seite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Nach Umzug weiße Seite

Postby Nazaled » 08. March 2019 16:01

Servus,

ich habe auf meinen Laptop XAMPP laufen um dort PHP Projekte zu programmieren. Nun wollte ich auf meinen Festrechner zu Hause weiter arbeiten und habe mir dort auch XAMPP installert. Dann habe ich fein den Script in rüber kopiert und erhalte nun eine weiße Seite. Kein Error 404 oder sonst was, einfach keine Ausgabe. PHP läuft, phpinfo() gibt alles fein aus.

Kennt jemand das Problem? Will ungern jetzt Virtuell Ubuntu als Lamp laufen lassen.

Gruß Sebastian
Nazaled
 
Posts: 2
Joined: 08. March 2019 15:53
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Nach Umzug weiße Seite

Postby Nobbie » 08. March 2019 17:44

Gar keine Ausgabe, oder vielleicht doch im Source (Browser->Rechtsklick->Sourcecode anschauen o.ä.)?

Kann falsches PHP Tag sein (<? anstatt <?php), kann Fehler im Script sein (was sagt error_log, was sagt acces_log?), kann eine fehlende oder fehlerhafte .htacess sein oder oder oder oder oder oder oder - da gibt es tonnenweise Ursachen. Du kennst Dein Script (hier kennt keiner irgendetwas), irgendetwas hast Du übersehen.
Nobbie
 
Posts: 11103
Joined: 09. March 2008 13:04

Re: Nach Umzug weiße Seite

Postby Nazaled » 08. March 2019 21:17

Hi,

Am Code liegt es nicht. Habe nun den gesamten xampp Ordner vom Laptop genommen und die Pfade angepasst. Nun läuft es. Ich denke einfach das ich irgendwas in der config vergessen habe. Mit error_repporting lag es wohl am soap, da ich mit api arbeite. Weiss nur nicht mehr wo ich das alles eingestellt hatte.

Aber nun geht's ja wieder und ich kann zu Hause weiter arbeiten.
Nazaled
 
Posts: 2
Joined: 08. March 2019 15:53
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Nach Umzug weiße Seite

Postby Nobbie » 08. March 2019 21:29

Nazaled wrote:Mit error_repporting lag es wohl am soap


Wunderbar, ein schönes Beispiel, wie sinnlos solche oberfächlichen Beschreibungen sind und warum hier NIEMAND auch nur eine Ahnung haben kann, was das eigentliche Problem ist. Zum Glück hat sich das Problem jetzt ja so erledigt, es hätte sonst niemand auch nur ansatzweise eine Idee haben können, was falsch läuft.
Nobbie
 
Posts: 11103
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests