Apache doesn't start

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache doesn't start

Postby fspade » 08. December 2018 22:28

I installed xampp 5.6.38 (because I need php5 to save an older cms) with admin right under Win 8.1. When I start the control panel. MySQL starts okay, but Apache produces these errors:Image
I understand it can't create its log files, which is probably because of missing rights.
How can I give it the rights it needs?
Thanks in advance for your kind help.
Frank
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10

Re: Apache doesn't start

Postby Nobbie » 09. December 2018 00:27

fspade wrote:I understand it can't create its log files, which is probably because of missing rights.


The most important part is before: it cannot connect to Port 80.

Why dont you use the Xampp Control? Run it with Admin rights, but the Port problem probably remains. Find out which process already uses Port 80.
Nobbie
 
Posts: 10671
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby fspade » 09. December 2018 08:37

Thank you Nobbie,
as I said, I use the XAMPP Control Panel, which I start as admin.
How can I go about finding out what is blocking port 80?
Kind regards
Frank
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10

Re: Apache doesn't start

Postby Nobbie » 09. December 2018 10:53

The control panel does not run in a terminal (DOS Box) and shows up more messages. There is also a button for Netstat for Ports listing.
Nobbie
 
Posts: 10671
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby fspade » 09. December 2018 12:52

I am afraid I don't get it. So far I didn't work in a DOS Box.
I use Windows-Explorer and start xampp-control.exe from c:\xampp with admin previleges.
Thanks for the tipp with Netstat, which shows 0.0.0.0 80 4 System. Doesn't look suspicious to me.
Since it can't write to the log file, I don't get more info from it.
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10

Re: Apache doesn't start

Postby fspade » 09. December 2018 12:55

12:50:35 [Apache] Problem festgestellt!
12:50:35 [Apache] Port 80 in Benutzung von "Unable to open process" (PID 4)!
12:50:35 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports nicht frei sind!
12:50:35 [Apache] Die blockierende Anwendung muss deinstalliert/deaktiviert/rekonfiguriert werden oder
12:50:35 [Apache] Apache und das Control Panel müssen auf einen anderen Port zu lauschen
12:50:35 [Apache] Versuche Apache zu starten...
12:50:36 [Apache] Statusänderung erkannt: gestartet
12:50:43 [Apache] Statusänderung erkannt: gestoppt
12:50:43 [Apache] Fehler: Apache wurde unerwartet beendet
12:50:43 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
12:50:43 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
12:50:43 [Apache] Drücke den Logs Button um error logs zu sehen und prüfe
12:50:43 [Apache] im Windows Event Viewer für weitere Hinweise
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10

Re: Apache doesn't start

Postby Boboli » 09. December 2018 13:20

Open Task-Manager, go to "Dienste" and stop "WWW-Publishingdienst". (The button for "Dienste" is in xampp-controll UI too)
Boboli
 
Posts: 5
Joined: 05. August 2018 15:01
XAMPP version: 7.2.7
Operating System: Windows 10

Re: Apache doesn't start

Postby Nobbie » 09. December 2018 13:30

Warum schreibst Du eigentlich als Deutscher im deutschen Forum (s.o. "Language german only!") auf englisch?

Außerdem hat sich gestern erst ein Anwender die Mühe gegeben, genau unter dem Topic " Port 80 in Benutzung von "Unable to open process" (PID 4)!" eine ausführlicher Erklärung zu schreiben, inklusive Anleitung, wie man das behebt. Aber ich habe befürchtet, dass das einfach nicht gelesen wird, drauflos fragen ohne mal hinzuschauen ist leider für die meisten einfacher...

viewtopic.php?f=4&t=75203#p262948
Nobbie
 
Posts: 10671
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby fspade » 09. December 2018 14:33

Boboli wrote:Open Task-Manager, go to "Dienste" and stop "WWW-Publishingdienst". (The button for "Dienste" is in xampp-controll UI too)
Thank you Boboli, that did it! Keep up the good work...
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10

Re: Apache doesn't start

Postby fspade » 09. December 2018 14:35

Nobbie wrote:Warum schreibst Du eigentlich als Deutscher im deutschen Forum (s.o. "Language german only!") auf englisch?
Sorry oder besser tut mir leid, war mir nicht aufgefallen (muss wohl am Alter liegen ;-)
Jetzt geht's, danke.
fspade
 
Posts: 11
Joined: 18. November 2006 00:04
Location: Potsdam
XAMPP version: 5.6.38/7.2.12
Operating System: Win 8.1/10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests