Probleme mit mod_proxy und Virtualhosts

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit mod_proxy und Virtualhosts

Postby xNanuNanax » 19. September 2018 20:27

Hi, habe hier 2 Xampp Versionen laufen.
Eine läuft auf localen IP, der andere über InternetIP. beide aufm gleichen rechner.

Hab auf dem Xampp-Local(localIP) haufen Virtualhosts.
Diese localen hosts, soll der xampp der von Internet erreichbar ist, nach Internet spiegeln. Also aus dem Internet aufrufbar machen.

sub1.domain.tld spiegelt per mod_proxy sub1.local.tld
sub2.domain.tld spiegelt sub2.local.tld
sub3.domain.tld spiegelt sub3.local.tld
Der von Internet erreichbare Apache hat ähnlich klingende virtualhosts, die die virtualhosts von localen Server spiegeln. Es für die Internet User sichtbar machen

Egal welche Sub ich aus dem Internet aufrufe, es erscheint immer nur die erste Definierte Virtualhost aus dem localem Server.
Wenn ich die localen Domains direkt aufrufe funktionieren sie. Dann sehe ich meine PHP4 scripte.
Wenn ich in meine Virtualhost mod_proxy configurationen irgendwelche externe URL's wie (Google.de,youtube.com usw) angebe statt der localen vhosts, funktionieren diesen auch..
Hab auf dem localen Server nämlich noch php4.x laufen, mit exotischen PHP-Script Sammlung. Die ich mit der zeit umschreiben möchte..
Bin schon fast 500 seiten durchgegangen im Google. Viele Beispiele. Aber keins funktioniert wie gewünscht.

Kann mir jemand helfen..
xNanuNanax
 
Posts: 4
Joined: 19. September 2018 19:46
XAMPP version: 5.6.37-0-VC11
Operating System: Windows 10

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests

cron