Xampp Test

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp Test

Postby Spliffster » 30. September 2004 00:23

Hallo,

ich hätte mal eine Bitte ob ihr mir beim testen meines Xampp behilflich sein könntet. Ich habe mir die ApacheFriends XAMPP (basic package) version 1.4.7 (win32) gezogen, installiert und lokal läuft alles super:

Habe mir nun eine dyndns bei www.ip-active.de zugelegt und hatte das vorhin mit ein paar Kumpels im Teamspeak ausprobiert.

Über der Domain von ip-active: www.ncs-clan.ipme.de konnten sie nicht zugreifen. Allerdings über die IP von meinem Provider.

Jetzt zu meiner Bitte, ob ihr den Server aufrufen könntet um mal zu schauen was passiert. Ich hatte noch Änderungen an der hosts und an der http.conf vorgenommen und es ist nun ein wenig spät geworden und meine Kumpels pennen. :lol:

www.ncs-clan.ipme.de
213.39.217.172

Mein Router ist ein ST Lab und Port hab ich freigeschaltet. IP ist die 192.168.1.1
Mein PC: 192.168.1.2
Windows XP Pro
Hansenet DSL

Im htdocs Ordner liegt eine index.htm als Testdatei.
Root Verzeichniss auf der Festplatte ist: D:\apache\xampp\htdocs

Die hosts Datei:
Code: Select all
127.0.0.1 www.ncs-clan.ipme.de


Auszüge aus der http.conf:

Code: Select all
# Do NOT add a slash at the end of the directory path.
#
ServerRoot "D:/apache/xampp/apache"



# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 127.0.0.1:80
Listen 80


# If your host doesn't have a registered DNS name, enter its IP address here.
# You will have to access it by its address anyway, and this will make
# redirections work in a sensible way.
#
ServerName www.ncs-clan.ipme.de


# UseCanonicalName: Determines how Apache constructs self-referencing
# URLs and the SERVER_NAME and SERVER_PORT variables.
# When set "Off", Apache will use the Hostname and Port supplied
# by the client.  When set "On", Apache will use the value of the
# ServerName directive.
#
UseCanonicalName Off


# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "D:/apache/xampp/htdocs



NameVirtualHost www.ncs-clan.ipme.de:80
<VirtualHost www.ncs-clan.ipme.de:80>
ServerName www.ncs-clan.ipme.de
ServerAlias www.ncs-clan.ipme.de
ServerAdmin deaconfrost@clan-ncs.net
DocumentRoot D:/apache/xampp/htdocs/
</VirtualHost>


Wäre nett wenn ihr mir die Ergebnisse mal posten würdet. Vielleicht sind ja auch noch Fehler in den Dateien.

Danke schon mal im Vorraus.

Gruß
Marco

PS: Über die Domain komm ich auf den Server. Über die IP nicht.
User avatar
Spliffster
 
Posts: 5
Joined: 24. June 2003 19:04

Postby Wiedmann » 30. September 2004 00:43

Scheint zu tun (IP und Domain). Es kommt eine Testseite.

Zuwas ist der VirtualHost eingerichtet?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

vhost

Postby Spliffster » 30. September 2004 00:48

Hi,

thx erstmal für die Anwort so spät. Ich möchte mir noch weitere vhosts einrichten und das dient nur als Test.

So, wenn du noch bereit bist für einen zweiten test. Ich nehme die index.htm und tausche die mal gegen meine aktuelle index.php. Das ging vorhin nämlich nicht.

In der index.php rufe ich die scripte z.B. über:

Code: Select all
 case 'news': case '':
      header('Location: http://localhost/news/index.php');   // Weiterleitung zu den News
      break;

Achso, über was hast du connectet. Über die IP oder der Domain?

Gruß
Marco[/code]
dont walk on gras...smoke it
User avatar
Spliffster
 
Posts: 5
Joined: 24. June 2003 19:04

oh shit

Postby Spliffster » 30. September 2004 00:56

wenn natürlich in der index.php die url per localhost angegeben ist dürftest du nix sehen können. Ich änder das mal eben
dont walk on gras...smoke it
User avatar
Spliffster
 
Posts: 5
Joined: 24. June 2003 19:04

Postby Wiedmann » 30. September 2004 00:57

Achso, über was hast du connectet. Über die IP oder der Domain?

Wiedmann wrote:Scheint zu tun (IP und Domain).


Ich möchte mir noch weitere vhosts einrichten und das dient nur als Test.

Dann mach da folgendes draus:
Code: Select all
NameVirtualHost *:80
<VirtualHost *:80>
ServerName www.ncs-clan.ipme.de:80
ServerAdmin deaconfrost@clan-ncs.net
DocumentRoot "D:/apache/xampp/htdocs"
</VirtualHost>


So, wenn du noch bereit bist für einen zweiten test.

Geht nicht, in deiner "index.htm" ist ein Redirect auf den Server "localhost" drin. Und mein lokaler Server kennt diese URL nicht...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Spliffster » 30. September 2004 00:59

Ich habe die index.htm nun auf index.php geändert. Da sollte eigentlich nun eine Clanseite erscheinen.
dont walk on gras...smoke it
User avatar
Spliffster
 
Posts: 5
Joined: 24. June 2003 19:04

Postby Wiedmann » 30. September 2004 01:03

Da sollte eigentlich nun eine Clanseite erscheinen.

Yep.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

woohoooo :-)

Postby Spliffster » 30. September 2004 01:05

Na Mensch, doch noch alles hinbekommen. Dank Dir für die nächtliche Hilfe :-)

Gruß
Marco :wink:
dont walk on gras...smoke it
User avatar
Spliffster
 
Posts: 5
Joined: 24. June 2003 19:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests