Fehlermeldung nach import einer Datenbank

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehlermeldung nach import einer Datenbank

Postby scaexp » 28. June 2018 13:23

Hallo,
ich habe Xampp 7.1.18 auf Win 10 C: installiert. Nach einem Import einer vorhandenen Datenbank /Drupalwebseite bekomme ich nach einiger Zeit diese Fehlermeldung:
Statische Analyse:
1 Fehler wurden während der Analyse gefunden.
Fehlender Ausdruck. (near "ON" at position 25)
SQL-Befehl: Bearbeiten Bearbeiten
SET FOREIGN_KEY_CHECKS = ON;
MySQL meldet: Dokumentation
#2006 - MySQL server has gone away


Image
Image


Die Empfehlung auf dieser Webseite habe ich auch schon probiert: https://stackoverflow.com/questions/50201874/xampp-phpmyadmin-incorrect-format-parameter
Bitte um Unterstützung
Karl-Heinz
scaexp
 
Posts: 3
Joined: 05. April 2017 13:15
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Fehlermeldung nach import einer Datenbank

Postby scaexp » 30. June 2018 11:48

Hat denn niemand irgendeinen Ansatzpunkt ? :(
scaexp
 
Posts: 3
Joined: 05. April 2017 13:15
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Fehlermeldung nach import einer Datenbank

Postby dschoni » 27. November 2020 20:10

Habe dasselbe Problem.
In der exportierten Datenbank findet sich bei mir kein Befriff mit "SET FOREIGN_KEY_CHECKS = ON;".
Schon gar nicht an Position 25.

Auszug
Position 10:
---
SET FOREIGN_KEY_CHECKS=1;
SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
SET AUTOCOMMIT = 0;
START TRANSACTION;
---
Position 78750:
---
ALTER TABLE `dryz_webform_submission`
MODIFY `sid` int(11) NOT NULL AUTO_INCREMENT, AUTO_INCREMENT=23;
SET FOREIGN_KEY_CHECKS=1;
COMMIT;
---

Habe versucht den Import zu ändern:
1. Export der Struktur und Import auf XAMPP: erfolgreich.
2. Export der Daten einzelner Tabellen und Import. Tabelle 1-20 von 50 erfolgreich, danach hat sich myPHPAdmin verabschiedet, d.h. nicht mehr gemeldet.
Nach einer Stunde oder so habe ich dann F5 gedrückt (Browser-Fenster Refresh). Danach kam myPHPAdmin mit
---
Fatal error: Uncaught TypeError: Argument 2 passed to PhpMyAdmin\Core::arrayWrite() must be of the type array, null given, called in C:\xampp\phpMyAdmin\libraries\classes\Config.php on line 1049 and defined in C:\xampp\phpMyAdmin\libraries\classes\Core.php:677 Stack trace: #0 C:\xampp\phpMyAdmin\libraries\classes\Config.php(1049): PhpMyAdmin\Core::arrayWrite('lang', NULL, 'de') #1 C:\xampp\phpMyAdmin\libraries\classes\Config.php(996): PhpMyAdmin\Config->setUserValue(NULL, 'lang', 'de', 'en') #2 C:\xampp\phpMyAdmin\libraries\common.inc.php(453): PhpMyAdmin\Config->loadUserPreferences() #3 C:\xampp\phpMyAdmin\index.php(27): require_once('C:\\xampp\\phpMyA...') #4 {main} thrown in C:\xampp\phpMyAdmin\libraries\classes\Core.php on line 677
---

Toll, was :)))))

Das Problem liegt an XAMPP. Komplett instabil. Nicht brauchbar für professionellen Einsatz.
Mein Urteil.

Kann leider die Datenbank nicht für Untersuchungen zur Verfügung stellen, da sie Kundendaten enthält.
Aber es sollte für die Entwickler und Supporter gar kein Problem sein, das zu reproduzieren, ausser vielleicht, es sind Bastler ...

Meine Lösung:
Betrieb eines Linux-Webservers.
Import derselben Datenbank ohne jegliches Problem.
dschoni
 
Posts: 1
Joined: 27. November 2020 19:55
XAMPP version: 7.3.2
Operating System: Win 7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests