Problem mit localhost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit localhost

Postby soerenk23 » 21. January 2018 11:26

Hallo,

ich bin neu hier und benutze seit längerem mal wieder xampp für die PHP Programmierung.
Früher hatte ich keinerlei Probleme aber jetzt kann ich über localhost nicht mehr auf meinen Ordner zugreifen.

Gebe ich im Browser localhost/Ordnername ein, leitet mich der Browser auf www.localhost um und sagt, dass der Server nicht gefunden werden konnte.

Ich habe kein Skype installiert und sonst auch an der Installation von Xampp sowie den Ordnern nichts verändert.

Ich habe keine Lösung für das Problem und finde dazu auch nichts im Netz.

Weiß jemand eine Lösung?

Vielen Dank
soerenk23

System: Windows 10 1709 / 16299.192
Xampp: v.3.2.2
Apache PID: 10244 / 3456
Apache Ports: 80, 443
MySQL: PID 8896
MySQL Port: 3306
soerenk23
 
Posts: 3
Joined: 21. January 2018 11:19
XAMPP version: 03.2.2
Operating System: Windows 10

Re: Problem mit localhost

Postby schnegg » 21. January 2018 16:35

Hi, ich bin schnegg.

was Könnte denn Skype mit dem localhost zu tun haben?
schnegg
 
Posts: 13
Joined: 19. January 2018 22:06
XAMPP version: 1.8.3
Operating System: Windows 10

Re: Problem mit localhost

Postby Nobbie » 21. January 2018 17:41

Skype lauscht in der Standardkonfiguration auch auf Port 80 und wenn das vor Apache gestartet wird, kann Apache nicht mehr darauf lauschen und startet nicht. Skype kann man aber konfigurieren, nicht den Port 80 zu benutzen.
Nobbie
 
Posts: 10621
Joined: 09. March 2008 13:04

Re: Problem mit localhost

Postby soerenk23 » 22. January 2018 08:22

Skype ist wie gesagt gar nicht installiert und kann so durch ein blockiertes Port 80 auch nicht das Problem sein, zumal der Apache und MySQL ja gestartet sind.
Es läuft ja alles.
Aber wenn ich im Browser http://localhost/mein Ordner aufrufe springt er nach Enter im Browser auf www.localhost und das wars.
Server nicht gefunden!
soerenk23
 
Posts: 3
Joined: 21. January 2018 11:19
XAMPP version: 03.2.2
Operating System: Windows 10

Re: Problem mit localhost

Postby Nobbie » 22. January 2018 11:42

Normalerweise bedeutet das, dass "localhost" nicht richtig von Windows aufgelöst wird. Früher stand das in der Windows hosts Datei ausdrücklich drin, seit Windows7 (oder noch später) hat Microsoft das im DNS Dienst "verdrahtet" (wegen irgendwelcher Probleme mit IPV6).

Versuche mal statt localhost "127.0.0.1" einzugeben.

Es fällt mir auch noch ein, dass es ein so geartetes Problem mit dem Edge Browser unter Windows 10 gibt, probiere auch mal einen anderen Browser mit "localhost".
Nobbie
 
Posts: 10621
Joined: 09. March 2008 13:04

Re: Problem mit localhost

Postby soerenk23 » 22. January 2018 12:15

Nobbie wrote:Versuche mal statt localhost "127.0.0.1" einzugeben.

Es fällt mir auch noch ein, dass es ein so geartetes Problem mit dem Edge Browser unter Windows 10 gibt, probiere auch mal einen anderen Browser mit "localhost".


Habe ich beides schon versucht. Bringt keine Lösung.

Bei 127.0.0.1 öffnet jeder Browser www.127.0.0.1 und sagt wie bei localhost, Server nicht gefunden.
soerenk23
 
Posts: 3
Joined: 21. January 2018 11:19
XAMPP version: 03.2.2
Operating System: Windows 10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests

cron