Windows 10 xampp mailparse Installation

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows 10 xampp mailparse Installation

Postby paradonym » 04. January 2018 13:44

Ein Composer-Projekt benötigt anscheinend Mailparse um dependencies zu prüfen:
Das Composerprojekt zeigt mittels des Slim-Framework eine Website an, welche auf einem Ubuntu-Server bereits läuft. Die Dateien wurden im Betrieb per SSH auf einen Windows-Computer heruntergeladen.
Diese sollte da sie rein auf PHP basiert auch auf Windows per XAMPP laufen, da alle per Composer installierten Dependencies ja ebenfalls Betriebssystemunabhängig sind und im Projektordner liegen.

Ich kann euch leider keine Details zur Website an sich nennen (da closed source) - sie basiert allerdings ausschließlich aus PHP per Slim Framework, in das ich mich gerade einarbeite.

Da die Website als XAMPP-PHP-Server auf Windows nicht mit Stylesheet angezeigt wird, bin ich auf Fehlersuche gegangen und wollte per installiertem Windows-Composer die dependencies checken:

Code: Select all
PS C:\Users\$USER\Documents\$PROJEKTORDNER> composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - php-mime-mail-parser/php-mime-mail-parser 2.4.3 requires ext-mailparse * -> the requested PHP extension mailparse is missing from your system.
    - php-mime-mail-parser/php-mime-mail-parser 2.4.3 requires ext-mailparse * -> the requested PHP extension mailparse is missing from your system.
    - Installation request for php-mime-mail-parser/php-mime-mail-parser 2.4.3 -> satisfiable by php-mime-mail-parser/php-mime-mail-parser[2.4.3].

  To enable extensions, verify that they are enabled in your .ini files:
    - C:\xampp\php\php.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.


Anscheinend wird Mailparse nicht mit XAMPP 7.2.0 mitinstalliert, daher:
http://wiki.cerbweb.com/Installing_PHP_Mailparse#On_Windows-based_Servers_.28XAMPP.29
- Die entpsrechende DLL von https://downloads.rene-schwarz.com/dc/file/22 heruntergeladen und als C:\xampp\php\ext\php_mailparse.dll hinterlegt.
- Die C:\xampp\php\php.ini angepasst und unter "Dynamic extensions" extension=mailparse hinzugefügt

Nun kann PHP anscheinend nicht mehr starten
Code: Select all
PS C:\Users\$USER\Documents\%PROJEKTORDNER> composer install
PHP Warning:  PHP Startup: Unable to load dynamic library 'mailparse' (tried: C:\xampp\php\ext\mailparse (Das angegebene Modul wurde nicht gefunden.
), C:\xampp\php\ext\php_mailparse.dll (Das angegebene Modul wurde nicht gefunden.
)) in Unknown on line 0


Warum wird die gerade eben installierte mailparse-Extension nicht gefunden?
Last edited by paradonym on 04. January 2018 14:19, edited 1 time in total.
paradonym
 
Posts: 2
Joined: 04. January 2018 13:27
XAMPP version: 7.2.0-0
Operating System: Win10 x64 Enterprise v1703

Re: Windows 10 xampp mailparse Installation

Postby Altrea » 04. January 2018 14:17

Du benötigst die mailparse dll wenn dann schon für PHP 7.2 VC15 thread safe x86.
Meine erste Anlaufstelle wäre die offizielle PECL: https://pecl.php.net/package/mailparse/3.0.2/windows
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9365
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Windows 10 xampp mailparse Installation

Postby paradonym » 04. January 2018 15:07

Code: Select all
PS C:\Users\$USER\Documents\$PROJEKTORDNER> composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files


Ich danke für die schnelle Antwort. Dieses Thema kann als gelöst markiert werden:

Für nachkommende meine Erkenntnis:
php_mailparse.dll ist nicht so frei wie PHP code selbst und an die jeweilige PHP Version gebunden, https://pecl.php.net/package/mailparse/3.0.2/windows enthält Versionen für 7.0 bis 7.2. Für ältere PHP-Versionen habe ich keine Quelle direkt bei PECL gefunden. Eure PHP-Version findet ihr mit
Code: Select all
php --version
in der Kommandozeile raus.
paradonym
 
Posts: 2
Joined: 04. January 2018 13:27
XAMPP version: 7.2.0-0
Operating System: Win10 x64 Enterprise v1703

Re: Windows 10 xampp mailparse Installation

Postby Altrea » 04. January 2018 16:58

Ich danke für deine sehr ausführliche Beschreibung, die eine schnelle Einschätzung samt Lösungsvorschlag erst möglich gemacht haben :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9365
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests