Einrichtung eines vhosts führt zu Fehler 403

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Einrichtung eines vhosts führt zu Fehler 403

Postby afisch » 15. December 2017 15:29

Liebe Gemeinschaft,

ich versuche derzeit, einen virtuellen Host einzurichten, wozu ich die Dateien hosts und httpd-vhosts.conf bearbeitet habe. Resultat: ich bekomme nach Eingabe der URL für den neu angelegten Host einen Fehler 403 zurück. Eine index.html ist im root-Verzeicnhnis vorhanden. Bleibt der Zugriffsschutz, wozu ich aber keine Idee habe, wie man das ändert. Wäre schön, wenn mir dabei jemand helfen könnte.

Schönen Gruß
Axel
afisch
 
Posts: 4
Joined: 15. December 2017 14:56
XAMPP version: v3.2.2
Operating System: Windows 7

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Nobbie » 15. December 2017 21:41

Es gibt bei Zugriffsfehlern die beiden grundsätzlich verschiedenen Codes 403 und 404. Fange ich hinten an:

a) Code 404: das bedeutet einen Zugriffsfehler auf Betriebssystemebene, beispielsweise wenn die gewünschte Datei überhaupt nicht vorhanden ist (einfach "sdlkajsldnlk" im Browser eingeben für eine bestimmte Domain), oder sie ist zwar vorhanden, aber das Betriebssystem erlaubt Apache nicht, die Datei zu lesen. Das kann viele Gründe haben und hängt von Betriebssystem und den Usern und den Dateien und den Rechten ab, die diese User für Dateien haben.

b) Code 403: das bedeutet einen Zugriffsfehler auf Apache Ebene. Apache findet die Datei (und/oder Ordner) und kann sie auch lesen, aber die Konfiguration von Apache ist so gestaltet, dass diese Datei nicht ausgeliefert werden darf. Das kann gewünscht sein, weil es beispielsweise eine Datei mit wichtigen Daten ist (Passwortdateien o.ä.), das ist aber oft unerwünscht und eine Folge einer falschen Konfiguration, weil man aus Versehen Apache so konfiguriert hat, dass er beispielsweise aus bestimmten Verzeichnissen keine Dateien ausliefern darf.

Hier liegt also der zweite Fall vor, die Konfiguration von Apache erlaubt es Apache nicht, aus dem Ordner (wahrscheinlich aus dem DocumentRoot - leider nennst Du uns keine URL und nichts, rein gar nichts) Dateien auszuliefern. Da Du einen VirtualHost eingerichtet hast würde ich vermuten, dass Du dort einen eigenen DocumentRoot angegeben hast, aber Du hast nirgends konkrete Angaben gemacht, ob und was Apache daraus ausliefern darf. Xampp kommt ja vorkonfiguriert ohne VirtualHosts und ist eingerichtet, dass er aus c:/xampp/htdocs als DocumentRoot an jeden User alles ausliefern darf. Wahrscheinlch hast Du für Deinen VirtualHost einen anderen DocumentRoot festgelegt, hast aber überhaupt keine Angaben getroffen, ob Apache überhaupt Dateien aus diesem Ordner (welchen?) ausliefern darf. Im Default (wenn man nichts unternimmt) darf Apache dann nichts ausliefern (das ist die Defaulteinstellung von Xampp), das ist ein wichtiger Schutz des Servers, damit man von außen nicht einfach irgendwelche Ordner angeben kann und herumschnüffelt.

Mangels jeglicher Dokumentation ist eine weitere Analyse nicht möglich, aber mit diesen Erklärungen solltest Du selbst in der Lage sein zu finden, wo das Problem liegt.
Nobbie
 
Posts: 9885
Joined: 09. March 2008 13:04

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby afisch » 17. December 2017 19:10

Besten Dank, Nobbie, für die Erläuterungen. In der Tat versuche ich, für eine weitere Test-Site (nur lokal, kein Zugriff von außen) einen zusätzlichen document-root anzulegen, was ja auch laut der vielen Ableitungen im Netz kein großes Problem sein soll. Die von dir angesprochenen Ausgabeeinschränkungen sind natürlich gut nachvollziehbar. Aber wo muss ich nun gegebenenfalls XAMPP (und nur XAMPP?) konfigurieren? Aber selbstverständlich schließe ich auch nicht einen dieser Flüchtigkeitsfehler aus...

Hier ein paar mehr Infos zum Stand meiner Dinge (es sind hoffentlich die richtigen, andernfalls fragt ihr ja nach...)
  • XAMPP habe ich unter D:/xampp/ installiert
  • in der Datei httpd-vhosts.conf unter XAMPP habe ich als letztes angehangen
    Code: Select all

    NameVirtualHost *:80

    <VirtualHost *:80>
        DocumentRoot "D:/xampp/htdocs/kobalos/web"
        ServerName localhost
    </VirtualHost>
    <VirtualHost *:80>
        DocumentRoot "D:/xampp/htdocs/kobalos_test"
        ServerName test.local
    </VirtualHost>
  • In der Datei hosts unter Windows habe ich an letztes eingetragen:
    Code: Select all
    127.0.0.1      localhost
    127.0.0.1      test.local
  • Im D:/xamp/htdocs/kobalos_test/ liegt zu Checken eine index.html

Danach sollten ja eigentlich die root-Verzeichnisse erreichbar sein, aber nach wie vor klappt das alles anstandslos nur für die Browsereingabe localhost, für test.local bekomme ich nach wie vor nur einen Fehler 403 ausgewiesen.

Die Eigenschaften des Verzeichnisses /kobalos_test erscheinen mir ganz in Ordnung, es ist auf jeden Fall für die betroffenen Windows-Benutzer als Besitzer oder mit Lesen/Schreiben-Berechtigung eingestellt.

Wenn jemand eine Idee hat - ich würd´ mich freuen...

Schöne Grüße
Axel
afisch
 
Posts: 4
Joined: 15. December 2017 14:56
XAMPP version: v3.2.2
Operating System: Windows 7

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Nobbie » 17. December 2017 19:38

afisch wrote:<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/kobalos_test"
ServerName test.local
</VirtualHost>


Genau das habe mich mir gedacht. Nullkommanull Angaben, welche Rechte für htdocs/kobalos_test gelten. Und dann reicht es leider nicht, Apache ist nicht in der Lage, die Dateien auszuliefern, es wurde ihm verboten.

afisch wrote:Die Eigenschaften des Verzeichnisses /kobalos_test erscheinen mir ganz in Ordnung, es ist auf jeden Fall für die betroffenen Windows-Benutzer als Besitzer oder mit Lesen/Schreiben-Berechtigung eingestellt


Oh schade, war alles für die Katz bisher. Genau das hatte ich gehofft, dass ich das erklären könnte, das liegt NICHT DARAN, DASS IRGENDWELCHE BENUTZER FEHLENDE RECHTE HABEN, es liegt NICHT am Rechtesystem des Betriebssystems. Das war der einzige Sinn meines Beitrags, diese Unterschiede aufzuzeigen. Es liegt daran, dass Apache falsch konfiguriert ist und Du Apache nicht erlaubst, die Dateien auszuliefern.

Ich weiß, dass Du darauf hoffst, dass ich Dir die fertige Konfiguration zeige. Aber leider tue ich so etwas nicht. Schau Dir an, was Xampp an Voreinstellungen für den DocumentRoot mitbringt, insbesondere schaue auf "Require" Statements. Da reicht es schon, wenn Du das abkupferst. Aber zum Verständnis empfiehlt es sich, auch die Dokumentation dazu zu lesen, die findet man hier https://httpd.apache.org/docs/2.4/mod/m ... _core.html
Nobbie
 
Posts: 9885
Joined: 09. March 2008 13:04

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Altrea » 18. December 2017 01:30

Hi,

Nobbie wrote:Genau das habe mich mir gedacht. Nullkommanull Angaben, welche Rechte für htdocs/kobalos_test gelten. Und dann reicht es leider nicht, Apache ist nicht in der Lage, die Dateien auszuliefern, es wurde ihm verboten.

Wenn ich davon ausgehe, dass D:\xampp\ das Installationsverzeichnis von XAMPP ist, so dürfte für D:\xampp\htdocs\ und alle Unterordner (sofern nicht anders defiiert) die Standardeinstellung aus der httpd.conf greifen, also Require all granted.

Das Problem muss also anders wo zu finden sein.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9011
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Nobbie » 18. December 2017 10:32

Altrea wrote:Das Problem muss also anders wo zu finden sein.


Stimmt eigentlich, aber es ist dennoch 403er Fehler. Wahrscheinlich in httpd.conf auch einfach die Directory Klausel von htdocs auf htdocs/kobalos/web angepasst (wäre ja plausibel) und dann fehlt die Require Klausel für den anderen DocumentRoot. Irgendso etwas wird es sein.
Nobbie
 
Posts: 9885
Joined: 09. March 2008 13:04

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby afisch » 18. December 2017 14:05

Merci fürs Kümmern - habs ans Laufen bekommen.
Gruß, Axel
afisch
 
Posts: 4
Joined: 15. December 2017 14:56
XAMPP version: v3.2.2
Operating System: Windows 7

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Altrea » 18. December 2017 15:12

Denkst du nicht, dass du beschreiben solltest was jetzt letztendlich das Problem war und wie du es gelöst hast?

Schließlich kannst du hier kostenlos nach Hilfe fragen, ausgebildete IT Experten haben ihre Freizeit darin investiert sich damit zu beschäftigen um das Problem zu identifizieren und zu lösen.

Ich denke es ist das mindeste hier Informationen zu hinterlassen, damit andere Hilfesuchende mit demselben Problem durch deinen Beitrag eine Lösungsmöglichkeit haben. Denn von soetwas lebt ein Community Forum.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9011
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Nobbie » 18. December 2017 20:40

Altrea wrote:Denkst du nicht, dass du beschreiben solltest was jetzt letztendlich das Problem war und wie du es gelöst hast?


Gutes Benehmen ist fremd in Foren, jeder glaubt, man hätte ein Anrecht auf kostenlose Hilfe. Die Hoffnung habe ich lange aufgegeben, dass jemand mal etwas zurückgibt. Und wenn ich ehrlich bin - brauche ich auch nicht. Im hier geschehenen Rahmen würde ich jedem anderen auch wieder helfen, wenn es geht, es geht eben nicht immer. Dieser Thread ist übrigens ein schönes Beispiel dafür, dass WIR BEIDE gut zusammen arbeiten: was ich übersehen habe, hast Du bemerkt und ich bin mir ziemlich sicher, dass die dann skizzierte Problematik auch getroffen hat.

Aber das versteht außer uns (und ein paar wenigen wertvollen Helfern mehr) keiner. Schon gar nicht so Egoisten wie hier. Unsere Mühe wird als selbstverständlich empfunden, mehr noch, wahrscheinlich ist der Troll auch noch beleidigt, dass ich ihm das Problem nicht auch noch mundgerecht serviert habe. Wie unglaublich schwierig es ist, "Remote" Hilfe zu leisten, können sich so Trolle sowieso nicht vorstellen. Die kennen nur ihre eigene kleine Welt. Schwamm drüber, wenn man sich darüber ärgert, müßte man konsequenterweise hier aufhören.
Nobbie
 
Posts: 9885
Joined: 09. March 2008 13:04

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby afisch » 19. December 2017 17:58

Denkst du nicht, dass du beschreiben solltest was jetzt letztendlich das Problem war und wie du es gelöst hast?


Völlig richtig, und ich hatte ehrlich gesagt schon ein schlechtes Gewissen. Also:

Nobbie liegt gar nicht so verkehrt mit seiner Vermutung:

Wahrscheinlich in httpd.conf auch einfach die Directory Klausel von htdocs auf htdocs/kobalos/web angepasst (wäre ja plausibel) und dann fehlt die Require Klausel für den anderen DocumentRoot.


Man müsste das "auch einfach" streichen, denn die Änderungen in der httpd.conf habe ich nicht etwa quasi doppelt gemoppelt in einem Zuge mit verändert, sondern die sind wohl schon vor längerer Zeit beim Installieren des Website-Programms mit erledigt worden - man möge mir verzeihen, wenn mir dieser Umstand jetzt nicht mehr präsent war. Der Ein oder Andere wird jetzt vielleicht schon das bei mir genutzte CMS erraten: Contao, das meines Wissens ab v4.x.x als document root ein bestimmtes Unterverzeichnis des Projektordners voraussetzt.
Im Zusammenhang mit der Einrichtung von vhosts las ich dann (ich würde gerne hier die Quelle angeben, wenn ich sie jetzt noch wüsste...), dass die Angaben in der httpd.conf durch die in der httpd-vhosts.conf ersetzt würden. Das habe ich fälschlicherweise so interpretiert, dass die httpd.conf-Angaben komplett ignoriert werden, und nicht so, dass die Eigenschaften offensichtlich veerbt werden und nur die expliziten Details in der httpd-hosts.conf überschrieben werden - wenn mans weiß, ist das leicht nachzuvollziehen.

Ich habe also nun:
- das root-Verzeichnis in der httpd.conf auf D://xampp/htdocs zurückgesetzt, mit den Anweisungen AllowOverride All, Require all granted und Options Indexes FollowSymLinks Includes ExecCGI für dieses Verzeichnis.
- in der httpd-vhosts.conf für die gewünschten/geforderten virtuellen Hosts die Angaben der Servernamen und der document roots eingegeben, ohne weitere Spezifikationen von Zugriffsrechten.

Diese Konstellation läuft bislang auch ohne Komplikationen. Ob sie nun wirklich richtig und sinnig sind (für eine eventuelle Nachahmung), das mögen nun wiederum andere beurteilen...

Das mag fürs Erste reichen an Informationen, andernfalls fragt bitte nach. Und auch an dieser Stelle noch einmal ausdrücklich meinen Dank für die Informationen, die ich nicht nur hier zur Lösung nicht nur in dieser Situation erhalten habe.

Eins muss ich allerdings doch noch richtigstellen: wenn man auf meinen Namen guckt, könnte man vielleicht drauf kommen, dass ich ein Fisch sei. Aber ein Troll bin ich ganz sicher nicht. Und schon gar nicht was hier mit diesem Begriff so alles konnotiert ist - in diesem Punkt muss sich Nobbie vertan haben.


Schöne Grüße
Axel
afisch
 
Posts: 4
Joined: 15. December 2017 14:56
XAMPP version: v3.2.2
Operating System: Windows 7

Re: Einrichtung eines vhosts führt zu Fehler 403

Postby Nobbie » 19. December 2017 21:06

afisch wrote: in diesem Punkt muss sich Nobbie vertan haben.


Das ist eben das Problem, wenn man sich so präsentiert. Ohne Altreas und meinem massiven EIngreifen hättest Du den letzten Beitrag ganz sicher nie geschrieben (hast Du von alleine ja auch nicht), und leider verbindet man so ein Verhalten nicht sehr positiv. Immerhin (und das wird Dir sicherlich zu Gute zu halten sein) hast Du im Nachgang dann doch die richtigen Worte gefunden. Aber warum es nur geht, wenn man den Knüppel herausholt? Das werde ich nie verstehen. Wenn Altrea das Thema nicht angesprochen hätte, hätte ich gar nichts geschrieben und meine persönlichen Schlussfolgerungen für mich gezogen. Irgendwann führt das dazu, dass Dir niemand mehr hilft - warum auch?
Nobbie
 
Posts: 9885
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests