Virtual hosts und ungewollte Weiterleitung auf Dashboard

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 10. April 2017 12:41

Hallo zusammen,

ich bin neu hier. Habe gerade die aktuellste Version von XAMPP 7.1.1 unter Windows 10 (direkt auf C:) installiert. Läuft soweit. Leider habe ich es nicht geschafft, mein Arbeitsverzeichnis als virtuellen Host einzurichten und über den Browser aufzurufen. Ich lande immer auf dem Dashboard.

Benutze aktuell nur html/css/js - starte also nur den Apache.

httpd.conv
(unverändert gelassen):
Code: Select all
# Virtual hosts
Include conf/extra/httpd-vhosts.conf

C:\Windows\System32\drivers\etc\hosts
(mit Administrator Rechten ergänzt):
Code: Select all
127.0.0.1 myfolder

C:\xampp\apache\conf\extra\httpd-vhosts.conf
Code: Select all
#localhost
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
    <Directory "C:/xampp/htdocs">
        Options All
        AllowOverride All
      Require all granted
    </Directory>
</VirtualHost>

<VirtualHost myfolder:80>
    DocumentRoot "C:/Users/myname/My%Path/myfolder"
    ServerName myfolder
   ErrorLog "logs/myfolder-error.log"
    CustomLog "logs/myfolder-access.log" combined
    <Directory "C:/Users/myname/My%Path/myfolder">
        Options All
        AllowOverride All
      Require all granted
    </Directory>
</VirtualHost>


Saß jetzt 2 Stunden an dem Problem und komme nicht weiter. Habt ihr mir einen Tipp?

Danke und Gruß,
nickprota
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby Altrea » 10. April 2017 15:44

nickprota wrote:
Code: Select all
<VirtualHost myfolder:80>

Lass das sein.
Benutze immer <VirtualHost *:80> es sei denn du hast gute Gründe es nicht zu tun.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8730
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 11. April 2017 08:48

Danke für den Hinweis. Da ich nicht weiß, wie man einen Apache einrichtet, sind dies bei Google gefundene Codeschnipsel.

Ich habe *:80 eingetragen, das Problem besteht aber weiterhin. Wenn ich den kompletten Pfad inkl. /index.html eingebe, kommt eine 404 Seite.
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 11. April 2017 08:58

Noch ein Hinweis:
Ich habe in meinem Pfad Leerzeichen drin, die ich in der vhosts.conf durch %20 ersetze.
Den Namen kann ich wegen Sync und Sharing leider nicht so einfach ändern.
Das habe ich als Ursache aber ausgeschlossen, indem ich temporär auf einen Ordner ohne Leerzeichen verwiesen habe. Dort hatte ich denselben Effekt: Weiterleitung aufs XAMPP Dashboard bzw. 404 Seite beim direkten Aufruf der index.html über die URL.
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby Altrea » 11. April 2017 17:00

nickprota wrote:Ich habe in meinem Pfad Leerzeichen drin, die ich in der vhosts.conf durch %20 ersetze.

Das ist Mumpitz. Pfade mit Leerzeichen werden einfach mit doppelten Leerzeichen eingeschlossen.

Mehr kann man an Hand deiner Angaben nicht sagen. Auf meiner Testumgebung funktioniert die Konfiguration.

hosts
Code: Select all
test    127.0.0.1


httpd-vhosts.conf
Code: Select all
#localhost
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
    <Directory "C:/xampp/htdocs">
        Options All
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>

#test vhost
<VirtualHost *:80>
    DocumentRoot "C:/Users/Altrea/Test Ordner/htdocs"
    ServerName test
    ErrorLog "logs/myfolder-error.log"
    CustomLog "logs/myfolder-access.log" combined
    <Directory "C:/Users/Altrea/Test Ordner/htdocs">
        Options All
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>


Da du aber soviele Pfade maskiert hast muss ich davon ausgehen, dass das Problem in den von dir maskierten Daten steckt.
Eine andere mögliche Fehleruraache wäre die Konfiguration deiner Anwendung selbst, eine Weiterleitung, falsche URL Konfiguration etc. Auch das kannst nur du allein wissen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8730
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby Nobbie » 12. April 2017 00:28

nickprota wrote:Ich habe in meinem Pfad Leerzeichen drin, die ich in der vhosts.conf durch %20 ersetze.


Aber nicht hier im Forum, da steht nur % drin, ohne 20 dahinter. Entweder ist da auch ein Fehler, oder Du zeigst hier nicht reale Daten. Im letzteren Fall gebe ich grundsätzlich keine Hilfestellung mehr, in allzu vielen Fällen wird die reale Fehlerursache verschleiert.
Nobbie
 
Posts: 9441
Joined: 09. March 2008 13:04

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 12. April 2017 11:00

Nobbie wrote:
nickprota wrote:Ich habe in meinem Pfad Leerzeichen drin, die ich in der vhosts.conf durch %20 ersetze.

Aber nicht hier im Forum, da steht nur % drin, ohne 20 dahinter. Entweder ist da auch ein Fehler, oder Du zeigst hier nicht reale Daten. Im letzteren Fall gebe ich grundsätzlich keine Hilfestellung mehr, in allzu vielen Fällen wird die reale Fehlerursache verschleiert.


Mann, seid ihr krass drauf. Habe mich in meinem Post sehr bemüht, alle relevanten Codestellen zu kopieren. Natürlich habe ich dann meinen Namen und andere Informationen des Pfades ersetzt, dabei ist wahrscheinlich aus Versehen die 20 verschwunden. Zum Punkt Leerzeichen habe ich bereits geschrieben, das ich testweise auf einen Ordner ohne Leerzeichen verwiesen habe, das hat ebenfalls nicht funktioniert.

Ich habe außer den im ersten Post beschriebenen Punkten überhaupt nichts an XAMPP verändert, das ist eine frisch installierte Version und der erste und einzige benutzte Server auf dem Rechner überhaupt.
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 12. April 2017 11:05

Altrea wrote:
nickprota wrote:Ich habe in meinem Pfad Leerzeichen drin, die ich in der vhosts.conf durch %20 ersetze.

Das ist Mumpitz. Pfade mit Leerzeichen werden einfach mit doppelten Leerzeichen eingeschlossen.


Ich habe deine Antwort nicht komplett verstanden, interpretiere aber anhand deines Beispiels, dass Leerzeichen kein Problem sind. Ich habe also den Pfad nun so geschrieben:
"C:/Users/myname/my folder/folder/folder"

Schön, das es bei dir funktioniert. Bei mir nicht :/

Gibt es außer der Änderung in C:\Windows\System32\drivers\etc\hosts noch irgendwelche Windows-Stellen, die ursächlich sein könnten?
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby Altrea » 12. April 2017 15:56

nickprota wrote:interpretiere aber anhand deines Beispiels, dass Leerzeichen kein Problem sind.

In diesem Teil der Konfiguration sind Leerzeichen in Pfaden kein Problem.
Sofern man darauf verzichten kann sollte man natürlich trotzdem wo es geht darauf verzichten.

nickprota wrote: Ich habe also den Pfad nun so geschrieben:
"C:/Users/myname/my folder/folder/folder"

Schön, das es bei dir funktioniert. Bei mir nicht :/

Das ist aber kein Problem des Leerzeichens im Pfad. Du hasr ein Problem damit, dass der vhost nicht trifft oder eine Umleitung ausgeführt wird.

Ping doch mal die Domain an die nicht trifft. Vielleicht wird sie ja nicht korrekt aufgelöst.
Du könntest auch mal Apache in der Eingabeaufforderung starten mit "httpd.exe -t -D DUMP_VHOSTS" (httod.exe befindet sich im apache/bin Ordner)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8730
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 13. April 2017 09:39

Pingen war kein Problem, hat funktioniert für localhost und myfolder.
Ist es normal, dass ping auch funktioniert, ohne dass der Apache läuft?

Code: Select all
C:\Users\myname>ping myfolder

Ping wird ausgeführt für myfolder [127.0.0.1] mit 32 Bytes Daten:
Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128
Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128

Ping-Statistik für 127.0.0.1:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 13. April 2017 09:44

Start über Eingabeaufforderung:

Code: Select all
C:\Users\myname>C:\xampp\apache\bin\httpd.exe -t -D DUMP_VHOSTS
VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server localhost (C:/xampp/apache/conf/extra/httpd-vhosts.conf:45)
         port 80 namevhost localhost (C:/xampp/apache/conf/extra/httpd-vhosts.conf:45)
         port 80 namevhost myfolder (C:/xampp/apache/conf/extra/httpd-vhosts.conf:55)
*:443                  www.example.com (C:/xampp/apache/conf/extra/httpd-ssl.conf:121)
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby nickprota » 13. April 2017 09:50

Habe gerade festgestellt, dass nur Chrome beim Eintrag von "myfolder" auf "https://myfolder/dashboard/" weiterleitet (https ist durchgestrichen)! Firefox, IE und Edge rufen die Suchmaschine des Browsers auf.
XAMPP 7.1.1, Windows 10 Pro 64bit, Surface Book
User avatar
nickprota
 
Posts: 8
Joined: 10. April 2017 12:26
XAMPP version: 7.1.1
Operating System: Windows 10

Re: Virtual hosts und ungewollte Weiterleitung auf Dashboard

Postby Altrea » 13. April 2017 20:37

Und was passiert bei http://myfolder/ ?
Und ja, es ist normal dass ping auch ohne Apache funktioniert. Der Ping wird direkt vom Netzwerkadapter oder Loopback Adapter beantwortet.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8730
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests