FastCGI & phpMyAdmin [Howto]

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

FastCGI & phpMyAdmin [Howto]

Postby eCom » 01. March 2017 14:54

Aktuelles Betriebssystem Win10, Xampp 7.1.1

Installation verlief wie gewohnt normal, System läuft einwandfrei.
Sowohl phpMyAdmin als auch die Webseiten sind einwandfrei aufzurufen.

Dennoch benötige ich FastCGI (bevor jetzt irgendwelche süffisanten Fragen dazu kommen - es ist so!).

Um FastCGI im Xampp 7.1.1 zu aktivieren, gibt es über das neue Dashboard einen feinen Link:
http://localhost/dashboard/docs/use-php-fcgi.html

Soweit so gut, möchte man aber mit laufendem FastCGI phpMyAdmin aufrufen, wird das angezeigt:
Zugriff verweigert!

Neues XAMPP Sicherheitskonzept:

Der Zugriff auf das angeforderte Objekt ist nur aus dem lokalen Netzwerk möglich.

Diese Einstellung kann in der Datei "httpd-xampp.conf" angepasst werden.


Und das ist es auch schon, so quasi 'LmiA'.

Was denn aber ist so eine URL: http://localhost/phpmyadmin
Ist sicher was von irgendwo, nur nicht lokal - oder??

Denn nirgends wird be-/ bzw. geschrieben was jetzt zu tun wäre und welche tolles 'Neues Sicherheitskonzept' das denn jetzt wäre.
Auch die Suche hier im Forum bringt nichts wirklich brauchbares, im Gegenteil - Meldungen dazu/darüber sind äußerst spärtlich.

Anyway, gibt ja auch noch das Internet und Suchmaschinen - wiewohl die Lösung mindestens hier irgendwo stehen sollte.
Die Lösung brachte dann dieser Eintrag bei stackoverflow: http://stackoverflow.com/a/34965810/3450837

Hier noch was angepasst werden muss (in der http-xampp.conf im Verzeichnis ..apache/conf/extra/:

Anstatt:
Code: Select all
    Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
    <Directory "D:/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>


das hier oder ausbessern:
Code: Select all
    Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
    <Directory "D:/xampp/phpMyAdmin">
       Options ExecCGI   
        AllowOverride AuthConfig
        Require all granted       
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </Directory>


Wichtig sind diese 2 Zeilen hier:
Code: Select all
Options ExecCGI   
Require all granted


Server neu starten - und somit funktioniert auch phpMyAdmin wieder.

Nachsatz: es wäre nett (!!) wenn die Macher von Xampp auch in der mitgelieferten Dokumentation das ergänzen würden bzw. in dem Bereich über FastCGI dazu schreiben würden was alles in allem zu machen ist.
eCom
 
Posts: 1
Joined: 01. March 2017 14:29
XAMPP version: 7.1.1
Operating System: Win10

Re: FastCGI & phpMyAdmin [Howto]

Postby Nobbie » 01. March 2017 15:26

eCom wrote:Nachsatz: es wäre nett (!!) wenn die Macher von Xampp auch in der mitgelieferten Dokumentation das ergänzen würden bzw. in dem Bereich über FastCGI dazu schreiben würden was alles in allem zu machen ist.


Dann schreibe eine Email an Bitnami, das sind die "Macher von Xampp". Sitzen übrigens in San Francisco.
Nobbie
 
Posts: 9760
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests