MYSQLI Probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: MYSQLI Probleme

Postby Altrea » 14. December 2016 17:43

Du kannst mir sagen was du willst, aber so ganz rund ist deine Fehlerbeschreibung nicht.

Ich habe mir deine phpinfo Ausgabe mal genau angesehen. Der relevante Teil ist dieser hier:
mysqli
MysqlI Support
enabled

Client API library version
mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $
Active Persistent Links
0
Inactive Persistent Links
0
Active Links
0
Directive
Local Value
Master Value
mysqli.allow_local_infile
On
On
mysqli.allow_persistent
On
On
mysqli.default_host
no value
no value
mysqli.default_port
no value
no value
mysqli.default_pw
no value
no value
mysqli.default_socket
no value
no value
mysqli.default_user
no value
no value
mysqli.max_links
Unlimited
Unlimited
mysqli.max_persistent
Unlimited
Unlimited
mysqli.reconnect
Off
Off
mysqli.rollback_on_cached_plink
Off
Off
mysqlnd
mysqlnd
enabled
Version
mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $
Compression
supported
core SSL
supported
extended SSL
not supported
Command buffer size
4096
Read buffer size
32768
Read timeout
31536000
Collecting statistics
Yes
Collecting memory statistics
Yes
Tracing
n/a
Loaded plugins
mysqlnd,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password
API Extensions
mysqli,pdo_mysql
mysqlnd statistics

Dort siehst du ziemlich genau, dass mysqli aktiviert ist (und damit auch die Funktion mysqli_connect()). Es sind auch nahezu alle Einstellungen mit meiner Testumgebung identisch, mit einer einzigen Ausnahme: In deiner Konfiguration ist der mysqli default port nicht gesetzt. Dies erklärt aber nicht weshalb deine Funktion mysqli_connect() nicht existieren soll.

Technisch gesehen ist deine Fehlermeldung quasi fast unmöglich. Selbst wenn ich den Aufruf in einen anderen Namensraum oder einer anderen Klasse kapsele kann ich ohne Namensraum Qualifizierung diese Funktion noch fehlerfrei ansprechen. Daher ist Nobbies Skepsis hier durchaus angebracht.

Es gibt drei Möglichkeiten:
1. Irgendetwas in deiner Fehlerbeschreibung ist falsch oder fehlt.
2. Du hast irgendeine Art PHP oder dessen Funktionen zu verwenden, die wir nicht kennen.
3. Du hast einen Bug im PHP Core gefunden den bisher niemand anders beobachtet hat.

Die mir wahrscheinlichste Ursache ist für mich 1. (einfach aus Erfahrung). Das muss nichtmal absichtlich passieren, es würde zum Beispiel schon genügen, dass du deinen PHP-Code (oder zumindest den relevanten Teil) in einer Zeichenkodierung gespeichert hast, den PHP nicht lesen kann.
Nur mit den Informationen die uns von dir hier vorliegen, können wir dein Problem nicht analysieren.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8845
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MYSQLI Probleme

Postby Nobbie » 14. December 2016 21:12

Daywalker4868 wrote:Auch nach der Neuinstallation von XAMPP besteht das Problem weiterhin :cry: :cry: :cry:


Spricht umso eher dafür, dass Du einen Fehler im Script hast. Die Idee, dass da ggf. auch ein falscher Zeichencode das Problem sein könnte, habe ich auch schon gehabt. Aber ich habe die Scripts per copy&paste getestet, wenn sie auch via copy&paste hier eingefügt wurden, ist auch der falsche Zeichencode unwahrscheinlich.

Da ich es aber so oder nicht mag, dass man mir veränderte Scripts und Fehlermeldungen zeigt (s.o. - doppelte Leerstelle), bin ich (wie versprochen) hier raus. Viel Glück!

P.S.: Auch die höchst oberflächliche und unzureichende Beschreibung "besteht das Problem weiterhin" ist nicht ohne gewissen Humor. Welches Problem?? Immerhin haben wir hier mindestens drei(!) verschiedene(!) Scripts, die sich an der entscheidenden Stelle unterscheiden und mit absoluter Sicherheit ist es vollkommen unmöglich, dass alle drei Varianten mit der gleichen Fehlermeldung beendet werden. Unabhängig davon, dass wir die aktuelle Fehlermeldung (welche?) zum aktuellen Script (welches?) eben genau nicht kennen, es ist UNMÖGLICH, dass alle Varianten an der gleichen Hürde scheitern.

Schau in Deinem Kuddel-Muddel danach, dass die notwendige Ordnung einzieht und der ganze Sachverhalt wird sich in Wohlgefallen auflösen.
Nobbie
 
Posts: 9557
Joined: 09. March 2008 13:04

Re: MYSQLI Probleme

Postby Daywalker4868 » 15. December 2016 12:41

Du kannst den Fehler jetzt auch online sehen.
Demnach hast du Recht, dass der Fehler nicht von XAMPP ausgeht, sondern am Script liegen muss.

Link zum Script:
http://www.hp-drees.de/Psycho/Psycho/test.php

Code: Select all
<?php

$hosti = "localhost";
$nutzi = "*********";
$passwi = "**********";
$dbi = "*********";

if ($db = mysqli_connect("$hosti", "$nutzi", "$passwi") or die("cannot select DB. Please contact us"))
{
  $sqli = "SELECT LMAIL from login";
  if ($ergebnis = mysqli_query($db,$sqli))
    {
    echo "<ul>";
    while ($zeile = mysqli_fetch_assoc($ergebnis))
      {
      echo "<li>" . htmlspecialchars($zeile["LMAIL"])  . "</li>";
      }
    echo "</ul>";
    mysqli_close($db);
    }
  }

?>


Das ist definitiv der Code, der jetzt auch online läuft. Ich habe nur hier im Script die Anmeldedaten rausgenommen.
Daywalker4868
 
Posts: 10
Joined: 11. December 2016 18:38
XAMPP version: 7.0.9
Operating System: Windows 10

Re: MYSQLI Probleme

Postby Nobbie » 15. December 2016 12:51

Das mag der Code sein - aber ist das jetzt Xampp?? Das ist ja ein Linux-Server, Du hast aber angeblich eine Windows Xampp installation. Wahrscheinlich läuft auf dem Server http://www.hp-drees.de eine andere PHP Version (und sowieso kein Xampp). Ob da mysqli aktiv ist, das weiß ich natürlich nicht (anscheinend nicht). Bau mal einen phpinfo() vor dem mysqli_connect() ein, um wieviel sollen wir wetten, dass das eine vollkommen andere Installation ist als Windows Xampp 7.0.9?

P.S.: Wenn Du auf deinem Xampp Rechner Änderungen in test.php machst, dann benenne das Script mal um (test2.php, test3.php usw.). Möglicherweise bekommst Du vom Browser seit Tagen eine alte Version aus dem Cache geliefert, die gar nicht mit der Realität übereinstimmt. Wenn Du den Scriptnamen änderst, kann das nicht passieren. Ist eine ganz beliebte Fehlersituation, wo Entwickler die Welt nicht mehr verstehen....
Nobbie
 
Posts: 9557
Joined: 09. March 2008 13:04

Re: MYSQLI Probleme

Postby Daywalker4868 » 15. December 2016 12:57

Hi,
liesst du auch ab und an was ich schreibe?

Na klar liegt es jetzt auf einem Webserver mit Linux und nicht auf XAMPP.

Ich schrieb ja, dass es an meinem Script liegen muss.

Ihr könnt das Thema schliessen, ich habe keinen Nerv mehr auf den Firlefanz hier.

Fakt ist. AN XAMPP liegt es nicht.

Ich wünsche euch aber ein frohes Weihnachtsfest und einen guten Rutsch ins neue Jahr.

Gruss
Thorsten
Daywalker4868
 
Posts: 10
Joined: 11. December 2016 18:38
XAMPP version: 7.0.9
Operating System: Windows 10

Re: MYSQLI Probleme

Postby Nobbie » 15. December 2016 13:17

Du hast nix von Linux geschrieben, wo soll ich das lesen? Und wo steht, dass auf dem Server mysqli aktiviert ist? Mach mal nicht so auf dicke Hose. Ich lese sehr genau, was geschrieben wird.

Mit einiger SIcherheit liegt es daran, dass Du in irgendeinem komischen Editor (welcher?) im Script ein nicht-sichtbares Zeichen vor mysqli_connect() stehen hast, welches hier im Forum nicht angezeigt wird. Kopier mal den Inhalt hier aus dem Forum in ein neues Script test2.php, das wird laufen.

Mir fällt immer noch auf, dass in der Fehlermeldung anscheinend 2 Leerstellen zwischen "function" und "mysqli_connect()" stehen, wahrscheinlich wird das hier Forum so dargestellt (weil das nicht-druckbare Zeichen sind), aber in echt scheint da irgendein Sonderzeichen zu stehen, was auch bei Dir so nicht erkennbar ist. Wenn Du einen sog. Binäreditor besitzt, könntest Du genau anzeigen lassen, was in dem Script steht, eine andere Idee habe ich nicht mehr. Aber probier es wenigstens nochmal aus, exakt das hier abgebildete Script in eine neue test2.php einzugeben (mit copy&paste und in einem vernünftigen Texteditor, auf keinen Fall Word oder sowas nehmen, das habe ich alles schon erlebt). Lass auch die Sternchen stehen, dann gibt es halt eine Fehlermeldung, dass der Connect nicht klappt, aber es geht nur darum, dass die Funktion vorhanden ist und wieso sie nicht gefunden wird.
Nobbie
 
Posts: 9557
Joined: 09. March 2008 13:04

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests